[SRU Regression] Launcher icon corruption while rearranging.

Bug #1071813 reported by Marco Scannadinari on 2012-10-26
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Nick Dedekind
6.0
Fix Released
High
Nick Dedekind
unity (Ubuntu)
High
Nick Dedekind
Quantal
High
Nick Dedekind

Bug Description

[Test Case]
1. Make sure there are a few icons on the Launcher
2. Start dragging (changing the position) of the icons on the Launcher
   -> Make sure that the dragged icon looks normally, has no graphical issues and artifacts (see screenshots)
3. Repeat step 2 a few times

[Regression Potential]
Broken launcher icon textures, blank icons.

Original description:

Hi,
When dragging an icon on the Unity panel, some random broken text and other iocons from the launcher layer themselves on top of the icon I am dragging, like so:
http://i50.tinypic.com/106amuf.png
http://i50.tinypic.com/oruv0j.png
http://i49.tinypic.com/2mfj3sx.png

Sapphire AMD Radeon HD 6570 with ubuntu-packaged fglrx driver.
QUANTAL

----
Additional notes:
- Has been confirmed with open source radeon drivers (so this might not be fglrx related)
- Downgrading nux back to 3.8.0-0ubuntu1 seems to fix this issue (so this is a regression in nux 3.10.0-0ubuntu1)

- - -

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Fri Oct 26 17:09:42 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus: fglrx, 9.000, 3.5.0-17-generic, x86_64: installed
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6570] [1002:6759] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:e193]
InstallationDate: Installed on 2012-10-18 (7 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=4d7ee3d1-aab7-44a7-9e76-278ed8191974 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/04/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1201
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M5A78L-M LX V2
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1201:bd09/04/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM5A78L-MLXV2:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.8.4-0ubuntu3
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Related branches

Marco Scannadinari (zheoffec) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sami Jaktholm (sjakthol) wrote :

I see similar corruption with the free radeon drivers (R600) so this may not be fglrx related.

Further testing reveals that the bug is not happening with nux 3.8.0-0ubuntu1 but after updating to nux 3.10.0-0ubuntu1 the corruption appears. So this is an SRU regression.

Changed in unity:
status: New → Confirmed
Sami Jaktholm (sjakthol) on 2012-10-28
Changed in nux:
status: New → Confirmed
Sami Jaktholm (sjakthol) on 2012-10-28
summary: - Unity icon corruption while rearranging.
+ [regression] Launcher icon corruption while rearranging.
description: updated
Sami Jaktholm (sjakthol) on 2012-10-28
tags: added: regression-update
tags: added: regression sru
summary: - [regression] Launcher icon corruption while rearranging.
+ [SRU Regression] Launcher icon corruption while rearranging.
Daniel van Vugt (vanvugt) wrote :

Confirmed with intel graphics on two different quantal machines.

Changed in nux:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in nux:
milestone: none → 4.0
Changed in unity:
milestone: none → 7.0.0
Changed in nux:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in nux:
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Fixed in Unity, so a fix in Nux is not needed.

Changed in nux:
status: In Progress → Invalid
milestone: 4.0 → none
assignee: Nick Dedekind (nick-dedekind) → nobody
importance: High → Undecided
description: updated
Omer Akram (om26er) on 2012-10-31
no longer affects: nux
Changed in unity (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in unity (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity (Ubuntu Quantal):
assignee: nobody → Nick Dedekind (nick-dedekind)
milestone: none → quantal-updates
milestone: quantal-updates → none
Didier Roche (didrocks) on 2012-10-31
tags: added: regression-proposed

Hello Marco, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Quantal):
status: Confirmed → Fix Committed
tags: added: verification-needed
Marco Scannadinari (zheoffec) wrote :

I am happy to report that the update in the proposed repository fixed it for me.

1. Enable proposed updates:
    Software Sources
        Updates
            Check the 'proposed' box

2. $ sudo apt-get update

3. $ sudo apt-get install unity

4. $ unity --replace / setsid unity

Marco Scannadinari (zheoffec) wrote :

Changed to: verification-done

tags: added: verification-done
removed: verification-needed
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Please do not change bug status' to Fix Released when the fix is not yet released.

Changed in unity:
status: Fix Released → Fix Committed
Changed in unity (Ubuntu Quantal):
status: Fix Released → Fix Committed
Marco Scannadinari (zheoffec) wrote :

Does Fix Released not include the release in the Proposed repo? If not I apologize.

On Monday, November 05, 2012 04:07:42 PM you wrote:
> Does Fix Released not include the release in the Proposed repo? If not I
> apologize.

No. It does not.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.