compiz crashed with SIGSEGV in unity::QuicklistView::Show() from unity::QuicklistManager::ShowQuicklist()

Bug #1055995 reported by Tyler Chamberland on 2012-09-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Nick Dedekind
6.0
Fix Released
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Crashed through regular, casual use; can't even remember exactly what I was trying to do at the time because it was a banal task.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Tue Sep 25 03:16:55 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120924)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::QuicklistView::Show() () from /usr/lib/compiz/libunityshell.so
 unity::QuicklistManager::ShowQuicklist(unity::QuicklistView*, int, int, bool) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 sigc::internal::signal_emit0<void, sigc::nil>::emit(sigc::internal::signal_impl*) () from /usr/lib/compiz/libunityshell.so
 PluginAdapter::OnScreenUngrabbed() () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in unity::QuicklistView::Show()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

[Test Case]
Unable to reproduce

[Regression Potential]
None

Related branches

StacktraceTop:
 unity::QuicklistView::Show (this=0x399deb0) at /build/buildd/unity-6.6.0/launcher/QuicklistView.cpp:381
 unity::QuicklistManager::ShowQuicklist (this=<optimized out>, quicklist=0x399deb0, tip_x=60, tip_y=<optimized out>, hide_existing_if_open=<optimized out>) at /build/buildd/unity-6.6.0/launcher/QuicklistManager.cpp:96
 operator() (this=0x2bc37f0) at /build/buildd/unity-6.6.0/launcher/LauncherIcon.cpp:622
 operator() (this=0x2bc37f0) at /usr/include/sigc++-2.0/sigc++/adaptors/adaptor_trait.h:251
 sigc::internal::slot_call0<unity::launcher::LauncherIcon::OpenQuicklist(bool, int)::<lambda()>, void>::call_it(sigc::internal::slot_rep *) (rep=0x2bc37c0) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:103

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
summary: - compiz crashed with SIGSEGV in unity::QuicklistView::Show()
+ compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
+ unity::QuicklistManager::ShowQuicklist()
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2012-09-25
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Confirmed → In Progress
Changed in unity:
milestone: none → 7.0.0
Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
description: updated
Stephen M. Webb (bregma) on 2013-02-17
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers