compiz crashed with SIGSEGV in memmove() from drisw_update_tex_buffer() from dri_set_tex_buffer2() from operator() from compiz::opengl::bindTexImageGLX() from ... from unity::UnityWindow::DrawWindowDecoration

Bug #1055166 reported by Sven.Frings on 2012-09-23
304
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Compiz
Critical
Marco Trevisan (Treviño)
Mesa
Invalid
High
Unassigned
Unity
Invalid
Critical
Marco Trevisan (Treviño)
6.0
Won't Fix
High
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
mesa (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

See also bug 927168, which was resolved recently.

Compiz crashed after installed something via Synaptic and just it installed that i want it crashed coz i want to see the black installition screen

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Sun Sep 23 21:36:37 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.2)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f031d57d73c: movntdq %xmm1,-0x10(%rdi)
 PC (0x7f031d57d73c) ok
 source "%xmm1" ok
 destination "-0x10(%rdi)" (0x108d5b170) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
 compiz::opengl::bindTexImageGLX(ServerGrabInterface*, unsigned long, unsigned long, boost::function<bool (unsigned long)> const&, boost::function<void (unsigned long)> const&, boost::function<void ()> const&, compiz::opengl::_PixmapSource) () from /usr/lib/compiz/libopengl.so
 TfpTexture::bindTexImage(unsigned long const&) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 gnome-session[1561]: WARNING: Application 'compiz.desktop' killed by signal 11
 gnome-session[1561]: WARNING: App 'compiz.desktop' respawning too quickly
 gnome-session[1561]: CRITICAL: We failed, but the fail whale is dead. Sorry....

Related branches

Sven.Frings (svenkirk) wrote :

StacktraceTop:
 memmove (__len=81888800, __src=<optimized out>, __dest=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/string3.h:58
 drisw_update_tex_buffer (drawable=<optimized out>, ctx=<optimized out>, res=<optimized out>) at drisw.c:272
 dri_set_tex_buffer2 (pDRICtx=<optimized out>, target=3553, format=8410, dPriv=<optimized out>) at dri_drawable.c:234
 operator() (a0=29362646, this=0x7f0311c02ce0) at /usr/include/boost/function/function_template.hpp:760
 compiz::opengl::bindTexImageGLX(ServerGrabInterface*, unsigned long, unsigned long, boost::function<bool (unsigned long)> const&, boost::function<void (unsigned long)> const&, boost::function<void ()> const&, compiz::opengl::_PixmapSource) (serverGrabInterface=<optimized out>, x11Pixmap=29362645, glxPixmap=29362646, checkPixmapValidity=..., bindTexImageEXT=..., waitGLX=..., source=compiz::opengl::InternallyManaged) at /build/buildd/compiz-0.9.8.2+bzr3377/plugins/opengl/src/glxtfpbind/src/glx-tfp-bind.cpp:50

Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX()
+ compiz crashed with SIGSEGV in memmove()
tags: removed: need-amd64-retrace
Daniel van Vugt (vanvugt) wrote :

This looks similar to bug 927168 but different. This one is coming from Unity trying to hand-draw decorations.

summary: - compiz crashed with SIGSEGV in memmove()
+ compiz crashed with SIGSEGV in memmove() from drisw_update_tex_buffer()
+ from dri_set_tex_buffer2() from operator() from
+ compiz::opengl::bindTexImageGLX() from ... from
+ unity::UnityWindow::DrawWindowDecoration
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
Changed in compiz:
milestone: none → 0.9.9.0
importance: Undecided → High
status: New → Confirmed
Changed in unity:
milestone: none → 7.0.0
description: updated
Changed in unity:
status: Confirmed → Triaged
importance: Medium → High
Changed in compiz:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz:
milestone: 0.9.9.0 → none
Changed in unity:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
Changed in unity (Ubuntu):
importance: Medium → High
affects: compiz → mesa
no longer affects: compiz/0.9.8
affects: compiz (Ubuntu) → mesa (Ubuntu)
Changed in unity:
assignee: Nicolas d'Offay (nicolas-doffay) → nobody
Daniel van Vugt (vanvugt) wrote :

See also bug 1062624.

Nate R (nate-ridderman) wrote :

This occurs approximately once a day for me... running 64 bit inside Virtualbox 4.2, did an in-place upgrade from 12.04.

Changed in unity (Ubuntu):
status: Confirmed → Triaged
tags: added: raring
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1055166

tags: added: iso-testing
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
tags: added: saucy
tags: added: bugpattern-needed
tags: added: trusty
Jacob MacDonald (jaccarmac) wrote :

I was able to solve this by installing the latest proprietary drivers for my graphics cards.

Compiz and Unity are crashing on Live DVD boot in Vmware player 6.0.1
No menus and menubars are visible, just managed to start terminal by keyboard shortcurts.

Amulet (amulet800) wrote :

This received first boot after upgrade to 14.04

Dave Gilbert (ubuntu-treblig) wrote :

Same here; unusable - 14.04 in KVM guest, dies immediately after I search for 'terminal' and select it.
The terminal eventually starts but by that time compiz is dead.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: 7.0.1 → 7.2.0
importance: High → Critical

This seems to happen here when compiz tries to create an empty texture (0x0), see bt at http://pastebin.ubuntu.com/7027036/

Some highlights:
#9 0x00007fbfc0f16429 in unity::compiz_utils::PixmapTexture::PixmapTexture (this=0x227a968, w=0, h=0) at /home/marco/Dev/unity/trunk/unity-shared/CompizUtils.cpp:115

The text buffer has random geometries at this point:
#2 drisw_update_tex_buffer (drawable=<optimized out>, ctx=<optimized out>, res=<optimized out>) at ../../../../../../../src/gallium/state_trackers/dri/sw/drisw.c:320
        dPriv = <optimized out>
        st_ctx = <optimized out>
        pipe = 0xc33200
        transfer = 0x2dd5490
        x = 36615400
        y = 0
        w = -711233149
        h = 32703
        ximage_stride = 1450034700
        line = 32702
        cpp = <optimized out>

Changed in unity:
status: Triaged → Invalid
Changed in compiz:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Critical
milestone: none → 0.9.11.0
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140303-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140303-0ubuntu1) trusty; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Window: define proper cases when we need to resize a window when
    decorating/undecorating Yeah, again here... So, now when setting the
    window extents, we resize a window only in these cases: 1) We have a
    normal window that has never been decorated (lp:1282304) 2) We're
    (re)decorating a maximized or fullscreen window (lp:1282305) This
    seems to work well in all the cases I tested, with no regressions
    with nedit (that highlighted an issue with old code path) (LP:
    #1282304, #1282305)
  * Opengl, Texture: don't try to create a texture of invalid (empty or
    negative) size This seem to cause also a crash when using software
    rendering. (LP: #1055166)
 -- Ubuntu daily release <email address hidden> Mon, 03 Mar 2014 20:09:55 +0000

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Invalid
Doug Smythies (dsmythies) wrote :

Yes, this has fixed my problem for one of my 14.04 Desktop VM running on my 12.04 server host.
I have several other scenarios to check, it'll take me awhile. (I came here from bug 1282342 , which started 2104.02.17)

Stephen M. Webb (bregma) on 2014-03-18
Changed in unity:
milestone: 7.2.0 → none
Stephen M. Webb (bregma) on 2014-11-04
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.