compiz crashed with SIGSEGV in void std::vector<unsigned int, std::allocator<unsigned int> >::_M_insert_aux<unsigned int>() from ... from unity::dash::HomeLens::Impl::LensSearchFinished()

Bug #1054219 reported by Michael Hall on 2012-09-21
156
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Nick Dedekind
6.0
Fix Released
High
Nick Dedekind
unity (Ubuntu)
High
Unassigned

Bug Description

Running latest Quantal

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
CrashCounter: 1
Date: Fri Sep 21 11:56:33 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 void std::vector<unsigned int, std::allocator<unsigned int> >::_M_insert_aux<unsigned int>(__gnu_cxx::__normal_iterator<unsigned int*, std::vector<unsigned int, std::allocator<unsigned int> > >, unsigned int&&) () from /usr/lib/compiz/libunityshell.so
 std::vector<unsigned int, std::allocator<unsigned int> >::insert(__gnu_cxx::__normal_iterator<unsigned int*, std::vector<unsigned int, std::allocator<unsigned int> > >, unsigned int const&) () from /usr/lib/libunity-core-6.0.so.5
 unity::dash::HomeLens::Impl::LensSearchFinished(std::shared_ptr<unity::dash::Lens> const&) () from /usr/lib/libunity-core-6.0.so.5
 ?? () from /usr/lib/libunity-core-6.0.so.5
Title: compiz crashed with SIGSEGV in void std::vector<unsigned int, std::allocator<unsigned int> >::_M_insert_aux<unsigned int>()
UpgradeStatus: Upgraded to quantal on 2012-08-17 (34 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

[Impact]
Crash when opening dash lens.

[Test Case]
Open home lens where there is only one addition category other than shopping (eg application & shopping). You may need to alter the installed lenses to get this to happen.

[Regression Potential]
Incorrect ordering of lens categories.

Related branches

Michael Hall (mhall119) wrote :

StacktraceTop:
 __copy_move_b<unsigned int> (__last=<optimized out>, __result=<optimized out>, __first=0x9d3baa0) at /usr/include/c++/4.6/bits/stl_algobase.h:561
 __copy_move_backward_a<true, unsigned int*, unsigned int*> (__result=<optimized out>, __last=<optimized out>, __first=0x9d3baa0) at /usr/include/c++/4.6/bits/stl_algobase.h:581
 __copy_move_backward_a2<true, unsigned int*, unsigned int*> (__result=<optimized out>, __last=<optimized out>, __first=0x9d3baa0) at /usr/include/c++/4.6/bits/stl_algobase.h:590
 move_backward<unsigned int*, unsigned int*> (__result=<optimized out>, __last=<optimized out>, __first=0x9d3baa0) at /usr/include/c++/4.6/bits/stl_algobase.h:661
 std::vector<unsigned int, std::allocator<unsigned int> >::_M_insert_aux<unsigned int>(__gnu_cxx::__normal_iterator<unsigned int*, std::vector<unsigned int, std::allocator<unsigned int> > >, unsigned int&&) (this=0xbfd51d44, __position=...) at /usr/include/c++/4.6/bits/vector.tcc:313

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
summary: compiz crashed with SIGSEGV in void std::vector<unsigned int,
- std::allocator<unsigned int> >::_M_insert_aux<unsigned int>()
+ std::allocator<unsigned int> >::_M_insert_aux<unsigned int>() from ...
+ from unity::dash::HomeLens::Impl::LensSearchFinished()
Changed in unity:
status: New → Confirmed
visibility: private → public
Changed in unity:
milestone: none → 6.8
Changed in unity:
milestone: 6.8.0 → 7.0.0
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Nick Dedekind (nick-dedekind) wrote :

I believe this happens when you open the home lens where there is only one addition category other than shopping (eg application & shopping).

Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Vasilis Toumpakaris (toumbo) wrote :

It crashed when I was trying to open the dash.

Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Download full text (5.1 KiB)

Thanks.

On Fri, Oct 5, 2012 at 1:03 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package unity - 6.8.0-0ubuntu1
>
> ---------------
> unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low
>
> [ Ángel Guzmán Maeso ]
> * debian/unity-crashdb.conf:
> - Update dictionary option for follow latest apport spec
>
> [ Łukasz 'sil2100' Zemczak ]
> * New upstream release.
> - unity 6.8 candidate segfaults on "app expose" with low gfx mode
> (LP: #1060148)
> - [regression] Dash - Left separator is missing (LP: #1057798)
> - unity-panel-service crashed with SIGSEGV in
> panel_indicator_entry_accessible_get_n_children() from
> atk_object_get_n_accessible_children() (LP: #913324)
> - [regression] If unity is started with maximized dash, unmaximizing
> the
> dash does not wrap rows (LP: #1053116)
> - Dash lens buttons don't work after changing form factor to maximize
> on
> desktop (LP: #1053316)
> - Clicking on Workspace Switcher icon when the expo is showing, not
> always
> closes it 1059759 convert files list deprecated keys (LP: #1059594)
> - Unity through llvmpipe is slow (LP: #1046497)
> - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
> unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
> - compiz crashed with SIGSEGV from
> unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
> - [regression] Starting an app & then locking to launcher is not
> persistent
> across sessions (LP: #1054645)
> - [regression] Dash, Launcher, Menu Bar - Unintended shadows are
> rendered
> for the Unity Launcher and Panel, when the dash is open (LP:
> #1043260)
> - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
> Framebuffer object (LP: #1039999)
> - Alt+Tab/Alt+grave brings other window to the front but loses focus
> entirely. (LP: #1035628)
> - Spread - Scaling all the windows is too slow (LP: #1055643)
> - Window management - Middle clicking on a window inside the spread
> should
> close that window (equivalent action to clicking on the close button)
> (LP: #1052821)
> - Scale window decorations don't have properly rounded corners
> (LP: #1055610)
> - Scale window decorations text does not match theme style (Radiance)
> (LP: #1055609)
> - Spread window decorations does not match the theme when changed
> (LP: #1055605)
> - scaled window decorations are sometimes wider than the window
> (LP: #1053225)
> - Launcher should not auto-hide after dragging an icon, if mouse is
> still
> over it (LP: #1053978)
> - unity spread window on second click not working when ibus language
> panel
> is shown. (LP: #1035895)
> - windows.push_back(<uninitialized value>) in
> BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
> - Category emblems are blurry (LP: #1056874)
> - Rendering flaws of the dash previews (LP: #1055455)
> - [UIFe] Social Lens doesn't have authorised and meaningful icon
> (LP: #1056191)
> - [dash] Preview fade out animation...

Read more...

description: updated
Stephen M. Webb (bregma) on 2013-02-17
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Wangermée Guy (wangermee-guy) wrote :

Thanks a lot.

On Tue, Feb 19, 2013 at 4:11 PM, Daniel van Vugt <
<email address hidden>> wrote:

> ** Changed in: unity
> Status: Fix Released => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1056742).
> https://bugs.launchpad.net/bugs/1054219
>
> Title:
> compiz crashed with SIGSEGV in void std::vector<unsigned int,
> std::allocator<unsigned int> >::_M_insert_aux<unsigned int>() from ...
> from unity::dash::HomeLens::Impl::LensSearchFinished()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1054219/+subscriptions
>

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Wangermée Guy (wangermee-guy) wrote :

OK thank you.

On Wed, Apr 3, 2013 at 4:59 PM, Stephen M. Webb
<email address hidden>wrote:

> Fix Released in Unity Unity 7.0.0 "R series".
>
> ** Changed in: unity
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1056742).
> https://bugs.launchpad.net/bugs/1054219
>
> Title:
> compiz crashed with SIGSEGV in void std::vector<unsigned int,
> std::allocator<unsigned int> >::_M_insert_aux<unsigned int>() from ...
> from unity::dash::HomeLens::Impl::LensSearchFinished()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1054219/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers