Broken UI and no window management

Bug #1053288 reported by Laura Czajkowski on 2012-09-20
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Robert Carr
Unity
Fix Released
Critical
Unassigned
WebApps: libunity-webapps
Undecided
Unassigned
unity (Ubuntu)
Critical
Unassigned
Quantal
Critical
Unassigned

Bug Description

As of the latest updates to 12.10 I cannot alt tab between any application on the workspace, it won't recognise I've other applications open on the workspace.

If you have multiple applications open from the same application ie. Terminal, everytime you click on terminal from the launcher it opens another terminal, what I'd expect to happen would be zoom out of desktop and show all open terminals so I can chose from one of them.

Window management for an application is gone, so no way to exit an application bar alt F4 seen screen attachments.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.4.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Thu Sep 20 09:52:33 2012
DistUpgraded: 2012-09-08 13:16:21,194 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:0009]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: TOSHIBA SATELLITE Z830
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=ce6ea08d-b7a1-41cb-9678-b534afddd7e8 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to quantal on 2012-09-08 (11 days ago)
dmi.bios.date: 11/09/2011
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 1.40
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion1.40:bd11/09/2011:svnTOSHIBA:pnSATELLITEZ830:pvrPT22LE-00F004EN:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: SATELLITE Z830
dmi.product.version: PT22LE-00F004EN
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.8.0-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu1

Related branches

Laura Czajkowski (czajkowski) wrote :
Laura Czajkowski (czajkowski) wrote :

Just confirmed this happens on the guest account also.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

you are using unity from archives but the version of Bamf is from staging ppa.

Changed in unity (Ubuntu):
status: Confirmed → New
Barneedhar (barneedhar) wrote :

I can reproduce the bug with bamf from repo:

$ apt-cache policy bamfdaemon
bamfdaemon:
  Installed: 0.3.0-0ubuntu2
  Candidate: 0.3.0-0ubuntu2
  Version table:
 *** 0.3.0-0ubuntu2 0
        500 http://sg.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

Barneedhar (barneedhar) wrote :

bamf was rebuilt against libunity-webapps. Installing libunity-webapps* helps solve the bug.

Omer Akram (om26er) on 2012-09-20
Changed in unity (Ubuntu):
importance: Undecided → Critical
Changed in unity:
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
David Callé (davidc3) wrote :

If I try to launch bamf manually:
$ /usr/lib/bamf/bamfdaemon

It fails with:
/usr/lib/bamf/bamfdaemon: error while loading shared libraries: libunity_webapps.so.0: cannot open shared object file: No such file or directory

Renaming the existing libunity-webapps.so.0 as a temporary workaround solves the issue:
$ sudo cp /usr/lib/x86_64-linux-gnu/libunity-webapps.so.0 /usr/lib/x86_64-linux-gnu/libunity_webapps.so.0

Shanekpiper (shanekpiper) wrote :

Just done the update and from the lightdm login screen I don't have the ubuntu icon for session changes. Reason there no unity. All I have is desktop folders. Had to install docky to get things to function.

I installed libunity-webapps but still have the issue.

I even tried this:

:~$ sudo apt-get install --reinstall ubuntu-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 ubuntu-desktop : Depends: unity but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I guess we should all be patient for the packages to be released.

Pavel P. (zarjart) on 2012-09-20
Changed in unity:
status: New → Incomplete
status: Incomplete → Confirmed
Olli Ries (ories) wrote :

I can confirm #9, seems like a packaging issue, shouldn't the temp fix read:

$ sudo cp /usr/lib/x86_64-linux-gnu/libunity-webapps.so.0.0.0 /usr/lib/x86_64-linux-gnu/libunity_webapps.so.0

?

can't reproduce atm though

For anyone experiencing this bug try:-

sudo apt-get update
sudo apt-get install ubuntu-desktop^

(the caret is important and will install the ubuntu-desktop task and pull in any missing dependencies).

Will Cooke (willcooke) wrote :

Fixed in BAMF

Changed in libunity-webapps:
status: New → Invalid
Timo Jyrinki (timo-jyrinki) wrote :

Would it be right to mark others than bamf as Invalid, if the real fix is in there?

I gather ubuntu-desktop missing on some people's machines is a different problem from this bug.

Changed in bamf:
milestone: none → 0.3.2
status: New → Fix Committed
assignee: nobody → Robert Carr (robertcarr)
importance: Undecided → Critical

https://bugs.launchpad.net/libunity-webapps/+bug/1053688

I confirmed rebuilding libunity and libunity-webapps fixes the problem...

xDfg#$ (mr-nobody) wrote :

I see everyone have this issue with unity. I have this issue with gnome (unity works fine for me).

Omer Akram (om26er) on 2012-10-02
Changed in unity (Ubuntu Quantal):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Changed in unity:
status: Invalid → Fix Committed
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.