launcher is not refreshed after user session switch

Bug #1016430 reported by Francis Ginther on 2012-06-22
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Precise
High
David Barth
Unity
Fix Released
Undecided
Daniel van Vugt
5.0
Fix Released
Undecided
Tim Penhey
unity (Ubuntu)
Undecided
Unassigned
Nominated for Quantal by Anthony Wong
Precise
Undecided
Unassigned

Bug Description

[Test Case]
1. Login as user X.
2. Switch to guest account via the session indicator
3. Switch back to the session for user X.
   -> Ensure that the launcher is refreshed and does not show any graphical artifacts.

[Regression Potential]
Visual regressions, shell drawing problems. Big change, many regression potentials.

Original description:

The launcher is not refreshed when switching between user sessions. Instead artifacts are left over from the prior session. This could potentially reveal private information between sessions.

How to reproduce:
1. Login as user X.
2. Switch to guest account via the session indicator
3. Switch back to the session for user X.

The launcher will not be refreshed and will instead show graphical artifacts from the guest session.

This is similar to Bug #755230, but specific to the launcher window on Precise.

Version: Precise
Graphics: Nvidia

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 295.40 Thu Apr 5 21:28:09 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Fri Jun 22 03:45:34 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.2.0-23-generic-pae, i686: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-24-generic-pae, i686: installed
 nvidia-current, 295.40, 3.2.0-23-generic-pae, i686: installed
 nvidia-current, 295.40, 3.2.0-24-generic-pae, i686: installed
GraphicsCard:
 NVIDIA Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:30cf]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 04f2:b015 Chicony Electronics Co., Ltd VGA 24fps UVC Webcam
 Bus 002 Device 002: ID 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface [Broadcom BCM2045]
 Bus 002 Device 003: ID 046d:c044 Logitech, Inc. LX3 Optical Mouse
MachineType: Hewlett-Packard HP Pavilion dv6500 Notebook PC
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic-pae root=UUID=887272f1-da71-4ef6-9fa3-336ec721a453 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 03/03/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.32
dmi.board.name: 30D0
dmi.board.vendor: Quanta
dmi.board.version: 85.26
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.32:bd03/03/2009:svnHewlett-Packard:pnHPPaviliondv6500NotebookPC:pvrRev1:rvnQuanta:rn30D0:rvr85.26:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6500 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.7.8-0ubuntu2~pre1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Francis Ginther (fginther) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
merovius (merovius) wrote :

This affects me as well running Nvidia version current-updates. Ubuntu 12.04

Also affected by this bug, the first time I tried to reproduce the launcher was not drawn at all until I moved my mouse over the area. I then switched to the guest account and back and the system locked up and I had to hard reset. Upon trying it again I got the ariefacts as described above until I moved my mouse into the launcher area again.

Daniel van Vugt (vanvugt) wrote :

I suspect this will be fixed by: lp:~vanvugt/unity/regionalDamage
So assigning to myself unless proven otherwise.

Changed in unity:
status: New → Confirmed
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in unity:
milestone: none → 6.0
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2470

Changed in unity:
status: In Progress → Fix Committed
tags: added: blocks-hwcert-enablement
Ding Zhou (tualatrix) wrote :

Thanks for the fix.

I tried to build the latest Unity and Nux from source and play with it under Ubuntu 12.04, this issue has been fixed. However, I found other issue.

As screenshot I attached, If I start to drag many files, the Launcher and Panel will disappear, until I release my mouse, they will be back.

My system: Ubuntu 12.04 with source compiled Nux and Unity, nVIDIA card.

Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
tags: added: rls-q-incoming
James M. Leddy (jm-leddy) wrote :

Ding, would you please open a separate bug for this? The unity devs are considering the original issue to be fixed on their side. Also, please include the graphics device and drivers you're using in the report.

Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Shengyao Xue (xueshengyao) wrote :

I backported the r2470 from trunk to precise (which unity version is 5.12-0ubuntu1.1), the patch attached.

Changed in oem-priority:
importance: Undecided → High
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
tags: added: patch
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity/5.0 at revision 2394

Changed in oem-priority:
status: New → Confirmed
status: Confirmed → In Progress
description: updated
description: updated
James M. Leddy (jm-leddy) wrote :

Quick quesiton, does targeting SRU-2 mean it's going to get a stable release update in precies?

On 12/09/12 10:42, James M. Leddy wrote:
> Quick quesiton, does targeting SRU-2 mean it's going to get a stable
> release update in precies?
>
I hope so. This work has been done targeting precise, and we are just
waiting for SRU 2.

Tim

Hello Francis, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Flittermice (flittermice) wrote :

Hello!

I enabled proposed like told above and did "sudo apt-get -t precise-proposed install unity".
After logging off all users I tested the new package.

Result: Screen refresh is now WORKING! I experienced no other problems until now.
Thanks very much!

Omer Akram (om26er) on 2012-09-13
tags: added: verification-done
removed: verification-needed
Bart Heinsius (bheinsius) wrote :

installed unity 5.16.0 and problem with refresh of launcher seems fixed, but other applications still have redraw problems, see attachment.

Changed in oem-priority:
status: In Progress → Fix Committed
Shengyao Xue (xueshengyao) wrote :

I tried this new unity version (5.16.0-0ubuntu1), and it works! I cannot reproduce the bug now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.16.0-0ubuntu1

---------------
unity (5.16.0-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - Update libgeis-dev and libgrail-dev dependencies in debian/control
  * New upstream release.
    - launcher is not refreshed after user session switch (LP: #1016430)
    - Dragging windows around is slow/sluggish/laggy when multiple monitors
      are enabled (LP: #874619)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - Tooltips backgrounds are not refreshed (no active blur) (LP: #967112)
    - [regression] Unity panel transparency (active blur) not updating properly
      (LP: #865006)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Black background around after dash is restored (LP: #992516)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - [SRU regression] alt-grave not switching to next window unless 'grave'
      pressed twice (LP: #1035668)
    - [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
      incomplete/missing (LP: #1034164)
    - [nvidia] unity crashed in
      nux::GraphicsEngine::QRP_GLSL_1Tex (glDrawArrays) (LP: #1031554)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Compiz won't start if "unredirect fullscreen windows" is enabled
      (LP: #980663)
    - [regression] Unity launcher on-screen corruption on resume from suspend
      with nVidia proprietary driver (LP: #915265)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - [nvidia] compiz crashed with SIGSEGV in
      nux::BasePainter::PaintBackground (LP: #982626)
    - Update dependency on the renamed libgeis

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest nux as libgeis-dev and libutouch-geis-dev are
      conflicting (LP: #1047385)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Sep 2012 10:53:17 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.