Software Center add to launcher icon animation is delayed when the launcher is in auto-hide mode

Bug #1012896 reported by Gary Lasker on 2012-06-13
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Bilal Akhtar
5.0
Fix Released
High
Bilal Akhtar
unity (Ubuntu)
High
Bilal Akhtar
Precise
High
Bilal Akhtar

Bug Description

[Test Case]
1. Set the Unity launcher to auto-hide.
2. Launch Ubuntu Software Center.
3. Make sure that the "View"-<"New Applications in Launcher" menu item in Software Center is checked.
4. Select the "Games" section, choose an uninstalled game and install it.
   -> Verify that the application's icon "flies" to the Unity Launcher at some point during the install process, and the icon should wiggle to indicate that it has been added.

[Regression Potential]
Broken software-center integration.

Original description:

Ubuntu 12.04
Ubuntu Software Center version 5.2.2.2
Unity version 5.12-0ubuntu1.1

When the automatic add-to-launcher option is enabled in Ubuntu Software Center and the Unity launcher is set to auto-hide mode, the the flying icon animation does not occur and the installed item added to the launcher until the launcher itself has been revealed.

To reproduce:
1. Set the Unity launcher to auto-hide.
2. Launch Ubuntu Software Center.
3. Make sure that the "View"-<"New Applications in Launcher" menu item in Software Center is checked.
4. Select the "Games" section, choose an uninstalled game and install it.

What happens:
The installation proceeds and completes, yet the "flying" icon animation for the add-to-launcher feature never occurs. Wait a few moments to verify that it still hasn't happened. Then, move the mouse to the left edge of the screen to expose the launcher, and observe as the icon "flys" into the launcher at that moment.

What should happen:
The application's icon should "fly" to the Unity Launcher at some point during the install process, and the icon should wiggle to indicate that it has been added.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Wed Jun 13 18:28:20 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2011-12-26 (170 days ago)

Related branches

Gary Lasker (gary-lasker) wrote :
no longer affects: software-center (Ubuntu)
Changed in unity (Ubuntu):
status: New → Confirmed
status: Confirmed → New
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in unity:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Bilal Akhtar (bilalakhtar)
Gary Lasker (gary-lasker) wrote :

As always, thank you for your help, Bilal! :D

tags: added: regression-update
Bilal Akhtar (bilalakhtar) wrote :

This issue was introduced in Unity 5.12-0ubuntu1.1 SRU for precise. The change that caused this issue, was that the launcher was changed to NOT redraw in the background by itself. The redrawing code contains the part to animate the icon. Because the launcher doesn't get redrawn frequently anymore, nothing happens until the user manually un-hides the launcher.

I'm working on a fix right now.

tags: removed: regression-update
tags: added: regression-release
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
milestone: none → 5.14.0
tags: added: regression-update
removed: regression-release
Michael Vogt (mvo) wrote :

Fwiw, my launcher is not doing auto-hide and I'm still affected by this bug. Or maybe the name "auto-hide" of the option is misleading ;) My unity panel does not automatically hide, its always visible.

Omer Akram (om26er) on 2012-06-14
Changed in unity (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
Bilal Akhtar (bilalakhtar) wrote :

@MVO The same thing applies in non-autohide cases too, and my fix should work in both cases. The launcher doesn't get re-drawn until you pass your mouse over it, and in the code currently on Precise, the animation waits for a redraw to happen.

My fix prompts a redraw to happen immediately after the launcher receives a DBus event from SC.

Changed in unity (Ubuntu Precise):
assignee: nobody → Bilal Akhtar (bilalakhtar)
milestone: none → precise-updates
Changed in unity:
milestone: 5.14.0 → 6.0
status: In Progress → Triaged
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
milestone: 6.0 → 6.2

Hello Gary, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers