Dash: installed/not installed packages are conflated under "Applications": incredibly confusing

Bug #733669 reported by Jeff Lane on 2011-03-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Mikkel Kamstrup Erlandsen
Unity Foundations
Medium
Mikkel Kamstrup Erlandsen
unity-lens-applications
Medium
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned

Bug Description

When looking for applications, I search for Terminal and lo and behold, there are THREE items that are simply named "Terminal" only one is the correct one, which one is it? This kind of ambiguous naming could be confusing for users. See attached screenshot.

Package: unity-place-applications 0.2.38-0ubuntu1

Ideally packages that are not installed should be visually separated. See comment #11 that it needs doing, but a solution probably needs designing first.

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :
Tom Adams (holizz) wrote :

Thanks for reporting this. I agree it's confusing (especially since I don't recognise two of the Terminals' icons) so I'm going to mark it "confirmed".

How did you envision this being solved? Just adding the name of the executable (i.e. "gnome-terminal", "urxvt") beneath the "human-friendly" name would work, I think?

Changed in unity-place-applications (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

The other two icons are what Unity is using to representing uninstalled applications that can be installed in Software Center.

How about modifying the .desktop files for the other two terminals so that they would be Terminal.app and Vala Terminal?

Jeff Lane (bladernr) wrote :

@Jeremy: Now THAT is even more confusing... is there some way to turn that off? I am not a big fan of having to remember the name of the application I want and then searching for it as it is, but now I'll have to also look through potentially hundreds of uninstalled applications as well because of Software Center integration???

@Tom: originally, I would have thought your suggestion reasonable... but if the "menu" is going to mix in icons representing uninstalled applications as well, I have no idea...

Now that I realize whats going on, that's even worse... I just did the lookup for Terminal again and noticed that there are actually 14 different terminal applications displayed. And the VAST majority of those are not even installed. This is just wrong...

For something that's supposed to be user friendly, it just became very user-confusing... and I use this every day... I can't imagine what someone with little to no experience is going to think... :/

Tom Adams (holizz) wrote :

I just this minute upgraded. Ubuntu Software Center integration must have been added in 0.2.38. Gosh that is confusing. It wouldn't be so bad if they were under a heading saying "uninstalled applications".

I made a new bug for the 3 "Terminal"s being named exactly the same: bug #733882.

This bug can continue to be about uninstalled applications being integrated confusingly into unity-place-applications.

IKT (ikt) wrote :

"Too many terminals" isn't really descriptive of the real issue, which is that it's misleading to have applications that aren't installed listed right next to programs which are installed with no way to tell which is installed and which isn't.

Paul Sladen (sladen) on 2011-03-15
description: updated

> "Too many terminals" isn't really descriptive of the real issue, which is that it's misleading to have applications that aren't installed
> listed right next to programs which are installed with no way to tell which is installed and which isn't.

IKT: you are correct, and I have changed the title accordingly...

Tom: thanks for opening the new bug :)

summary: - Too many terminals
+ Inclusion of uninstalled packages mixed in with installed packages when
+ using the application menu is incredibly confusing
Didier Roche (didrocks) on 2011-03-16
Changed in unity:
status: New → Confirmed
Changed in unity-place-applications:
status: New → Confirmed
IKT (ikt) wrote :

Just to be sure this seems to be an issue with just the dash after opening the global menu, it seems that if you search for "terminal" in the applications place/launcher, it correctly separates the applications which are installed and which are not.

Jeff Lane (bladernr) wrote :

IKT: Correct... this appears to be a dash only issue. As you've pointed out (and I also just verified myself) in applications place the uninstalled packages ARE separated from the installed packages.

On 16/03/11 21:23, Jeff Lane wrote:
> IKT: Correct... this appears to be a dash only issue. As you've pointed
> out (and I also just verified myself) in applications place the
> uninstalled packages ARE separated from the installed packages.

This should be confirmed if it isn't already - displaying apps which are
not installed under the general heading "Applications" in the Dash Home
Screen Search is very misleading. They should be broken out into a
separate section, or clearly labelled individually.

Mark

Paul Sladen (sladen) on 2011-03-17
summary: - Inclusion of uninstalled packages mixed in with installed packages when
- using the application menu is incredibly confusing
+ Dash: installed/not installed packages are conflated under
+ "Applications": incredibly confusing
description: updated
Changed in ayatana-design:
importance: Undecided → High
status: New → Confirmed
tags: added: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)

Not sure exactly how to solve this. A few suggestions for debate:

 1) Simply don't show uninstalled apps in the Dash homescreen. Only in the apps place (super easy fix)
 2) Add some "web" emblem to the uninstalled app icons (easy in unity-place-applications, but may need shell integration to work..?)
 3) Prefix name labels with "Download: " or something. This will probably result in an ellipsis nightmare, but is trivial to implement
 4) Split out in a different section in the Dash (requires some work in both the place daemon and in the Unity shell)

David Callé (davidc3) wrote :

IMHO, at this point of the release schedule, the best way to go would be to do 1 for Natty and investigate 4 for Oneiric, as 2 & 3 seem to add an unnecessary layer of complexity.

I played a little with 2) just for the heck of it. It's a trivial change to unity-place-applications. I tried with a web- and a package emblem. Could maybe work - but I think it requires some fiddling with the rendering in Unity because the emblem offsets seem hosed on smaller icons. See fx.the icon under the cursor in the package-emblem-screenie...

http://grillbar.org/files/unity-package-emblem.png
http://grillbar.org/files/unity-web-emblems.png

Paul Sladen (sladen) wrote :

My temptation would be for 1(+2) for Ubuntu 11.04. For (3), rather than prepending "Download: ", one could /append/ "…" indicating a multi-step process in-addition/instead of an overlay emblem. When users notice, this would be a quick and easy discriminator and should(?) work for accessibility when a simple icon-overlay would not.

I'd expect to see non-local/non-installed applications sort later, unless they are an exact match too. An already-installed "xterm" or "Gnome Terminal" would win over Konsole for the example search of "terminal", but 'Konsole" would still win for a search for "konsole" typed explicitly because of an exact match.

Paul; I'm not sure I get what you mean by "1(+2)" :-) Is it "1 and maybe 3" or "1 and maybe 2"?

Wrt to appending ... it could potentially look odd when intermixed with ellipsis because of truncation?

Wrt to sorting - like it is now uninstalledd apps *always* sort after installed apps in the Dash, no matter how well they match

ok - I can't find any apps with truncated names, maybe we just don't do that anymore - i just brought it up because it was a big issue in M

David Callé (davidc3) wrote :

Let's take this the other way around : what about adding the software-center-installed.png emblem to installed apps? Less clutter than 2 and consistency with USC.

Paul Sladen (sladen) wrote :

Mikkel: Yes 1(+2) meant: (1) don't show on the first screen, and maybe also (2) to have an overlay emblem at the second level of searching, although instead/as well, an easier idea for (3) might be to append an "…" ellipse, which is shorter then "Download: " (I'm not keen on the "Download: " prefix, my hunch is that it'll look clumsy being repeated so much like the "Find Find Find Find" is at the moment).

On 17/03/11 10:42, Mikkel Kamstrup Erlandsen wrote:
> Not sure exactly how to solve this. A few suggestions for debate:
>
> 1) Simply don't show uninstalled apps in the Dash homescreen. Only in the apps place (super easy fix)

This is sufficient to close the bug for Natty.

> 2) Add some "web" emblem to the uninstalled app icons (easy in unity-place-applications, but may need shell integration to work..?)
> 3) Prefix name labels with "Download: " or something. This will probably result in an ellipsis nightmare, but is trivial to implement

If we're to do either of these, we need to evaluate it's value as a
general system. In other words, evaluate whether there is sufficient
benefit in having the lens/place provide the home screen with
emblems/tags for the results. John Lea is looking at Dash 3.0 right now
for Oneiric, cc'd.

> 4) Split out in a different section in the Dash (requires some work in both the place daemon and in the Unity shell)

I have a feeling this is the right end-game anyhow in this case.
Apps-for-install is really great to see on the home screen, but they
really are a completely different class of thing than apps installed.
For example, I would like to see:

 - matching apps installed
 - matching local / cloud files
 - available apps

In that order... which suggests they need to be a different section, and
that's out of scope for Natty.

Mark

On 03/17/2011 11:04 AM, Mark Shuttleworth wrote:
> On 17/03/11 10:42, Mikkel Kamstrup Erlandsen wrote:
>> Not sure exactly how to solve this. A few suggestions for debate:
>>
>> 1) Simply don't show uninstalled apps in the Dash homescreen. Only in the apps place (super easy fix)
>
> This is sufficient to close the bug for Natty.

+1

>> 4) Split out in a different section in the Dash (requires some work
> in both the place daemon and in the Unity shell)
>
> I have a feeling this is the right end-game anyhow in this case.
> Apps-for-install is really great to see on the home screen, but they
> really are a completely different class of thing than apps installed.
> For example, I would like to see:
>
> - matching apps installed
> - matching local / cloud files
> - available apps
>
> In that order... which suggests they need to be a different section, and
> that's out of scope for Natty.

On the one hand, I would suggest that having them in Dash at all is
overkill as they already exist in Applications Place, however, I could
also agree that the above breaks them down nicely as well.

I would be completely happy with that breakdown, though I'd also prefer
that the last bit (available apps) be an option that can be turned off
based on personal preference, as I already know I can click Applications
and find things via software center that I search for, so personally, I
don't need them elsewhere... (though I also recognize that what 'I'
prefer is not necessarily what works for the community at large)

But in any case, this certainly seems like a good end-game for this
particular issue.

--
Jeff Lane - Hardware Certification Engineer and Test Tools Developer
Ubuntu Ham: W4KDH
Freenode IRC: bladernr or bladernr_
gpg: 1024D/3A14B2DD 8C88 B076 0DD7 B404 1417 C466 4ABD 3635 3A14 B2DD

Changed in ayatana-design:
status: Confirmed → Fix Released
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 3.6.8
status: Confirmed → Triaged
Changed in unity-place-applications:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 0.2.42
status: Confirmed → Triaged
Changed in unity-foundations:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → unity-3.6.8
status: New → Triaged
Changed in unity-foundations:
status: Triaged → Fix Committed
Changed in unity-place-applications:
status: Triaged → Fix Committed
Changed in unity-place-applications (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Fix Committed → Fix Released
Changed in unity-foundations:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.42-0ubuntu1

---------------
unity-place-applications (0.2.42-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Dash search unavoidably returns offensive results (LP: #739469)
    - SearchFinished signal for Places API (LP: #739311)
    - Dash: installed/not installed packages are conflated under "Applications":
      incredibly confusing (LP: #733669)
    - Apps Place: SIGABRT when monkey-typing global searches (LP: #737396)
  * debian/control:
    - bump dep req.
 -- Didier Roche <email address hidden> Wed, 23 Mar 2011 17:06:19 +0100

Changed in unity-place-applications (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers