unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()

Bug #930499 reported by Chenheting on 2012-02-11
This bug affects 320 people
Affects Status Importance Assigned to Milestone
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

I just started ubuntu 12.04 and started luncher, I got this bug

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sat Feb 11 09:10:52 2012
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111212)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_SG:en
 LANG=en_SG.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fc809f2b090: cmp %rdi,0x18(%rdx)
 PC (0x7fc809f2b090) ok
 source "%rdi" ok
 destination "0x18(%rdx)" (0x00000017) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdee-1.0.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to precise on 2012-02-10 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Chenheting (chenheting) wrote :
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed

StacktraceTop:
 snprintf (__fmt=<optimized out>, __n=<optimized out>, __s=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/stdio2.h:65
 g_scanner_unexp_token (scanner=0x13655a0, expected_token=30352, identifier_spec=0x1577cf0 "\320:O\001", symbol_spec=<optimized out>, symbol_name=<optimized out>, message=0x2 <Address 0x2 out of bounds>, is_error=21972736) at /build/buildd/glib2.0-2.31.16/./glib/gscanner.c:1508
 ?? ()
 ?? ()
 ?? ()

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.6.2-12ubuntu1 required, but 1:4.6.2-14ubuntu1 is available
libnih1 version 1.0.3-4ubuntu7 required, but 1.0.3-4ubuntu8 is available
psmisc version 22.14-1 required, but 22.15-2 is available
debconf version 1.5.41ubuntu1 required, but 1.5.41ubuntu2 is available
passwd version 1:4.1.4.2+svn3283-3ubuntu3 required, but 1:4.1.4.2+svn3283-3ubuntu4 is available
libglib2.0-0 version 2.31.16-0ubuntu1 required, but 2.31.16-0ubuntu2 is available
gcc-4.6-base version 4.6.2-12ubuntu1 required, but 4.6.2-14ubuntu1 is available
ifupdown version 0.7~beta2ubuntu3 required, but 0.7~beta2ubuntu4 is available
libnih-dbus1 version 1.0.3-4ubuntu7 required, but 1.0.3-4ubuntu8 is available
libstdc++6 version 4.6.2-12ubuntu1 required, but 4.6.2-14ubuntu1 is available

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace
jlb181 (jeffery-birkhofer) wrote :

Was using tDash to get to previously opened images.

Just installed newset updates and got this crash too.

Diska (discardi-nicola) wrote :

all update but crash happened

Changed in unity-lens-applications (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed

I got this when trying to reproduce bug 933760. Unity 5.2.0-0ubuntu5 has been extremely buggy for me.

I installed a fresh version of 12.04 (dated 17th Feb). At install I unticked the download updates while installing.

Once installed I logged into Ubuntu and selected Updated Manager from the Dash. That didn't load and instead I got this error.

Now nothing will run from Dash.

Tony Themelis (tony-athemelis) wrote :

I have the exact same problem as n_s_simpson. Performed an update/upgrade yesterday (took me from Unity 5.2 to Unity 5.4). Also, I have Ubuntu Tweak installed - not sure if that makes a difference. And now nothing will run from the dash.

Jeff Obadal (w-jeffrey-k) wrote :

I had this problem, and could find no way to solve it using the affected account. Later I logged in using a different account(Simplified Chinese if that matters). It did not have the same problem as my main account. Logged out and logged back into my main account(US English) and the problem was gone.

John Belton (jbelton1950) wrote :

I had a problem flag up when I opened an existing file, it opened OK but the error flag opened on top of it. This happened before when using the dash, if I go to the file through the home folder and sub folders the flag doesn't seem to appear.
It appears mre irritating than serious.
John

I got this crash again, and got the same result this time as in comment #13. It rendered the Applications Lens completely empty and the problem went away after logging out and back in.

mike stewart (mdrmike) wrote :

Upgraded from 11.10. During install I unticked the download updates while installing. Initial install complained about not being able to upgrade all packages.

Once upgraded 'finished' -- I rebooted and logged into Ubuntu.

* Installed synaptic package manager.
    * Added canonical partner repositories.
    * Clicked Synaptic "Reload" button -- then it crashed -- suggesting I report a bug if problems persist but that it may be due to outdated packages. (sorry, going off memory)

* So then, I selected Updated Manager from the Dash. Also complained about out-dated packages -- and suggested partial upgrade.
* I ran partial upgrade. (walked away for 30min)
* Came back to an error installing something (clicked on more details and got an error 'permission denied' when trying to access report)
* In a background dialog, also had error message couldn't update CUPS. (perhaps that was the previous problem?)
* Upgrade continued. suggested removing two unneeded packages... so I did. finished 'successfully.'
* rebooted
* attemted to login to run update-manager again, and dash unresponsive -- here I am.

Fresh installation of Ubuntu 12.04. No tweaks whatsoever. After login I wasn't able to start any application, then I got the message that some application-demon crashed. I was just going to report the bug, but this one is it.

I just got this crash again after searching for Swell Foop in the dash, playing it, closing it, re-opening the dash and clicking its icon in there again. Again, it left the Applications Lens empty and unusable, and clicking any applications shown in Recent Apps causes no response.

Note: it appears this crash also takes out the Alt+F2 run dialog, preventing me from running `unity --replace` that way and instead having to log out or run it in a terminal. Either method restores the Applications Lens and Alt+F2, and Recent Apps items once again become responsive.

Rory Holland (blazemore) wrote :

This prevents the user from selecting an application to run.

Applications can be searched for and highlighted, but clicking an application to run does nothing.

John Belton (jbelton1950) wrote :

This still happens on selection of an icon.

John Belton (jbelton1950) wrote :

This is happening again, I can't even open Terminal from the Dash and the select options don't do anything.
This is ona new install of 12.04 beta1 as an upgrade to a Wubi install.
John

John Belton (jbelton1950) wrote :

This problem has recured even after a complete reinstall yesterday, attempting to open the Terminal using the Dash failed and it seemed to lockup the system so nothing could be opened then the error flag was raised. I noticed that none of the icons on the bottom of the dash did anything either. This may be something different to the previous fault but looks too similar to me to not be from the same cause.
John

John Belton (jbelton1950) wrote :

I've just tried again and noticed the "files" icon seems to work but the "applications" icon doesn't, I can't be sure about the others as I haven't got any "music" or "videos" on this installation yet, but there are all the pre-installed applications that don't appear or do anything.

John Belton (jbelton1950) wrote :

After updating today I tried several icons on the Dash selection and it worked the first time after rebooting but failed to respond to any second or third selection. It also failed to open any application whith it's name typed in full after the first attempt to run another application. I hope this can guide someone where to look for this problem. It has affected both my Wubi installs on my Desktop and Laptop.
John

Bart Willemsen (b-willemsen8) wrote :

Crashed here too with I think the same error message.

Mike L (mikerl) wrote :

Ditto. Very annoying bug!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers