lightdm shutdown opens a window without focus

Bug #986289 reported by C de-Avillez on 2012-04-20
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
Low
Michael Terry
unity-greeter (Ubuntu)
Medium
Unassigned
Precise
Medium
Michael Terry

Bug Description

[Impact]
Users cannot shutdown from the greeter screen using only the keyboard. This means that some users that rely on accessibility features cannot shutdown from the greeter at all. (or devices that don't have a pointer at all)

[Test Case]
1) Go to the greeter.
2) Press F10.
3) Press Down and Enter to select "Shut Down"
4) Try to press tab, or left and right, to select the buttons in the dialog that pops up

[Regression Potential]
A potential fix may cause problems restoring focus to the user list after the dialog disappears. Or maybe issues with the onscreen keyboard staying on top of the screen as we move focus around.

Related branches

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/986289

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what greeter do you use? the gtk one or the unity one?

Changed in lightdm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
C de-Avillez (hggdh2) wrote :

The unity one. I am still to check on the GTK one.

Changed in lightdm (Ubuntu):
status: Incomplete → New
C de-Avillez (hggdh2) wrote :

Actually, I would say both -- the description states lightdm-gtk-greeter is installed (so this was the environment I checked), and I just repeated it under the unity greeter.

Changed in lightdm:
importance: Undecided → Low
Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in lightdm (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Low
status: New → Triaged
affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
affects: lightdm → unity-greeter
Michael Terry (mterry) on 2012-05-29
Changed in unity-greeter:
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Matt Fischer (mfisch) wrote :

I'm fairly sure that fixing this will also fix this one:

#933990 Unable to confirm shutdown using only keyboard

Since that dialog is tab-able in normal unity, I think it has problems due to focus.

Michael Terry (mterry) on 2012-09-14
Changed in unity-greeter (Ubuntu):
importance: Low → Medium
Changed in unity-greeter (Ubuntu Precise):
importance: Low → Medium
Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-greeter:
status: In Progress → Fix Released
Michael Terry (mterry) on 2012-09-14
description: updated
Michael Terry (mterry) wrote :

I backported the latest focus handling code from upstream and uploaded it as unity-greeter 0.2.8-0ubuntu1.3 in precise-proposed.

Hello C, or anyone else affected,

Accepted unity-greeter into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-greeter/0.2.8-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-greeter (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
C de-Avillez (hggdh2) wrote :

Verified original issue on Precise, and verified I can now move around the options with tabs. Tagging verification-done.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.8-0ubuntu1.3

---------------
unity-greeter (0.2.8-0ubuntu1.3) precise-proposed; urgency=low

  * debian/patches/fix-focus.patch:
    - Backport better keyboard focus handling from upstream as new windows
      appear and disappear. This fixes keyboard navigation in dialogs
      (LP: #986289) and the onboard keyboard not showing up on startup
      if it was enabled before (LP: #1051946)
 -- Michael Terry <email address hidden> Fri, 14 Sep 2012 15:47:42 -0400

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
Paul Crawford (psc-sat) wrote :

There is still an underlying issue of "discover-ability" here and it fails, in my view, to be acceptable for a disabled user:

(1) Why does the tab key not cycle to the shutdown menu? Where exactly will a user, faced with the log-in screen, find out that the 'F10' key opens that menu?

(2) The tab key only cycles between the log-in method (e.g. Gnome, Unity, etc, and not the user list) and the entry window for the current account's password. How would a keyboard-only user change account?

Paul Crawford (psc-sat) wrote :

OK, I just discovered that the up & down arrow keys cycle the user accounts, but they do not cycle the log-in method! For that you need to use the tab key!

How do you get access to the accessibility drop-down menu on the to bar?

Same for the keyboard/language selection?

Also why no 'F1' for help on any of this? If it were obvious/discoverable using the tab key that would not be needed, but there seems to be a non-obvious mix of methods and some I have not been able to discover yet (as noted above).

Paul Crawford (psc-sat) wrote :

Realised this is separate issue so opening new bug for it as #1071728

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers