no reaction on shortly pressing power button

Bug #903306 reported by Fritz Heinrichmeyer on 2011-12-12
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
unity-greeter (Ubuntu)
Medium
Robert Ancell

Bug Description

I think this is a regression:

Somewhere in the past shutdown or an appropriate dialog to shutdown or reboot came up.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-greeter 0.1.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Mon Dec 12 18:47:44 2011
SourcePackage: unity-greeter
UpgradeStatus: Upgraded to oneiric on 2011-10-21 (52 days ago)

summary: - no reaction on short pressing power button
+ no reaction on shortly pressing power button
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Andres Muniz (andresmp) wrote :

i can confirm this happens on 32 bit ubuntu 11.10 and xubuntu 11.10 (they seem to use the same greeter).

it is anoying when a todler turns on computer but not tv screen.

also if turned on computer but not overhead projector.
you want a) avoid turn on screen and b) avoid "hard" shutdown.

I experience this bug in 11.10 + updates for AMD64. There are other sightings on the web:
 <https://lists.ubuntu.com/archives/ubuntu-uk/2011-December/032588.html>
 <https://forums.virtualbox.org/viewtopic.php?f=3&t=46554>

I don't know if this is a unity-greeter bug or a bug in acpid's /etc/acpi/powerbtn.sh

It looks to me as if /etc/acpi/powerbtn.sh tries hard to find the X user to figure out what to do but that when unity-greeter is running there is no user. Mind you, /etc/acpi/powerbtn.sh ends with "if all else fails, shutdown -h now".

Before unity-greeter, this wasn't a problem.

All-in-all, I'd guess that this is a unity-greeter bug.

Why do I care? Because sometimes my computer is headless and it is awkward to shut it down cleanly without the power button functioning as it should.

See also <https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/792242> "power button shuts down immediatly (no warning)"

This seems to be a different manifestation of what is likely the same problem.

David Henningsson (diwic) wrote :

Confirmed under 12.04 as well.

tags: added: precise
Changed in unity-greeter (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Nick Jenkins (nickpj) wrote :

I have a desktop with USB keyboard & mouse, and a motherboard (MSI G31M3) that intermittently (around 1 boot in 15) fails to initialise USB correctly in the BIOS. Unplugging and re-plugging USB devices doesn't help, the whole subsystem is non-functional, the only thing that works is to reboot.

For those boots when I have no functioning input device, in Ubuntu 11.04 and before, the power button on the case was my input device, because it could be pressed briefly, and the computer would then shut itself down cleanly after 60 seconds, and then I could boot again normally, and the USB problem was easily worked around. But from 11.10 onwards, this no longer works, so all I can do is a forced power-off, with resulting possible disk data corruption problems. It would be really good to have this functionality back.

fabioamd87 (fabioamd87) wrote :

guys seems that on my machine everything work now, can you control on yours?

Nick Jenkins (nickpj) wrote :

> on my machine everything work now, can you control on yours?
No, it's still present as a problem in Ubuntu 13.04 Raring. Pressing the power button _after_ logging in will bring up the shutdown dialog - but at the greeter/login screen, pressing the power button still does nothing, so it's still an issue.

Robert Ancell (robert-ancell) wrote :
Changed in unity-greeter (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 14.04.0-0ubuntu1

---------------
unity-greeter (14.04.0-0ubuntu1) trusty; urgency=low

  * New upstream release:
    - Use Unity style shutdown dialogs (LP: #857577)
    - Handle hardware power button in greeter (LP: #903306)
    - Use an Upstart process to start indicator services (LP: #1185565)
    - Fix build with Vala 0.22
    - Clean up compile warnings
 -- Robert Ancell <email address hidden> Mon, 11 Nov 2013 17:16:17 +1300

Changed in unity-greeter (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers