Greeter logo needs to be updated for 12.04

Bug #892394 reported by Colin Watson on 2011-11-18
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
Medium
Xi Zhu
unity-greeter (Ubuntu)
Medium
Robert Ancell
Precise
Medium
Robert Ancell

Bug Description

The unity-greeter logo still claims to be Ubuntu 11.10 in precise. This should be updated to 12.04.

(It's a shame that this is a .png rather than rendering the version number on the fly based on lsb-release ...)

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
tags: added: precise
Robert Ancell (robert-ancell) wrote :

It used to render on the fly but the exact positioning of the text turned out to be too hard.

Changed in unity-greeter (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Request for asset sent to Xi

Changed in unity-greeter:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Xi Zhu (xi.zhu)
tags: added: rls-mgr-p-tracking
tags: added: iso-testing
Martin Pitt (pitti) on 2011-11-30
Changed in unity-greeter (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
assignee: nobody → Robert Ancell (robert-ancell)
Xi Zhu (xi.zhu) wrote :

Can anyone attach a screen grab please? Which one is greeter logo?

Colin Watson (cjwatson) wrote :

The file name on your system (assuming you're running 11.10 or precise) is:

  /usr/share/unity-greeter/logo.png

Kate Stewart (kate.stewart) wrote :

Would like to see this fixed much sooner than beta-1 please. Its a bad first impression to have it still refering to the prior release.

Xi Zhu (xi.zhu) wrote :

Here is the logo in vector. :)

John Lea (johnlea) wrote :

@robert-ancell; is the attached logo good, or would you like it exported in raster format.

Robert Ancell (robert-ancell) wrote :

Yes, can you please convert it to raster (I just tried with Inkscape but the sizing and spacing is completely different to the current logo). It needs to have the same position relative to the top level of the old one to be placed correctly. You can test by overwriting the current one with the following command from a terminal:
$ sudo cp logo.png /usr/share/unity-greeter/logo.png

Xi Zhu (xi.zhu) wrote :

Hi Robert,

Because the size of logo has been scaled down a bit, the space to left and top edge are both correct in the svg file, should be fine to replace the old one. And I attached the png file as a reference.

Adolfo Jayme (fitojb) wrote :

I've replaced my greeter's logo with the new one provided by Rosie. Looks much better proportioned.

The unity greeter logo has been attached as a simple tar.gz file for simple patching. tar zxvf unity_greeter_logo_precise.tar.gz -C /

New debian package with patch!

i have install the patch and its work and solve the issue but when i do the system update and upgrade ... its show a unity-greeter update in the list but when the upgrade finish .. the logo turn back to 11.10

Get:41 http://us.archive.ubuntu.com/ubuntu/ precise/main unity-greeter i386 0.1.1-0ubuntu1 [53.0 kB]

then i go check the /usr/share/unity-greeter/logo.png .. it go back to 11.10

can someone verify this?

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/892394

Changed in unity-greeter (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in unity-greeter:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.0-0ubuntu1

---------------
unity-greeter (0.2.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - Improve scrolling animation (LP: #844050)
    - Select menubar when F10 is pressed
    - Fix Orca not starting when enabling screen reader (LP: #850554)
    - Add a keyboard indicator (LP: #783827, LP: #834487)
    - Always focus new windows
    - Check version of Vala when compiling
    - Update logo for 12.04 (LP: #892394)
    - Use default invisible character in password dialog (LP: #834878)
    - Darken indicator bar
    - User smaller grid size
    - Put end-stops on user list scrolling
    - Only fade out user labels that can't fit in completely (LP: #883260)
    - Center dots (LP: #872800)
    - Add translator comments (LP: #855385)
    - Add option to disable dots (LP: #883908)
    - Only redraw parts of the screen that have changed
    - Don't run the greeter if can't connect to daemon and not in test mode
      (LP: #876754)
 -- Robert Ancell <email address hidden> Thu, 19 Jan 2012 14:56:21 +1100

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-greeter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers