[regression] Some Display settings have gone missing: Scale, Launcher placement

Bug #1629668 reported by Patrick Johnson on 2016-10-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Critical
Robert Ancell

Bug Description

There appear to be other options missing as well. They should be under "General options" but there is nothing there.

Ubuntu Yakkety Yak (development branch)

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: unity-control-center 15.04.0+16.10.20160705.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-17.19-generic 4.8.0-rc7
Uname: Linux 4.8.0-17-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Sun Oct 2 09:56:19 2016
ExecutablePath: /usr/bin/unity-control-center
InstallationDate: Installed on 2016-09-29 (3 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160922)
ProcEnviron:
 LANG=en_US.UTF-8
 LANGUAGE=en_US
 PATH=(custom, user)
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
SourcePackage: unity-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

description: updated
description: updated
summary: - Display settings does not have option to disable launcher on 2nd monitor
+ Some Display settings have gone missing: Scale and the option to disable
+ launcher on 2nd monitor

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

This is a big deal. Without the Scale slider Yakkety is now unusable on high DPI displays.

Changed in unity-control-center (Ubuntu):
importance: Undecided → High
summary: - Some Display settings have gone missing: Scale and the option to disable
- launcher on 2nd monitor
+ Some Display settings have gone missing: Scale, Launcher placement
tags: added: regression

Weird because I can see it here:
/usr/share/unity-control-center/ui/display-capplet.ui

summary: - Some Display settings have gone missing: Scale, Launcher placement
+ [regression] Some Display settings have gone missing: Scale, Launcher
+ placement
Robert Ancell (robert-ancell) wrote :

This is due to XDG_CURRENT_DESKTOP now containing more than one value, i.e. it is "Unity:Unity7" when it used to be "Unity". u-c-c is still incorrectly doing a simple string comparison to check if it is running under Unity. Looks like this fix for this never got completed / applied (bug 1554878).

Changed in unity-control-center (Ubuntu):
status: Confirmed → Triaged
importance: High → Critical
Changed in unity-control-center (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Daniel van Vugt (vanvugt) wrote :

Seems to be fixed today. But what fixed it?

Robert Ancell (robert-ancell) wrote :

gnome-session (3.20.2-1ubuntu6) yakkety; urgency=medium

  * Set DesktopNames back to Unity. There are many buggy components that don't
    know how to deal with XDG_CURRENT_DESKTOP having multiple values, and it's
    too close to the release to fix them all.

 -- Iain Lane <email address hidden> Mon, 03 Oct 2016 17:37:57 +0100

Changed in unity-control-center (Ubuntu):
status: Fix Committed → Invalid
Robert Ancell (robert-ancell) wrote :

Marking invalid since it no longer occurs - it will be fixed by the linked branch ultimately which will allow gnome-session to update XDG_CURRENT_DESKTOP if they want.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+16.10.20161003.1-0ubuntu1

---------------
unity-control-center (15.04.0+16.10.20161003.1-0ubuntu1) yakkety; urgency=medium

  [ Robert Ancell ]
  * Don't check if we're running under Unity - we only support Unity
    (LP: #1554878, #1629668)
  * Ubuntu only supports usernames with lowercase letters. (LP:
    #1600638)

  [ Sebastien Bacher ]
  * Revert the change from r12750 to include only graphical sessions.
    (LP: #1380364)

  [ <email address hidden> ]
  * Removed "when battery is critical" functionality from the power
    panel as this is now handled by Upower and these settings now do
    nothing. Fixes LP: #1599264 (LP: #1599264)

 -- <email address hidden> (<email address hidden>) Mon, 03 Oct 2016 11:19:09 +0000

Changed in unity-control-center (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers