unity-2d-shell crashed with SIGSEGV in QCoreApplication::notifyInternal()

Bug #918566 reported by Alberto Mardegan on 2012-01-19
120
This bug affects 13 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Paweł Stołowski
qt-at-spi (Ubuntu)
Undecided
Unassigned
qt4-x11 (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Critical
Paweł Stołowski

Bug Description

Have gconf-editor installed.
1) Search for "gconf" in the dash -- no results
2) then delete the search text, and write "conf"

For some reason, it seems that typing "conf" crashes the dash all the times in my machine.
Orca was running
ProblemType: CrashDistroRelease: Ubuntu 12.04
Package: unity-2d-places 5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
Date: Thu Jan 19 09:03:59 2012
ExecutablePath: /usr/bin/unity-2d-placesInstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: /usr/bin/unity-2d-places
SegvAnalysis:
 Segfault happened at: 0x7f7724e5340d <_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+125>: mov 0x40(%rax),%rbx
 PC (0x7f7724e5340d) ok
 source "0x40(%rax)" (0x00000091) not located in a known VMA region (needed readable region)!
 destination "%rbx" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: unity-2d
StacktraceTop:
 QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 QAccessible::queryAccessibleInterface(QObject*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QAccessible::updateAccessibility(QObject*, int, QAccessible::Event) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtDeclarative.so.4
 QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
Title: unity-2d-places crashed with SIGSEGV in QCoreApplication::notifyInternal()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Alberto Mardegan (mardy) wrote :
visibility: private → public
Alberto Mardegan (mardy) wrote :

I notice only now from the stack trace, that accessibility was probably enabled.

StacktraceTop:
 QCoreApplication::notifyInternal (this=0x7fff3f76f2d0, receiver=0x3ca1480, event=0x7fff3f76e840) at kernel/qcoreapplication.cpp:863
 sendEvent (event=0x7fff3f76e840, receiver=0x3ca1480) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
 QAccessible::queryAccessibleInterface (object=0x3ca1480) at accessible/qaccessible.cpp:591
 QAccessible::updateAccessibility (o=<optimized out>, who=0, reason=QAccessible::LocationChanged) at accessible/qaccessible_unix.cpp:102
 QDeclarativeAccessibilityUpdater::sendPostedGeometryUpdates (this=0xa7b100) at util/qdeclarativeaccessibility.cpp:203

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

In my case it crash with orca running
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

description: updated
description: updated

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/918707

tags: added: iso-testing
Gerry Boland (gerboland) on 2012-01-19
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Changed in unity-2d (Ubuntu):
importance: Medium → High
Changed in unity-2d:
milestone: none → 5.2.1

I'm unable to reproduce with today's Precise. You guys running Oneiric?

Gerry Boland (gerboland) wrote :

I can reproduce on Precise. Ignore above comment.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt-at-spi (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: 5.2.1 → 5.6
Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
Paweł Stołowski (stolowski) wrote :

I'm unable to reproduce on today's Precise.

Paweł Stołowski (stolowski) wrote :

I was able to reproduce the same crash by switching lenses in the dash:
1. Enable screen reader (Oraca): System Settings -> Universal Access -> Screen Reader
2. Log out & log in. Verify that QT_ACCESSIBILITY=1 environment variable is set.
3. Close Orca window (probably irrelevant, but that's what I did).
4. Open dash
5. Switch between lenses, repeat until it crashes.

The original recipe with "gconf" search string in the dash doesn't seem to reproduce the problem anymore.

Paweł Stołowski (stolowski) wrote :

A couple of observations:
1. It seems that the crash occurs only when switching between Video- or Music- lens to any other lens.
2. There are a lot of qt-at-spi warnings related to unsupported events, e.g.
.....
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: QDeclarativeColumn(0x8c50ba8) ""
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: TextCustom_QMLTYPE_29(0x902b8b8) ""
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: TextCustom_QMLTYPE_29(0x90bc010) ""
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: QDeclarativeItem_QML_60(0x90a9578) ""
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: QDeclarativeColumn(0x90cf0a8) ""
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: TextCustom_QMLTYPE_29(0x8ff8718) ""
unity-2d-shell: [WARNING] QSpiAccessible::accessibleEvent not handled: "800b" obj: TextCustom_QMLTYPE_29(0x90d9478) "
......

if you look at stacktrace frame for QDeclarativeAccessibilityUpdater::sendGeometryUpdate method call, its 'item' argument corresponds to one of the QDeclarativeColumn objects displayed in qt-at-spi warnings, e.g.

#6 0xb6e6b163 in QDeclarativeAccessibilityUpdater::sendGeometryUpdate (this=0x81b4c2c, item=0x90cf0a8)

and it's always QDeclarativeColumn for every crash I experienced.

The warning should not be relevant. It just means the bridge ignores some a11y updates. ([WARNING] QSpiAccessible::accessibleEvent not handled)

Paweł Stołowski (stolowski) wrote :
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Gerry Boland (gerboland) on 2012-03-27
summary: - unity-2d-places crashed with SIGSEGV in
+ unity-2d-shell crashed with SIGSEGV in
QCoreApplication::notifyInternal()
Gerry Boland (gerboland) on 2012-03-27
Changed in unity-2d:
importance: High → Critical
Changed in unity-2d (Ubuntu):
importance: High → Critical
Gerry Boland (gerboland) on 2012-03-27
tags: added: a11y
Changed in qt-at-spi (Ubuntu):
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
Paweł Stołowski (stolowski) wrote :

I had dicussed this problem via email and IRC with Frederik Gladhorn (who implemented a11y changes that we have in kubuntu_97_a11y_qt_and_qml_backport.diff patch) and he blamed geometry/location updates of that patch for the problem. He suggested removal of these pieces of code from the kubuntu_97_a11y_qt_and_qml_backport patch as they are considered as *useless. I've linked a branch that amends this patch - with this change I can no longer reproduce the crash.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2012-04-10
Changed in unity-2d:
assignee: nobody → Pawel Stolowski (stolowski)
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.1-0ubuntu3

---------------
qt4-x11 (4:4.8.1-0ubuntu3) precise; urgency=low

  * kubuntu_97_a11y_qt_and_qml_backport.diff from upstream: removed geometry and animation updates
    because they are useless and the code is buggy, leading to crashes (LP: #918566).
 -- Pawel Stolowski <email address hidden> Mon, 09 Apr 2012 18:55:11 +0200

Changed in qt4-x11 (Ubuntu):
status: Confirmed → Fix Released
Gerry Boland (gerboland) on 2012-04-11
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.10.0-0ubuntu1

---------------
unity-2d (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in
      QCoreApplication::notifyInternal() (LP: #918566)
    - Unity-2d-shell crashes on startup on 64bit machines with 20+ tiles in
      launcher (LP: #967012)
    - Unity 2-d launcher doesn't hide or display properly (LP: #940590)
    - [dash] search terms aren't applied on lens change / dash show
      (LP: #947985)
    - [5.8 pre staging] "sticky edge" option does nothing visible
      (LP: #961285)
    - [dash] Maximise, then restore - much of background not removed from
      screen (LP: #968215)
    - [hud] shows up when using ctrl+alt and pressing alt first (LP: #972318)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - [dash] Unable to scroll Filter Results (LP: #920878)
    - [launcher] stays open if you mouseOut before reveal animation completes
      (LP: #943296)
    - HUD on wrong screen on mutli monitor system (LP: #947145)
    - [a11y] Orca reports "Shell" when opening HUD, Dash or Launcher
      (LP: #948033)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - [dash] Esc key behavior inconsistent with Unity (LP: #966121)
    - toggling the spread from the launcher does not work (LP: #968146)
    - unity-2d-shell crashed with SIGSEGV in KeyMonitor::registerEvents()
      (LP: #965464)
    - [Dash] Focus is lost when switching with the mouse (LP: #974235)
    - Multiple items selected in HUD list (LP: #948441)
    - Hud hides launcher even if set to always show (LP: #948960)
    - [launcher] Pointer reveal barrier should be 1 way only (LP: #960175)
    - [hud] connection to HUD being created on startup (LP: #965106)
    - [dash] On 1024x786 screen, dash not fullscreen so border truncated
      (LP: #967305)
  * debian/20_ubuntu-2d-gconf-default:
    - set a default key for HUD showing on Alt, in case unity-3d isn't
      installed or run before unity-2d.
  * debian/control:
    - bump libnux-2.0-dev to latest for ABI break
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:02:08 +0200

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers