DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from environment making gedit and possibly others fail to start

Bug #873027 reported by Stéphane Graber on 2011-10-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Oneiric
Undecided
Unassigned
unity-2d
High
Unassigned
unity-2d (Ubuntu)
High
Chris Coulson
Oneiric
High
Unassigned
Precise
High
Chris Coulson

Bug Description

SRU note:

[Impact]

Anyone using unity-2d and also using gedit, which can affect a number of machines for which there are no 3d drivers, eg underpowered netbooks.

[Fix]
See lp:~jm-leddy/ubuntu/oneiric/unity-2d/unsetenvvariables

[Test Case]

1) Switch to unity-2d on login
2) Start up Gedit
3) observe gedit does not start

[Regression Potential]
Small, we've been running this patch in precise without issue. Additionally, it's just a 3 line change to unset an env variable.

[Original report]

ISO testing showed that sometimes, only on Unity 2D (so far), DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't unset from the environment when starting a new software.

This breaks gedit as it's actually checking these variables for its own DBUS activation

Related branches

Changed in unity-lens-applications (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → oneiric-updates
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Canonical Desktop Team (canonical-desktop-team)
Kate Stewart (kate.stewart) wrote :

This may well be related to the symptoms seen in https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/827414 (was closed as invalid).

affects: unity-lens-applications (Ubuntu Oneiric) → unity-2d (Ubuntu Oneiric)
Changed in unity-2d (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Coulson (chrisccoulson)
Alberto Mardegan (mardy) wrote :

An easy way to reproduce it is to kill unity-2d-launcher: it will get automatically restarted, and then the DBUS_* variable will be set.

Changed in unity-2d:
milestone: none → 4.14
status: New → Confirmed
importance: Undecided → High
Changed in unity-2d:
status: Confirmed → Fix Committed
Changed in unity-2d (Ubuntu Precise):
milestone: oneiric-updates → none
Changed in unity-2d:
milestone: 4.14 → 5.2
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu Precise):
status: Confirmed → Fix Released
tags: added: rls-mgr-o-tracking
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
importance: Undecided → High
James M. Leddy (jm-leddy) wrote :

I've tested the branch at lp:~chrisccoulson/unity-2d/lp873027 and it definitely fixes the problem.

James M. Leddy (jm-leddy) wrote :

[Impact]

Anyone using unity-2d and also using gedit, which can affect a number of machines for which there are no 3d drivers, eg underpowered netbooks.

[Test Case]

1) Switch to unity-2d on login
2) Start up Gedit
3) observe gedit does not start

[Regression Potential]
Small, we've been running this patch in precise without issue. Additionally, it's just a 3 line change to unset an env variable.

description: updated
James M. Leddy (jm-leddy) wrote :

Hello,

Please test https://launchpad.net/~jm-leddy/+archive/lp873027 and let me know if that fixes the problem.

Changed in unity-2d (Ubuntu Oneiric):
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu Oneiric):
status: In Progress → Incomplete
Ding Zhou (tualatrix) wrote :

@jm-leddy

Hi James,

I have tested this PPA, and tried to open the Gedit for many times, this bug has been fixed. Thanks.

Changed in unity-2d (Ubuntu Oneiric):
status: Incomplete → Confirmed
Changed in unity-2d (Ubuntu Oneiric):
status: Confirmed → In Progress
Changed in oem-priority:
status: New → In Progress
Dimitri John Ledkov (xnox) wrote :

The proposed branch needs fixing, see comments on the merge proposal.
Unsubscribing ubuntu-sponsors.
Please request a review from ubuntu-branches in the merge-proposal & re-subscribe ubuntu-sponsors team for a new review.

James M. Leddy (jm-leddy) wrote :

Thanks for the heads up. I accidentally cherry picked from the devel branch, which caused the issue. The resubmission should be good.

Bryce Harrington (bryce) on 2012-09-13
description: updated
description: updated
Changed in oem-priority:
status: In Progress → Fix Released
Changed in oem-priority:
status: Fix Released → In Progress
Dimitri John Ledkov (xnox) wrote :

unsubscribing sponsors, as the branch is updated/submitted for sponsorship.

Dimitri John Ledkov (xnox) wrote :

uploaded, now waiting in the oneiric-proposed unapproved queue.

James M. Leddy (jm-leddy) wrote :

Hi Dmitrijs, Thanks much!

Changed in unity-2d (Ubuntu Oneiric):
assignee: Chris Coulson (chrisccoulson) → nobody

Hello Stéphane, or anyone else affected,

Accepted unity-2d into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-2d/4.12.0-0ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-2d (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in oem-priority:
status: In Progress → Fix Committed
James M. Leddy (jm-leddy) wrote :

tested with 4.12.0-0ubuntu1.4

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.12.0-0ubuntu1.4

---------------
unity-2d (4.12.0-0ubuntu1.4) oneiric-proposed; urgency=low

  [ Chris Coulson ]
  * DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
    environment making gedit and possibly others fail to start (LP: #873027)
 -- James M Leddy <email address hidden> Fri, 31 Aug 2012 15:04:49 -0400

Changed in unity-2d (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers