unity-2d-launcher crashed with SIGSEGV in exit()

Bug #859596 reported by André Barmasse on 2011-09-26
74
This bug affects 11 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Gerry Boland
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

Starting an xubuntu session crashes unity-2d. Why is it starting anyway, when I am loggin into a xubuntu session??

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-launcher 4.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Mon Sep 26 14:11:02 2011
ExecutablePath: /usr/bin/unity-2d-launcher
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcCmdline: unity-2d-launcher
ProcEnviron:
 LANGUAGE=de_CH:de
 PATH=(custom, no user)
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x427934: mov 0x8(%edx),%edx
 PC (0x00427934) ok
 source "0x8(%edx)" (0xa4f67060) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 exit () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
 _XIOError () from /usr/lib/i386-linux-gnu/libX11.so.6
 _XReadEvents () from /usr/lib/i386-linux-gnu/libX11.so.6
Title: unity-2d-launcher crashed with SIGSEGV in exit()
UpgradeStatus: Upgraded to oneiric on 2011-09-12 (14 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (xfwm4:1469): GLib-CRITICAL **: g_str_has_prefix: assertion `prefix != NULL' failed
 (xfce4-settings-helper:1552): GLib-CRITICAL **: g_str_has_prefix: assertion `prefix != NULL' failed
 (xfwm4:1469): xfwm4-WARNING **: The property '/general/double_click_distance' of type int is not supported
 (xfce4-panel:1471): libxfce4ui-WARNING **: ICE I/O Error
 (xfce4-panel:1471): libxfce4ui-WARNING **: Disconnected from session manager.

Related branches

André Barmasse (barmassus) wrote :

StacktraceTop:
 __run_exit_handlers (status=1, listp=0x56d324, run_list_atexit=true) at exit.c:50
 __GI_exit (status=1) at exit.c:100
 qt_xio_errhandler () at kernel/qapplication_x11.cpp:781
 _XIOError (dpy=0x9b20128) at ../../src/XlibInt.c:1618
 _XReadEvents (dpy=0x9b20128) at ../../src/xcb_io.c:442

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Didier Roche (didrocks) on 2011-10-07
visibility: private → public
Changed in unity-2d:
importance: Undecided → Critical
milestone: none → 4.14
Alberto Mardegan (mardy) wrote :

I'll try to investigate this.

Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :

Got some other bugs to attend to, so I'll leave this unassigned for the time being :-)

Changed in unity-2d:
assignee: Alberto Mardegan (mardy) → nobody
Gerry Boland (gerboland) on 2011-10-10
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
Gerry Boland (gerboland) wrote :

I cannot reproduce this. André, can you still get this?

Investigating this, I see that the KeyMonitor has a thread which watches for all keyboard events with XNextEvent. If the Xserver shuts down, XNextEvent will fail and calls _XIOError which calls any error handler if defined (to quit). Qt installs an error handler qt_xio_errhandler to print an error & quits (exit(1)). During this exit, I believe a thread isn't stopping cleanly.

Gerry Boland (gerboland) on 2011-10-31
Changed in unity-2d:
status: Confirmed → In Progress
Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
milestone: 4.14 → 5.2
Gerry Boland (gerboland) on 2011-11-28
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers