unity-2d-places crashed with SIGABRT in raise()

Bug #857575 reported by SlugiusRex on 2011-09-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Tiago Salem Herrmann
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

in the middle of performing aptitude update ...

ran ~$ sudo apport-collect -p linux 851422

recieved notification that Google Chrome cannot be run as root

popup messages was observed

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-places 4.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Fri Sep 23 09:57:37 2011
ExecutablePath: /usr/bin/unity-2d-places
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
ProcCmdline: /usr/bin/unity-2d-places
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: unity-2d
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/libunity-2d-private.so.0
 qt_message_output(QtMsgType, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
Title: unity-2d-places crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to oneiric on 2011-08-25 (28 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

SlugiusRex (slugiusrex) wrote :

StacktraceTop:
 Unity2dDebug::unity2dQtHandler (type=QtFatalMsg, message=0x1e81ca8 "Settings schema 'com.canonical.Unity2d' is not installed\n") at /build/buildd/unity-2d-4.10.0/libunity-2d-private/src/unity2ddebug.cpp:89
 qt_message_output (msgType=QtFatalMsg, buf=0x1e81ca8 "Settings schema 'com.canonical.Unity2d' is not installed\n") at global/qglobal.cpp:2240
 qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f41085e9da8 "Settings schema '%s' is not installed\n", ap=0x7fff18279c88) at global/qglobal.cpp:2361
 qFatal (msg=<optimized out>) at global/qglobal.cpp:2544
 QConfSchema::QConfSchema(QString const&) () from /tmp/tmpumsSaF/usr/lib/libdconf-qt.so.0

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2011-11-19
visibility: private → public
Changed in unity-2d:
status: New → Triaged
Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
importance: Undecided → Critical
milestone: none → 5.2
Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
status: Triaged → Confirmed
Changed in unity-2d:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in unity-2d:
status: Confirmed → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers