unity-2d-launcher crashed with SIGSEGV in geis_finish()

Bug #850893 reported by Tim Kornhammar on 2011-09-15
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Gerry Boland
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

Just signed in to ubuntu 11.10 on my x64 system.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-launcher 4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Thu Sep 15 09:06:21 2011
ExecutablePath: /usr/bin/unity-2d-launcher
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: unity-2d-launcher
ProcEnviron:
 PATH=(custom, no user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f9a519dac54 <geis_finish+4>: mov 0x8(%rdi),%rdi
 PC (0x7f9a519dac54) ok
 source "0x8(%rdi)" (0x0000005d) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 geis_finish () from /usr/lib/libutouch-geis.so.1
 GestureHandler::~GestureHandler() ()
 main ()
Title: unity-2d-launcher crashed with SIGSEGV in geis_finish()
UpgradeStatus: Upgraded to oneiric on 2011-09-06 (8 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1838): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed
 (gnome-settings-daemon:1838): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed
 (gnome-settings-daemon:1838): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed
 (gnome-settings-daemon:1838): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

Related branches

Tim Kornhammar (tim-kornhammar) wrote :

StacktraceTop:
 geis_finish (instance=0x55) at geis_v1.c:482
 GestureHandler::~GestureHandler (this=0x7fff6e8339a0, __in_chrg=<optimized out>) at /build/buildd/unity-2d-4.8.0/launcher/app/gesturehandler.cpp:47
 main (argc=1, argv=<optimized out>) at /build/buildd/unity-2d-4.8.0/launcher/app/launcher.cpp:144

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Changed in unity-2d:
importance: Undecided → Critical
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Florian Boucault (fboucault) wrote :

Thanks a lot for the bug report Tim.
Are you using Ubuntu via FreeNX maybe?

Changed in unity-2d:
status: New → Incomplete
Changed in unity-2d (Ubuntu):
status: New → Incomplete
Shelby Cain (alyandon) wrote :

I just received this crash and am using x2go.

Benjamin Heil (benjamin-heil) wrote :

I'm using NX 3.5 Free Edition and see this bug.

Tim Kornhammar (tim-kornhammar) wrote :

No, just a Ubuntu 11.04 upgrade to the 11.10 beta. All I did on my laptop was to start it, I think I'm getting this bug each signin to unity.

Holger Knust (hknust) wrote :

Crashed right after login on 11.10 x64

Changed in unity-2d:
status: Incomplete → New
Changed in unity-2d (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
tr33m4n (tr33m4n) wrote :

Same here, Ubuntu 2D works, however receive this crash when logging into the standard Ubuntu desktop. Thought it might of been an issue with Compiz to be honest...

Changed in unity-2d:
status: New → Confirmed
DanielRoesler (diafygi) wrote :

I got this bug when trying to install Ubuntu on my Macbook Air 4,2 using the instructions from here:
https://help.ubuntu.com/community/MacBookAir4-2

After using the fix-i915.sh script, I rebooted. The login screen appeared normally at full resolution. After I logged in only the desktop background and mouse appeared (mouse was movable with the trackpad). Then, after about 60 seconds, I got an error report that Compiz crashed (submitted Bug #870092). Then about 5 seconds later, I got an error report that 2d-Unity had crashed (which sent me here after I clicked submit report).

Gerry Boland (gerboland) on 2011-10-31
Changed in unity-2d:
status: Confirmed → In Progress
assignee: nobody → Gerry Boland (gerboland)
Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
milestone: none → 5.2
Gerry Boland (gerboland) on 2011-11-21
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers