[panel] graphics corruption in top line of pixels

Bug #846335 reported by Chris Coulson on 2011-09-10
116
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity-2d
High
Gerry Boland
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Since yesterday's update of unity-2d (to 4.6.1-0ubuntu1), I'm seeing a 1 pixel line above the top panel, which appears to be full of garbage. Screenshot attached

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Sat Sep 10 09:55:52 2011
DistributionChannelDescriptor: canonical-test
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: Upgraded to oneiric on 2010-07-07 (429 days ago)

Related branches

Chris Coulson (chrisccoulson) wrote :
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Tan Kah Ping (kahping) wrote :

Not just Unity 2D but Unity as well has this. On my desktop at least it appears to be the wallpaper showing through and not any sort of "garbage".

Using gnome-tweak-tool to change themes, it appears this only affects Ambiance and Radiance

Susanne Schlensog (sschlensog) wrote :

I can confirm Tank Kah Ping's report. Saw it yesterday on my netbook running Unity (3D)

shafin (mahdee-jameel) wrote :

I can confirm this for unity 3D

Changed in unity:
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Chris Gagnon (chris.gagnon) wrote :

I can confirm this in unity 2D, corruption is on both the right and the left part of the panel. See screen shot

Changed in unity-2d:
importance: Undecided → High
milestone: none → 4.8
summary: - Corruption above unity-2d panel with 4.6.1
+ [panel] graphics corruption in top line of pixels
shafin (mahdee-jameel) wrote :

I have this fixed with the latest unity update.

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

While this may be fixed when unity-2d 4.8 releases it hasn't yet and the bug is certainly still present & not 'fix released' yet

Michał Sawicz (saviq) wrote :

What's more I can still reproduce on rev lp:unity-2d @715, so the bug isn't fixed. Maybe it is in unity, but not in unity-2d.

Changed in unity-2d:
status: Fix Released → Confirmed
Gerry Boland (gerboland) on 2011-09-14
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
status: Fix Committed → Fix Released
Pete Graner (pgraner) wrote :

Just tried with unity-2d 4.8.0-0ubuntu1 and the corruption is still there, see attached screen shot.

Changed in unity-2d (Ubuntu):
status: Fix Released → Incomplete
Changed in unity-2d (Ubuntu):
status: Incomplete → Fix Released
Didier Roche (didrocks) wrote :

Seems, Pete still get it, can you have another look Gerry?

Changed in unity-2d (Ubuntu):
status: Fix Released → Triaged
Changed in unity-2d:
status: Fix Released → Triaged
milestone: 4.8 → 4.10
Pete Graner (pgraner) wrote :

For the record this is a Lenovo T410 Laptop with the following graphics.
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated G
raphics Controller (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device 215a
 Flags: bus master, fast devsel, latency 0, IRQ 42
 Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 1800 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
 Capabilities: [d0] Power Management version 2
 Capabilities: [a4] PCI Advanced Features
 Kernel driver in use: i915
 Kernel modules: i915

Colin Law (colin-law) wrote :

If it is relevant, I am seeing it fixed in unity-2d 4.8.0-0ubuntu1, but I note that Pete's screenshot in #9 looks quite different to the symptom I saw, which was just a single pixel row of white dots. Possibly his is a different bug.

Rocko (rockorequin) wrote :

I still see a corrupted top line of pixels in unity 4.8.0. It happens above the menu items or indicators when they are drawn - for instance, while the network-manager icon is flashing to indicate that it is awaiting a DHCP address, pixels above it continually and randomly change colour. I'm using a XPS 15 L502x with Sandy Bridge graphics.

I am still experiencing this bug, which now affects me a bit more than before since 3D Unity seems to no longer want to work for me after this morning's updates.

christopher@Xyz:~$ dpkg -s unity-2d | grep Version
Version: 4.8.0-0ubuntu1

Rocko (rockorequin) wrote :

@Warrioring64: You could try the Gnome-shell session. It's a lot more stable than Unity 3D at the moment, although it would be nicer if it had global menus and a launcher that remained on-screen permanently.

@Rocko: Trust me, at this point I am very tempted to. I'm trying to stick it out though to better test Unity as the default interface, and I have run GNOME Shell from git on my desktop before during 10.10 and got very bad performance from it (I was using the proprietary NIVIDIA drivers at the time, which is probably to blame...I don't know how much better nouveau would be now that I switched to that).

Gerry Boland (gerboland) wrote :

@Pete @Rocko @Warrioring64
the 4.10 release tomorrow will contain the fix. If you still see the problem then, please report here!

I'm using today's PPA version: 4.8-0ubuntu1~bzr721 and I'm bad-pixel free.
-Gerry

Rocko (rockorequin) wrote :

The corruption is gone now that libunity-2d-private0 and unity-2d-panel have updated to 4.8.0 - thanks, it looks much better now.

Pete Graner (pgraner) wrote :

@Gerry

That did the trick works for me now.

Thanks

I just ran some updates a little while ago, and it seems the problem is now gone.

bug is no more present in unity-2d

Gerry Boland (gerboland) wrote :

Great, thanks for the confirmation everyone!

Changed in unity-2d:
status: Triaged → Fix Released
Changed in unity-2d (Ubuntu):
status: Triaged → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released

This is happening again for me using Nvidia 313.26 graphics drivers and GeForce 8400M GS on a Dell Vostro 1500.

Link to bug: https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/1154723

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers