[panel] Maximized window title switches to Arial font

Bug #820274 reported by Lucazade on 2011-08-03
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gconf
Won't Fix
Medium
unity-2d
High
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Window title switch to arial font after using Synaptic, so after have updated or installed some packages.
Doesn't seem to happen in other occasions.
Using unity-2d daily-ppa in Oneiric.

Related branches

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Florian Boucault (fboucault) wrote :

With the latest release of Unity 2D in Oneiric I cannot reproduce that issue. Is it still happening for you Lucazade?

Changed in unity-2d:
status: Confirmed → Incomplete
Changed in unity-2d (Ubuntu):
status: Confirmed → Incomplete
Changed in unity-2d:
importance: Undecided → High
Hernando Torque (htorque) wrote :

I'm not sure how to trigger it, but I still get that font with up-to-date Oneiric.

Hernando Torque (htorque) wrote :

Banshee it is. Starting Banshee immediately and permanently (for the session) changes the window title font.

Changed in unity-2d (Ubuntu):
status: Incomplete → Confirmed
Pete Goodall (pgoodall) wrote :

I'm seeing this bug and I have neither used Synaptic nor started Banshee (in this session). Will check later whether it is the case for all windows for a new session.

Changed in unity-2d:
status: Incomplete → Confirmed
summary: - Window title switch to arial font after using Synaptic
+ [panel] Window title switch to arial font after using Synaptic
Changed in unity-2d:
milestone: none → 4.2
assignee: nobody → Aurélien Gâteau (agateau)

I'm also concerned by this bug (today) but I'm not using any ppa. I don't use synaptic neither. But it happened after running "apt-get update" and "apt-get upgrade". So it seems to be related to update process.

Alberto Mardegan (mardy) wrote :

This is very likely the same issue described here:
http://blogs.operationaldynamics.com/andrew/software/java-gnome/use-comma-in-font-description

As Aurelién is on holiday, I'll steal the bug from him. :-)

Changed in unity-2d:
assignee: Aurélien Gâteau (agateau) → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :
Download full text (5.2 KiB)

I was wrong in my last comment. The issue posted in the blog has nothing to do with this bug, because the font is specified as "Ubuntu Bold 11", so the font family doesn't contain any space.

Anyway, I added some debugging info in the panel (CroppedLabel.cpp), to print out the name of the font being retrieved, and I managed to reproduce the bug (though I'm not sure what steps I followed, it seems rather random). Here's the output:

======================
unity-2d-panel: [DEBUG] Font name: "Ubuntu Bold 11"
unity-2d-panel: [DEBUG] Desc 0x7fa3ac00d890
unity-2d-panel: [DEBUG] Font name: "Ubuntu Bold 11"
unity-2d-panel: [DEBUG] Desc 0x257a150
unity-2d-panel: [DEBUG] Font name: "Ubuntu Bold 11"
unity-2d-panel: [DEBUG] Desc 0x23a4610
unity-2d-panel: [DEBUG] Font name: "Ubuntu Bold 11"
unity-2d-panel: [DEBUG] Desc 0x257a120
unity-2d-panel: [DEBUG] Font name: "Ubuntu Bold 11"
unity-2d-panel: [DEBUG] Desc 0x7fa3ac0044f0
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [CRITICAL] GLib-GObject: g_object_weak_ref: assertion `G_IS_OBJECT (object)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] Configuration server couldn't be contacted: D-BUS error: Method "LookupExtended" with signature "ssb" on interface "org.gnome.GConf.Database" doesn't exist

GConf Error: Configuration server couldn't be contacted: D-BUS error: Method "AddNotify" with signature "s" on interface "org.gnome.GConf.Database" doesn't exist

unity-2d-panel: [WARNING] GConf: Directory `/apps/metacity/general/titlebar_font' was not being monitored by GConfClient 0x22fd000
unity-2d-panel: [DEBUG] Font name: ""
unity-2d-panel: [DEBUG] Desc 0x7fa3ac00da40
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: [CRITICAL] GLib-GObject: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-panel: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-panel: ...

Read more...

Alberto Mardegan (mardy) wrote :

Some more info, as I reproduced the bug again: the launcher is invoking the LookupExtended DBus method on the /org/gnome/GConf/Database/0 object, and that fails.
However gconftool-2 works, and it's invoking its methods on the /org/gnome/GConf/Database/2 object.

Alberto Mardegan (mardy) wrote :

Ok, I finally found a way to reproduce this reliably. I noticed that installation and removal of certain packages (p.e., ekiga) always caused this problem. The reason is that the installation of ekiga (and other packages) triggers the gconf post-install script, which amon other things sends a HUP signal to gconf. To keep it short, the way to reproduce this issue is just executing the following line in a terminal:

kill -s HUP `pidof gconfd-2`

This causes gconfd to reload its configuration, and to advertise the DB under a new D-Bus object path. Existing GConfClient instances are not notified of the change in object path, and therefore all the APIs invoked through them simply fail. In Unity2d, we never cache the GConfClient instance (which is properly obtained with gconf_client_get_default() and unref'ed every time we retrieve a value), so the problem is in the libgconf2 itself.

Possible ways to solve it (in libgconf2):

- Make GConfClient track the DB object path changes, and readjust its internal structures consequently. This is the proper solution, but it might involve changing gconfd as well and add a D-Bus signal from it.

- gconf_client_get_default(), on the first invocation, creates a new GObject *and* references it; therefore, this object is never destroyed. A possible solution is to change g_object_ref() into a g_object_weak_ref(), so the GConfClient is properly destroyed when no client is using it.

@Thanks Alberto for taking care of this bug!

Changed in gconf:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in unity-2d:
milestone: 4.2 → 4.4
Sergey Filkin (sergey-filkin) wrote :

I thought with migration to GNOME3 we should use gsettings, not gconf. Is it planned to port Unity-2d to gsettings in Oneiric?

@Sergey
Unity-2d has already migrated to gsettings if you use the daily ppa, for both natty and oneiric.
You will see anyway also old gconf settings because are not removed automatically.

Alberto Mardegan (mardy) wrote :

@Sergey, @Lucazade
Yes, unity-2d is using GSettings wherever possible. Unfortunately metacity is still using GConf, and unity-2d needs to read the name of the window title font from metacity: that's why we are still using GConf in that case.

Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
komputes (komputes) wrote :

I am experiencing this as well. I did use synaptic yesterday but not today.

Dmitry Shachnev (mitya57) wrote :

I use neither Synaptic not Banshee.
Just got this after restart. Unity-2D 4.4.0-0ubuntu1, Ubuntu Oneiric.

summary: - [panel] Window title switch to arial font after using Synaptic
+ [panel] Maximized window title switches to Arial font
Dmitry Shachnev (mitya57) wrote :

Mabe this is the right warning:
unity-2d-panel: [WARNING] GConf: Directory `/apps/metacity/general/titlebar_font' was not being monitored by GConfClient 0x93a3ea8

@Dmitry
same here, it seems you find the culprit:

Errore di GConf: Impossibile contattare il server di configurazione: D-BUS error: Method "AddNotify" with signature "s" on interface "org.gnome.GConf.Database" doesn't exist

unity-2d-panel: [WARNING] GConf: Directory `/apps/metacity/general/titlebar_font' was not being monitored by GConfClient 0x9ef76c0
unity-2d-panel: [WARNING] Impossibile contattare il server di configurazione: D-BUS error: Method "LookupExtended" with signature "ssb" on interface "org.gnome.GConf.Database" doesn't exist

Errore di GConf: Impossibile contattare il server di configurazione: D-BUS error: Method "AddNotify" with signature "s" on interface "org.gnome.GConf.Database" doesn't exist

unity-2d-panel: [WARNING] GConf: Directory `/apps/metacity/general/titlebar_font' was not being monitored by GConfClient 0x9ef76c0
Avviso del window manager: last_user_time (1315371802) is greater than comparison timestamp (1162993). This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE_WINDOW. Trying to work around...
Avviso del window manager: 0x4000004 (Terminal) appears to be one of the offending windows with a timestamp of 1315371802. Working around...
unity-2d-panel: [WARNING] Impossibile contattare il server di configurazione: D-BUS error: Method "LookupExtended" with signature "ssb" on interface "org.gnome.GConf.Database" doesn't exist

Errore di GConf: Impossibile contattare il server di configurazione: D-BUS error: Method "AddNotify" with signature "s" on interface "org.gnome.GConf.Database" doesn't exist

unity-2d-panel: [WARNING] GConf: Directory `/apps/metacity/general/titlebar_font' was not being monitored by GConfClient 0x9ef76c0

Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8

fixed with latest release

Alberto Mardegan (mardy) wrote :

@lucazade: glad to hear that it's not reproducible for you, but unfortunately we didn't fix it yet and I could still reproduce it this morning. Anyway, now I think I'm on the good track to fix it.

Changed in unity-2d:
status: Confirmed → In Progress

@Alberto
Yep, ignore that comment.... bug is still present.
Thanks for fixing it :)

Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in gconf:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.