Ubuntu

Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but in the panel

Reported by Lucazade on 2011-07-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Florian Boucault
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Fonts in the globalmenu bar (in unity-2d-panel) are bold instead of regular.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-4.5-generic 3.0.0-rc6
Uname: Linux 3.0.0-4-generic i686
Architecture: i386
Date: Mon Jul 11 17:27:25 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110702)
PackageArchitecture: all
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Lucazade (lucazade) wrote :
Lucazade (lucazade) wrote :
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
milestone: none → 3.8.12
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

Probably a dup of bug #744812 ("FontConfig/Qt stack choke on Ubuntu Medium font meta-data (No medium in Inkscape and too bold in Qt apps)").

Lucazade (lucazade) wrote :

@Paul
probably related to that bug.
I've seen the same bold issue in virtualbox qt4 gui

Florian Boucault (fboucault) wrote :

@Paul: if I understand correctly the workaround of dropping 'Medium' and 'Medium Italic' from the Ubuntu 11.04 release did not make it into Oneiric, right? Therefore bug #744812 is still valid and will be fixed for Natty?

Once this is fixed, if our assumption that the present bug is a dupe of bug #744812, then it should go away at that point.

Paul Sladen (sladen) wrote :

The /bug/ is in the $font_stack not being able to handle more than just Regular/Italic/Bold/Bold-Italic. We worked around it in natty by just not shipping some of the .ttfs. The intention would be to ship all thirteen .ttfs for Oneiric and instead to fix the software. (Same happens for other advanced fonts with multiple weights, like LinuxLiberation).

Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
milestone: 3.8.12 → 3.8.14
Lucazade (lucazade) wrote :

This bug is fixed with latest updates of Unity-2D in Oneiric with daily ppa.
Transition to gtk3 have fixed it.

Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Florian Boucault (fboucault) wrote :

@Lucazade: I believe the issue is still present everywhere else but in the panel. I changed the title accordingly.

summary: - Bold fonts in global menubar
+ Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
+ in the panel
Lucazade (lucazade) wrote :

@Florian
Yes, not fixed, you're right.
Yesterday didrocks made me notice the issue is still present in the other parts of the UI.
It is true in the panel the issue is no more present (at least in appmenu and indicators) but it happens a strange thing after I use synaptic, the window title in the panel switch from the normal font to a bigger one in Arial-like style. Is it a known issue? If you need a make a sshot, it is always reproducible.

Florian Boucault (fboucault) wrote :

@Lucazade: definitely worth a bug report with screenshot :)

Lucazade (lucazade) wrote :
Didier Roche (didrocks) on 2011-08-11
Changed in unity-2d:
milestone: 4.0 → 4.2
Changed in unity-2d:
milestone: 4.2 → 4.4
Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Changed in unity-2d:
status: Confirmed → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

For clarity, what has worked around is to temporarily not ship the medium and Medium Italic weights of the Ubuntu Font Family.

Neither the broken software (FontConfig, Qt), nor the symptomatic software (Unity-2D) have been fixed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.6.1-0ubuntu1

---------------
unity-2d (4.6.1-0ubuntu1) oneiric; urgency=low

  * Fix a segfault due to new unity service backend change.

unity-2d (4.6.0-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Metacity needs command line options to activate capture before unmap and
      compositing without effects (LP: #791205)
    - Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
      in the panel (LP: #808849)
    - the migration script needs to be run in unity-2d as well (LP: #819733)
    - [dash] "View photos" in the dash launches default image viewer instead
      of shotwell (LP: #822605)
    - Launcher tooltips sometimes leave holes in panel and windows
      (LP: #837277)
    - [dash] Search with non ascii characters fails (LP: #840010)
    - add a configuration key (dconf) to enable the opengl backend
      (LP: #809202)
    - [launcher] when pressing super key shortcuts numbering start at 2
      instead of 1 (LP: #830036)
    - [UIFe] Unity 2D should be using the same BFB icon as Unity (LP: #838829)
    - [launcher] trash icon needs to be the same as in Unity 3D (LP: #840025)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - [dash] DropShadow on "See X more results" can cause visual errors on
      scroll (LP: #843820)
    - Dash - In the App lens filters, users should only be able filter by
      'star' rating in one star increments (LP: #839759)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
  * debian/control:
    - rebuild against current nux and unity (API change)
 -- Didier Roche <email address hidden> Fri, 09 Sep 2011 13:50:22 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Paul Sladen (sladen) on 2011-09-09
Changed in unity-2d (Ubuntu):
status: Fix Released → Won't Fix
status: Won't Fix → Invalid
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers