`unison -ui graphic' does not show password dialog

Bug #696706 reported by Thomas Krennwallner
262
This bug affects 50 people
Affects Status Importance Assigned to Milestone
unison (Debian)
Fix Released
Unknown
unison (Ubuntu)
Fix Released
Undecided
Unassigned
unison (openSUSE)
Won't Fix
Medium

Bug Description

Binary package hint: unison

I'm using Ubuntu Natty (development branch) with unison-gtk 2.32.52-1ubuntu2. When I force unison to call ssh without public key authentication with

 $ unison -ui graphic -sshargs -oPubkeyAuthentication=no

I get no password dialog. Instead, unison shows only a dialog window "Contacting server..." and waits forever, thus making unison unusable. If I force a text UI with

 $ unison -ui text -sshargs -oPubkeyAuthentication=no

everything works as normal: I get a password prompt in the terminal and after typing in my password, unison starts syncing.

If I run

 $ unison-gtk -sshargs -oPubkeyAuthentication=no

I get a window with "Connecting to 'ssh://myuser@myhost//mypath'..." and I can type in my password; the connection can be established and unison works.

Tags: patch
Revision history for this message
Jérôme Vouillon (jerome-vouillon) wrote :

This is due to a bad interaction between Unison and openssh 5.6. Here is a patch that fixes the bug.

tags: added: patch
Revision history for this message
In , Dani Llewellyn (diddledani) wrote :

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12) Gecko/20110222 Firefox/4.0b12

Unison seems to hang at the point where it would ordinarily ask for an SSH password. Instead of the password input dialog the "contacting server" screen stalls forever, or until the user clicks quit.

Reproducible: Always

Steps to Reproduce:
1.launch unison in gui/gtk mode
2.create a remote (ssh) profile that does not have a public/private keypair assigned
3.connect
Actual Results:
the "contacting server" dialog remains on screen indefinitely with no progress further into the application's workflow.

Expected Results:
a password dialog should appear followed (after correct password input) by the main application interface.

There is a similar ubuntu bug here complete with patch (I haven't tested the patch):
https://bugs.launchpad.net/ubuntu/+source/unison/+bug/696706

Changed in unison (openSUSE):
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Almorales-cableonline (almorales-cableonline) wrote :

I am confirming the bug with unison on openSUSE 11.4 x86-64.
Same behavior as described before.
Amorales.

Revision history for this message
In , kolAflash (colaflash) wrote :

Confirming the bug for:
my notebook, openSUSE 11.4 i586, updated from 11.3
my pc, openSUSE 11.4 x86_64, updated from 11.3

On both, Unison worked fine on openSUSE 11.3.

Workaround:
Install the new Unison version 2.40.61-20.1 from (date 2011-03-26):
http://download.opensuse.org/repositories/network/openSUSE_Factory/
It's working fine!

A bigger discussion about this problem:
http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/455870-unison-problems-opensuse-11-4-a.html

Revision history for this message
In , kolAflash (colaflash) wrote :

P.S. Maybe you need to install "lablgtk2" as a dependency for Unison version 2.40.61-20.1 from:
http://download.opensuse.org/repositories/network/openSUSE_Factory/

The INSTALL-README of Unison "2.40.61" tells, you need lablgtk2 to compile. But currently lablgtk2 is not a dependency of the package from that repository.

Revision history for this message
NuZeb (nudelzebra) wrote :

Same here on Ubuntu Natty Development (2.32.52-1ubuntu2) 32bit. This bug does not occur on my 64bit install (same version).

Changed in unison (Ubuntu):
status: New → Confirmed
Revision history for this message
Jeremy LaCroix (j-jlacroix) wrote :

Same problem here, Kubuntu 11.04 64-bit.

Revision history for this message
Jeremy LaCroix (j-jlacroix) wrote :

I forgot to mention that the work-arounds posted here do not work for me. If I use unison via the commandline, I have no issue, but that's hard for me to use. If there is a work around that would be awesome. I'm hoping this is fixed before final release, this is a very important program to me. Anything I can do to help test?

Revision history for this message
Emanuele Gissi (emanuele-gissi-gmail) wrote :

I confirm it in an updated Natty.

Revision history for this message
pyjamashark (pyjamashark) wrote :

Hi, I've got the same problem in Natty - works via terminal but not the gtk version. As I'm a wee bit clueless could someone explain how to apply Jerome's patch? Many thanks

Revision history for this message
c42105 (c42105) wrote :

Same problem here, also Kubuntu 11.04 64-bit.

If you need a solution to this problem before the bug is solved, you can authenticate through keys instead of password. When I read it, I thought it was going to be difficult (excuse my ignorance), but it's pretty simple:

http://www.pclinuxos.com/forum/index.php?topic=86809.0

Revision history for this message
Chris Puttick (cputtick) wrote :

Bug confirmed. If attached patch fixes issue can it please be applied repos updated? Or someone could post a how-to for the patch? My entire working life depends on Unison working...

Revision history for this message
pyjamashark (pyjamashark) wrote :

I can confirm c42105's workaround works really well. Authenticating through keys instead of the password 'solves' the problem. Thanks

Revision history for this message
Glenn Murray (inga.edulis) wrote :

I can also confirm c42105's workaround works really well. Authenticating through keys instead of the password 'solved' the problem. Thanks

Revision history for this message
itsjustarumour (itsjustarumour-gmail-deactivatedaccount-deactivatedaccount) wrote :

Well, as a mere "human being" Ubuntu user alas I didn't find c442105's fix "pretty easy" and in fact couldn't get it to work - so I don't think this is really an acceptable "workaround" for the majority of users.

Is there any news on fixing this bug? Unison provides critical functionality for a lot of people, and the patch seems to have been available for several months now...

Revision history for this message
Cristian Mammoli (cristian-mammoli) wrote : Re: [Bug 696706] Re: `unison -ui graphic' does not show password dialog

Using keys is not a fix.

I use unison to sync to a Windows fileserver where the ssh service does not
support key authentication.

--
Cristian Mammoli

Revision history for this message
Björn Leder (bjoern-leder) wrote :

Bug confirmed, Kubuntu 11.04 64-bit. My 'workaround' is to use the non-gui version.

Revision history for this message
Ethan Bissett (draimus-deactivatedaccount) wrote :

This bug has already been fixed in Debian for version 2.32.52-3 of unison-gtk. I linked this bug to the debian bug but for some reason launchpad isn't picking up the debian status.

The Debian version of the package is fully installable on Ubuntu and I have verified that it is fixed. Ubuntu might want to think about pulling down their changes.

In the meantime if you want a fully working unison-gtk installed just download the deb from http://packages.debian.org/wheezy/unison-gtk and install it. Make sure you pick the right architecture (i386 or amd64).

Revision history for this message
Sami Mäkinen (sami-makinen-helsinki) wrote :

thx, works nicely with the Debian package!
Looking forward to get the fix into the official Ubuntu package.

Revision history for this message
Ferry Toth (ftoth) wrote :

We use keys, but with a pass phrase. Same problem: hangs on the pass phrase.

Installing the deb worked for me.

Thanks Ethan.

Revision history for this message
In , Mhopf (mhopf) wrote :

Thanks for the pointers. You can also find versions compiled for older openSUSE versions in home:mhopf.

*** This bug has been marked as a duplicate of bug 662139 ***

Revision history for this message
In , 8-kde (8-kde) wrote :

I just updated to version 2.40.63 from tumbleweed and it's now working.

Changed in unison (openSUSE):
status: Confirmed → Won't Fix
Revision history for this message
Robert Bredereck (rbredereck) wrote :

Why don't we use the patch that is included in the current Debian package (2.32.52-3)?

At least for me (and some other), this version works.

Please note that solving this bug is essential for using Unison for most people that want to use it!

Revision history for this message
Wolf Rogner (war-rsb) wrote :

Some comments on this.

1. Unison is the only useful equivalent to Microsofts offline files. Using a notebook it is mandatory to use a file synchroniser
2. Installing the 2.40.63 on the client does not help. The server version is required as well. This means installing unofficial software both on a line of clients and untested software on a server. In a production environment nothing that a serious administrator would do lightheartedly
3. RBredereck suggested a solution. For something that broke some month ago and that is that essential, the attitude towards fixing is astounding.

I start asking myself why I use a stable distribution if I can have technical experiments by installing from scratch?

Changed in unison (Debian):
status: Unknown → Fix Released
Revision history for this message
Matthew Carpenter (matt-eisgr) wrote :

Still a problem for me, using 2.27.57 (I have multiple varied systems to sync, and Unison doesn't *do* backwards-compat).
Natty-64bit. Keys has me working for now, but I don't care to use un-protected keys for access to my main filesync!

Thank you for all your hard work guys.
Matt

Revision history for this message
Oleksandr "Sanja" Byelkin (sanja-byelkin) wrote :

I also faced the problem on unison 2.27.57 (ubunto 11.10 up to date)

Revision history for this message
pacrook (paul-crook) wrote :

I'm similarly stuck trying to sync using 2.27.57 to my main file sync. Any progress? (kubuntu 11.10)

Revision history for this message
pacrook (paul-crook) wrote :

Patching 2.27.57 source code in-line with the above patch (comment #1) and compiling (with packages liblablgtk2-ocaml and liblablgtk2-ocaml-dev installed) fixes it for me. Patch matches line 194 of terminal.ml in version 2.27.57.

Revision history for this message
Kay Drangmeister (kay-t) wrote :

Also affects me with unison version 2.32.52, on Kubuntu 11.04. This is so sad.

Revision history for this message
Nicolas Riesco (nicolas-riesco) wrote :

Debian reports this bug was closed in version 2.32.52-3 and I can confirm I don't see this bug in ubuntu 12.04.
Can anyone close this bug report?

Revision history for this message
Dani Llewellyn (diddledani) wrote :

per comment 30 and the relevant package versions with correct citations in the standard repo for precise and above, I'm marking this as fix released.

Changed in unison (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.