udisks reporting input/output error that seems to be nonsense

Bug #1143495 reported by Phillip Susi on 2013-03-04
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
libatasmart
Confirmed
Medium
udisks
Unknown
Unknown
libatasmart (Ubuntu)
Medium
Unassigned
udisks (Ubuntu)
Undecided
Unassigned
udisks2 (Ubuntu)
Undecided
Unassigned

Bug Description

My syslog is full of entries that look like this:

Mar 3 12:06:45 faldara udisksd[2630]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD360GD_00FNA0_WD_WMAH91337618: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)

And opening the disks utility shows invalid smart data, and choosing to update the smart data also reports an I/O error. Using smartctl on the command line though says this disk is fine:

root@faldara:~# smartctl -a /dev/sdc
smartctl 5.43 2012-06-30 r3573 [x86_64-linux-3.8.0-7-generic] (local build)
Copyright (C) 2002-12 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Model Family: Western Digital Raptor
Device Model: WDC WD360GD-00FNA0
Serial Number: WD-WMAH91337618
Firmware Version: 35.06K35
User Capacity: 37,019,566,080 bytes [37.0 GB]
Sector Size: 512 bytes logical/physical
Device is: In smartctl database [for details use: -P show]
ATA Version is: 6
ATA Standard is: Exact ATA specification draft version not indicated
Local Time is: Sun Mar 3 23:25:55 2013 EST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x82) Offline data collection activity
     was completed without error.
     Auto Offline Data Collection: Enabled.
Self-test execution status: ( 0) The previous self-test routine completed
     without error or no self-test has ever
     been run.
Total time to complete Offline
data collection: ( 1572) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
     Auto Offline data collection on/off support.
     Suspend Offline collection upon new
     command.
     Offline surface scan supported.
     Self-test supported.
     Conveyance Self-test supported.
     Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
     power-saving mode.
     Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
     No General Purpose Logging support.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 28) minutes.
Conveyance self-test routine
recommended polling time: ( 5) minutes.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate 0x000b 200 200 051 Pre-fail Always - 0
  3 Spin_Up_Time 0x0007 088 084 021 Pre-fail Always - 2100
  4 Start_Stop_Count 0x0032 095 095 040 Old_age Always - 5566
  5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
  7 Seek_Error_Rate 0x000b 200 200 051 Pre-fail Always - 0
  9 Power_On_Hours 0x0032 080 080 000 Old_age Always - 14706
 10 Spin_Retry_Count 0x0013 100 100 051 Pre-fail Always - 0
 11 Calibration_Retry_Count 0x0013 100 100 051 Pre-fail Always - 0
 12 Power_Cycle_Count 0x0032 095 095 000 Old_age Always - 5255
194 Temperature_Celsius 0x0022 109 253 000 Old_age Always - 34
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0012 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0012 200 200 000 Old_age Always - 0
199 UDMA_CRC_Error_Count 0x000a 200 253 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0009 200 125 051 Pre-fail Offline - 0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Extended offline Completed without error 00% 942 -
# 2 Extended offline Completed without error 00% 232 -
# 3 Extended offline Completed without error 00% 145 -
# 4 Extended offline Completed without error 00% 62 -
# 5 Extended offline Completed without error 00% 761 -
# 6 Extended offline Completed without error 00% 562 -
# 7 Extended offline Completed without error 00% 696 -
# 8 Extended offline Completed without error 00% 192 -
# 9 Extended offline Completed without error 00% 888 -

SMART Selective self-test log data structure revision number 1
 SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
    1 0 0 Not_testing
    2 0 0 Not_testing
    3 0 0 Not_testing
    4 0 0 Not_testing
    5 0 0 Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

root@faldara:~#

Related branches

Phillip Susi (psusi) wrote :

It looks like the problem is in libatasmart. It seems to be throwing the io error in sk_disk_smart_status here:

        /* SAT/USB bridges truncate packets, so we only check for 4F,
         * not for 2C on those */
        if ((d->type == SK_DISK_TYPE_ATA_PASSTHROUGH_12 || cmd[3] == htons(0x00C2U)) &&
            cmd[4] == htons(0x4F00U))
                *good = TRUE;
        else if ((d->type == SK_DISK_TYPE_ATA_PASSTHROUGH_12 || cmd[3] == htons(0x002CU)) &&
                 cmd[4] == htons(0xF400U))
                *good = FALSE;
        else {
                errno = EIO;
                return -1;
        }

(gdb) print d->type
$5 = SK_DISK_TYPE_ATA_PASSTHROUGH_16
(gdb) print /x cmd
$4 = {0x0, 0x0, 0x0, 0xc200, 0x454f, 0x5000}

affects: udisks (Ubuntu) → udisks2 (Ubuntu)
Download full text (3.3 KiB)

I get an I/O error trying to read health status:

psusi@faldara:~$ sudo skdump /dev/sdc
Device: sat16:/dev/sdc
Type: 16 Byte SCSI ATA SAT Passthru
Size: 35304 MiB
Model: [WDC WD360GD-00FNA0]
Serial: [WD-WMAH91337618]
Firmware: [35.06K35]
SMART Available: yes
Quirks:
Awake: yes
SMART Disk Health Good: Input/output error
Off-line Data Collection Status: [Off-line data collection activity was completed without error.]
Total Time To Complete Off-Line Data Collection: 1572 s
Self-Test Execution Status: [The previous self-test routine completed without error or no self-test has ever been run.]
Percent Self-Test Remaining: 0%
Conveyance Self-Test Available: yes
Short/Extended Self-Test Available: yes
Start Self-Test Available: yes
Abort Self-Test Available: yes
Short Self-Test Polling Time: 2 min
Extended Self-Test Polling Time: 28 min
Conveyance Self-Test Polling Time: 5 min
Bad Sectors: 0 sectors
Powered On: 1.7 years
Power Cycles: 5260
Average Powered On Per Power Cycle: 2.8 h
Temperature: 35.0 C
Attribute Parsing Verification: Good
Overall Status: Input/output error
ID# Name Value Worst Thres Pretty Raw Type Updates Good Good/Past
  1 raw-read-error-rate 200 200 51 0 0x000000000000 prefail online yes yes
  3 spin-up-time 88 84 21 2.1 s 0x340800000000 prefail online yes yes
  4 start-stop-count 95 95 40 5571 0xc31500000000 old-age online yes yes
  5 reallocated-sector-count 200 200 140 0 sectors 0x000000000000 prefail online yes yes
  7 seek-error-rate 200 200 51 0 0x000000000000 prefail online yes yes
  9 power-on-hours 80 80 0 1.7 years 0x833900000000 old-age online n/a n/a
 10 spin-retry-count 100 100 51 0 0x000000000000 prefail online yes yes
 11 calibration-retry-count 100 100 51 0 0x000000000000 prefail online yes yes
 12 power-cycle-count 95 95 0 5260 0x8c1400000000 old-age online n/a n/a
194 temperature-celsius-2 108 253 0 35.0 C 0x230000000000 old-age online n/a n/a
196 reallocated-event-count 200 200 0 0 0x000000000000 old-age online n/a n/a
197 current-pending-sector 200 200 0 0 sectors 0x000000000000 old-age online n/a n/a
198 offline-uncorrectable 200 200 0 0 sectors 0x000000000000 old-age online n/a n/a
199 udma-crc-error-count 200 253 0 0 0x000000000000 old-age online n/a n/a
200 multi-zone-error-rate 200 125 51 0 0x000000000000 prefail offline yes yes

I traced it down to sk_disk_smart_status here:

        /* SAT/USB bridges truncate packets, so we only check for 4F,
         * not for 2C on those */
        if ((d->type == SK_DISK_TYPE_ATA_PASSTHROUGH_12 || cmd[3] == htons(0x00C2U)) &&
            cmd[4] == htons(0x4F00U))
                *good = TRUE;
        else if ((d->type == SK_DISK_TYPE_ATA_PASSTHROUGH_12 || cmd[3] == htons(0x002CU)) &&
                 cmd[4] == htons(0xF400U))
                *good...

Read more...

Phillip Susi (psusi) wrote :
Download full text (5.0 KiB)

The error only happens trying to read the overall health, the rest of the values can be read fine, yet udisks refuses to report anything:

psusi@faldara:~$ sudo skdump /dev/sdc
Device: sat16:/dev/sdc
Type: 16 Byte SCSI ATA SAT Passthru
Size: 35304 MiB
Model: [WDC WD360GD-00FNA0]
Serial: [WD-WMAH91337618]
Firmware: [35.06K35]
SMART Available: yes
Quirks:
Awake: yes
SMART Disk Health Good: Input/output error
Off-line Data Collection Status: [Off-line data collection activity was completed without error.]
Total Time To Complete Off-Line Data Collection: 1572 s
Self-Test Execution Status: [The previous self-test routine completed without error or no self-test has ever been run.]
Percent Self-Test Remaining: 0%
Conveyance Self-Test Available: yes
Short/Extended Self-Test Available: yes
Start Self-Test Available: yes
Abort Self-Test Available: yes
Short Self-Test Polling Time: 2 min
Extended Self-Test Polling Time: 28 min
Conveyance Self-Test Polling Time: 5 min
Bad Sectors: 0 sectors
Powered On: 1.7 years
Power Cycles: 5260
Average Powered On Per Power Cycle: 2.8 h
Temperature: 35.0 C
Attribute Parsing Verification: Good
Overall Status: Input/output error
ID# Name Value Worst Thres Pretty Raw Type Updates Good Good/Past
  1 raw-read-error-rate 200 200 51 0 0x000000000000 prefail online yes yes
  3 spin-up-time 88 84 21 2.1 s 0x340800000000 prefail online yes yes
  4 start-stop-count 95 95 40 5571 0xc31500000000 old-age online yes yes
  5 reallocated-sector-count 200 200 140 0 sectors 0x000000000000 prefail online yes yes
  7 seek-error-rate 200 200 51 0 0x000000000000 prefail online yes yes
  9 power-on-hours 80 80 0 1.7 years 0x833900000000 old-age online n/a n/a
 10 spin-retry-count 100 100 51 0 0x000000000000 prefail online yes yes
 11 calibration-retry-count 100 100 51 0 0x000000000000 prefail online yes yes
 12 power-cycle-count 95 95 0 5260 0x8c1400000000 old-age online n/a n/a
194 temperature-celsius-2 108 253 0 35.0 C 0x230000000000 old-age online n/a n/a
196 reallocated-event-count 200 200 0 0 0x000000000000 old-age online n/a n/a
197 current-pending-sector 200 200 0 0 sectors 0x000000000000 old-age online n/a n/a
198 offline-uncorrectable 200 200 0 0 sectors 0x000000000000 old-age online n/a n/a
199 udma-crc-error-count 200 253 0 0 0x000000000000 old-age online n/a n/a
200 multi-zone-error-rate 200 125 51 0 0x000000000000 prefail offline yes yes

/org/freedesktop/UDisks2/drives/WDC_WD360GD_00FNA0_WD_WMAH91253983:
  org.freedesktop.UDisks2.Drive:
    Configuration: {}
    ConnectionBus:
    Ejectable: false
    Id: WDC-WD360GD-00FNA0-WD-WMAH91253983
    Media:
    MediaAvailable: true
    MediaChangeDetected: ...

Read more...

Changed in libatasmart:
importance: Unknown → Medium
status: Unknown → Confirmed

Created attachment 76719
fix-status-io-error.patch

Fixed the bug with this simple patch. The existing code is testing the value of 8 bits to be zero that the standard says are undefined. My drives were not setting them to zero. Mask off the undefined bits when comparing.

Changed in udisks2 (Ubuntu):
status: New → Invalid
Changed in udisks (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libatasmart (Ubuntu):
status: New → Confirmed
hookerjay (hookerjay) wrote :

Having the same issue with an IDE WDC drive. Works fine in Windows and when mounted in Linux Mint 14.

My SATA based WDC drives are not affected.

Here's a log of "inxi -fxxx" if it helps ...

----
System: Host: <redacted> Kernel: 3.5.0-26-generic i686 (32 bit, gcc: 4.7.2) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: Mobo: Gigabyte model: M57SLI-S4 version: x.x Bios: Award version: FHa date: 04/23/2008
CPU: Dual core AMD Athlon 64 X2 5200+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) bmips: 10850
           Clock Speeds: 1: 2712.503 MHz 2: 2712.503 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI RV515 [Radeon X1300] bus-ID: 02:00.0
           X.Org: 1.13.0 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1440x900@60.1hz
           GLX Renderer: Gallium 0.4 on ATI RV515 GLX Version: 2.1 Mesa 9.0.2 Direct Rendering: Yes
Audio: Card: Creative Labs SB X-Fi driver: snd_ctxfi port: 8000 bus-ID: 01:08.0 Sound: ALSA ver: 1.0.25
Network: Card: NVIDIA MCP55 Ethernet driver: forcedeth port: e400 bus-ID: 00:08.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1d:7d:d6:61:8b
Drives: HDD Total Size: 410.1GB (1.2% used) 1: id: /dev/sda model: WDC_WD2500JB size: 250.1GB serial: WD-WMAEP2579168
           2: id: /dev/sdb model: WDC_WD800JD size: 80.0GB serial: WD-WMAM9P293246
           3: id: /dev/sdc model: WDC_WD800JD size: 80.0GB serial: WD-WMAM9P341257
Partition: ID: / size: 19G used: 4.1G (23%) fs: ext4 ID: /home size: 51G used: 495M (2%) fs: ext4
           ID: swap-1 size: 4.09GB used: 0.01GB (0%) fs: swap
RAID: System: supported: N/A
           No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
           Unused Devices: none
Sensors: System Temperatures: cpu: 14.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 143 Uptime: 4:29 Memory: 422.8/1002.9MB Runlevel: 2 Gcc sys: 4.7.2 alt: 4.4 Client: Shell inxi: 1.8.4
---

Thanks Philip! I applied your patch to the Debian package (and will sync that into Ubuntu)

Martin Pitt (pitti) wrote :

Thanks Philip! I applied your patch to the Debian package (and will sync that into Ubuntu).

Changed in libatasmart (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libatasmart - 0.19-2

---------------
libatasmart (0.19-2) unstable; urgency=low

  * debian/local/apport-hook.py: Fix syntax to be Python 3 compatible.
    (LP: #1013171)
  * debian/local/apport-hook.py: Include output of "udisksctl dump" from
    udisks2.
  * Add 0001-Dont-test-undefined-bits.patch: Fix an incorrect IO error reading
    SMART status, by filtering out undefined bits. Thanks Phillip Susi.
    (LP: #1143495)
  * Bump Standards-Version to 3.9.4, no changes necessary.

 -- Martin Pitt <email address hidden> Mon, 25 Mar 2013 07:38:36 +0100

Changed in libatasmart (Ubuntu):
status: Fix Committed → Fix Released
Eromatic (eromatic) wrote :

I have also seen this issue within Ubuntu 12.10. Will a backport fix also be available?

udisksd[1895]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD400EB_00CPF0_WD_WCAATA803870: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)

Jeff (jdorenbush) wrote :

I too have this issue in Ubuntu 12.10.

Is it possible to upgrade libatasmart 0.19-1 to the fixed version 0.19-2 in Ubuntu 12.10?

Phillip Susi (psusi) wrote :

You should be able to download and install the new version if you want, but it would of course, be better to just upgrade to 13.04.

Hi Lennart, it has been 6 months since I submitted this patch and it hasn't been applied yet. Could you take a look and at least comment?

Patch appears to fix this for me as well as bug 53475

*** Bug 53475 has been marked as a duplicate of this bug. ***

Created attachment 122509
ssd crash

I have a cheap SSD (Corsair Force LS) in my working computer, and it regularly crash. I think this is related to this bug, see my attachment.

Gilles Schintgen (shigi) wrote :
Download full text (12.8 KiB)

Hi, my 16.04 is suffering from this bug even though a fix has been released (apparently) 3 years ago.

Here's a (slightly sanitized) snippet of the syslog:

===============================================
Jul 19 15:06:48 udisksd[2434]: message repeated 13 times: [ Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)]
Jul 19 15:06:57 udisksd[2434]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Jul 19 15:07:18 udisksd[2434]: Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Jul 19 15:08:20 udisksd[2434]: message repeated 2 times: [ Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)]
Jul 19 15:09:21 udisksd[2434]: Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Jul 19 15:12:25 udisksd[2434]: message repeated 6 times: [ Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)]
Jul 19 15:12:32 smartd[1034]: Device: /dev/sda [SAT], SMART Usage Attribute: 194 Temperature_Celsius changed from 38 to 40
Jul 19 15:12:32 smartd[1034]: Device: /dev/sda [SAT], Read SMART Self-Test Log worked again, warning condition reset after 1 email
Jul 19 15:12:32 smartd[1034]: Device: /dev/sda [SAT], Read Summary SMART Error Log failed
Jul 19 15:12:32 smartd[1034]: Device: /dev/sdb [SAT], SMART Usage Attribute: 190 Airflow_Temperature_Cel changed from 68 to 66
Jul 19 15:12:32 smartd[1034]: Device: /dev/sdb [SAT], SMART Usage Attribute: 194 Temperature_Celsius changed from 32 to 34
Jul 19 15:12:33 smartd[1034]: Device: /dev/sdc [SAT], SMART Prefailure Attribute: 1 Raw_Read_Error_Rate changed from 120 to 99
Jul 19 15:12:33 smartd[1034]: Device: /dev/sdc [SAT], SMART Usage Attribute: 194 Temperature_Celsius changed from 36 to 38
Jul 19 15:12:33 smartd[1034]: Device: /dev/sdc [SAT], SMART Usage Attribute: 195 ECC_Uncorr_Error_Count changed from 120 to 99
Jul 19 15:12:56 udisksd[2434]: Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Jul 19 15:14:59 udisksd[2434]: message repeated 4 times: [ Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)]
Jul 19 15:15:29 udisksd[2434]: Error updating ATA smart for /org/freedesktop/UDisks2/drives/KINGSTON_SUV400S37480G_50026B72650C5002: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Jul 19 15:16:31 udisksd[2434]: message repeated 2 times: [ Error upd...

Gilles Schintgen (shigi) wrote :

I tried disabling udisks's checking of SMART attributes: open gnome-disk-utility ("Disks"), select the SSD, click the "hamburger" icon in the top right corner, SMART, disable. But unfortunately it is automatically re-enabled after a reboot.

Is there a workaround?

Philippe Lefevre (ph-l) wrote :
Download full text (5.3 KiB)

Also affected by this. I'm running Debian 8.9 up to date.

(Linux phlsys 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u3 (2017-08-15) x86_64 GNU/Linux)

syslog shows : (each 10mn)

Aug 26 07:02:06 phlsys udisksd[2161]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/ST1000DM003_1SB10C_W9A07ER1: Error updating SMART data: sk_disk_check_sleep_mode: Operation not supported (udisks-error-quark, 0)

GSmartControl doesn't show any error.

Output of smartctl:

=== START OF INFORMATION SECTION ===
Model Family: Seagate Barracuda 7200.14 (AF)
Device Model: ST1000DM003-1SB10C
Serial Number: W9A07ER1
LU WWN Device Id: 5 000c50 08b7c0db3
Firmware Version: CC41
User Capacity: 1,000,204,886,016 bytes [1.00 TB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: 7200 rpm
Form Factor: 3.5 inches
Device is: In smartctl database [for details use: -P show]
ATA Version is: ACS-3 T13/2161-D revision 3b
SATA Version is: SATA 3.1, 6.0 Gb/s (current: 1.5 Gb/s)
Local Time is: Sat Aug 26 08:07:50 2017 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
     was never started.
     Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
     without error or no self-test has ever
     been run.
Total time to complete Offline
data collection: ( 0) seconds.
Offline data collection
capabilities: (0x73) SMART execute Offline immediate.
     Auto Offline data collection on/off support.
     Suspend Offline collection upon new
     command.
     No Offline surface scan supported.
     Self-test supported.
     Conveyance Self-test supported.
     Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
     power-saving mode.
     Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
     General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 1) minutes.
Extended self-test routine
recommended polling time: ( 103) minutes.
Conveyance self-test routine
recommended polling time: ( 2) minutes.
SCT capabilities: (0x10a5) SCT Status supported.
     SCT Data Table supported.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate 0x000f 083 066 006 Pre-fail Always - 201611737
  3 Spin_Up_Time 0x0003 098 097 000 Pre-fail Always - 0
  4 Start_Stop_Count 0x0032 100 100 020 Old_age Always - 259
  5 Reallocated_Sector_Ct 0x0033 100 100 010 Pre-fail Always - 0
  7 Seek_Error_Rate 0x000f 100 253 045 Pre-fail Always - 999312
  9 Power_On_Hours 0x0032 100 ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.