Ubuntu

Missing "Safely Remove Drive" option from Quicklists. Only have "Eject".

Reported by Lonnie Lee Best on 2012-10-17
508
This bug affects 108 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned
Nautilus
New
Medium
Unity
Low
Unassigned
gvfs
New
Low
udisks
Won't Fix
Medium
Fedora
Unknown
Unknown
gvfs (Ubuntu)
Low
Martin Pitt
nautilus (Gentoo Linux)
New
High
nautilus (Mandriva)
Confirmed
Medium
openSUSE
Confirmed
High
udisks2 (ALT Linux)
Unknown
Unknown
udisks2 (Ubuntu)
Low
Unassigned

Bug Description

In Ubuntu 12.04, I could right-click on my usb-external-harddrive's Unity-Task-Bar icon (launcher icon) and select "Safely Remove". Upon doing this, the icon would disappear and I would proceed in unplugging my external hard drive.

However, since upgrading to Ubuntu 12.10, this option is no longer available in the context menus (Quicklists) for external drives.

Instead, all I see is "Unmount", and after clicking "Unmount" the icon remains on the task-bar (launcher) and no indication is given that would imply that the unmount occurred successfully.

The intent of this report is to bring back the "Safely Remove" option which (by making the icon disappear after selected) indicates that you may now safely removal your USB external hard drive (by unplugging its usb connector).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Wed Oct 17 14:55:17 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to quantal on 2012-10-04 (13 days ago)

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I noticed this yesterday on quantal. There are no Safely Remove or Eject options for my USB harddrives.

Changed in unity:
status: New → Confirmed
Andrea Azzarone (andyrock) wrote :

I think this is a gio/gvfs bug. Do you have Safely Remove/Eject options in the nautilus sidebar?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

In Nautilus, right-clicking on a USB-External-Harddrive only provides the "unmount" option also. Selecting it doesn't remove the device from the left-pane of Nautilus NOR does it remove the device from Unity's Task-bar.

In 12.04, you could right-click on the device (from the Unity Taskbar) and select "Safely Remove". After that the device would be removed from the task-bar and you could then unplug it with some degree of confidence.

"Safely Remove" and "Eject" are missing from the Unity-Taskbar-Device-Icon's context menu. I don't know how Nautilus was before, but it too doesn't provide those options now (in its left-pane, under the "Devices" section). Nautilus may have been that way before; I cannot confirm that.

Yet, this bug report is specifically indicating the un-evolved behavior of the Unity-Taskbar-Device-Icon's Context-Menu, which seems to have un-evolved to a less-ensuring indicator of "whether it is safe to unplug your USB hard-drive or not".

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

To be fair, when you do select "unmount", if you right-click on the device-icon again, the "unmount" option will no longer be selectable. Perhaps this is a more subtle indicator that the drive has been successfully unmounted, but it does take an additional step to confirm (versus the behavior in 12.04). 12.04's behavior was more apparently without that additional step.

One plus, about this new behavior, is that if you want to mount the device again, the device icon remains on the taskbar, and it auto-mounts it upon clicking it. This prevents you from having to unplug and replug the device to get the icon to re-appear on the task bar.

Perhaps a great compromise would be to indeed bring back the "Safely Remove" option (because to a new user that makes more sense than the technical term "unmount". And, once removed, allow the icon to remain on the task bar, but modify the icon so that it indicates an "unmounted" status (with a red x or something else more elegant).

Additionally, upon "Safely Remove", perhaps a message notification should fade up to explicitly indicate that the safe removal was successful.

Andrea Azzarone (andyrock) wrote :

This is a gio/gvfs bug. Marking as invalid in unity.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Charlie Wax (charliewax) on 2012-10-23
information type: Public → Public Security
information type: Public Security → Public
Maikon (maikon) on 2012-11-03
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in unity:
status: Invalid → Confirmed
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Maikon (maikon) wrote :

I'm sorry about the mess that i did with the status above, i just want to confirm that the problem afects me too. When i need to unplug the external drive the option "safely remove drive" turns off the drive. When i just unmout he still remains spinning. I'm afraid to damage my drive.

John Wang (johnwang) on 2012-11-10
Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
John Wang (johnwang) wrote :

Original reporter should use the proper terms for the Unity desktop components involved. There's no "Unity-Task-Bar" -- it's called the Launcher. And the pop-up that appears when right-clicking on a Launcher icon is called a Quicklist, not a context menu. For general Unity terminology, see: http://askubuntu.com/questions/10228/whats-the-right-terminology-for-unitys-ui-elements/19166#19166

Anyhow, under 12.04 and earlier my Patriot USB memory stick also had the "Safely Remove" Quicklist entry, but in 12.10 there's only "Eject" which doesn't perform a sync operation before telling me the device has been ejected. Ejecting (i.e. unmounting) without syncing can corrupt the filesystem if a write operation has been recently performed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Could you get a "gvfs-mount -li" log with the drive mounted and add it to the bug?

affects: unity (Ubuntu) → udisks2 (Ubuntu)
Changed in unity:
status: Confirmed → Invalid
importance: Undecided → Low
Changed in gvfs:
importance: Undecided → Low
Changed in gvfs (Ubuntu):
importance: Undecided → Low
Changed in udisks2 (Ubuntu):
importance: Undecided → Low
Martin Pitt (pitti) wrote :

The "safe remove" functionality was removed from udisks2, and it's not planned to bring it back. It caused too much trouble with e. g. devices which are internally wired to an USB port, and you could never use them again until after a reboot. Also, having two options was a constant source of confusion. So I'm afraid this is "wontfix" from the distro side.

Changed in gvfs (Ubuntu):
status: Confirmed → Invalid
Changed in udisks2 (Ubuntu):
status: Confirmed → Won't Fix
John Wang (johnwang) wrote :

Attaching output log of `gvfs-mount -li`. My 16 GB Patriot USB stick is auto-mounted and listed as "Drive(2)".

summary: - Missing "Safely Remove Drive" Option from Context-Menu
+ Missing "Safely Remove Drive" and "Eject" options from context menu.
+ Only have "Unmount".
summary: - Missing "Safely Remove Drive" and "Eject" options from context menu.
- Only have "Unmount".
+ [quantal] Missing "Safely Remove Drive" and "Eject" options from context
+ menu. Only have "Unmount".

Also, the safely remove option would recognise if the external drive had multiple partitions and offer to remove the master device if I remember correctly. Now I have to manually unmount four partitions on my 2 TB external disk every time I want to remove it.

Expected behaviour - Expected behaviour - when Unity detects that the user is ejecting a partition that is on an external drive containing more partitions, it should offer to safely remove the whole device. Alternatively there should be two options upon right clicking a drive icon - "unmount only the partition" and "safely remove master device".

Jano (2-jano) wrote :

Why is it a "Won't fix" when there are workarounds avaible?
http://nikunjlahoti.com/2012/11/09/missing-safely-remove-in-ubuntu-12-10/
Couldn't it be fixed this way? I think this is a serious bug for a operating system. It made me change back to 12.04 because i don't want to lose my data when I disconnect my Harddrive while its still used and spinning!

tecknomage (tecknode) wrote :

The function of "Safely Remove" is to remove POWER from USB connected devices.

Unplugging any device while powered up is UNSAFE! This bug is not about unmounting a USB drive/stick.

If Windoz has no problem with "Safely Remove" are we saying Ubuntu cannot do it? Really?

description: updated
description: updated
summary: - [quantal] Missing "Safely Remove Drive" and "Eject" options from context
- menu. Only have "Unmount".
+ [quantal] Missing "Safely Remove Drive" and "Eject" options from
+ Quicklists. Only have "Unmount".

I agree we could just:
  1. Unmount all partitions; and then
  2. Suspend the drive (put it to sleep).
That should be a safe way to remove the drive.

The main issue with this bug is that the Unity launcher is presently tied to the Nautilus behaviour. So far we have only mirrored what Nautilus would let you do. But we don't really need to. If there's a safe way to shut down a drive without risking removing it (it may be an internal device), then we should. But a better solution would be to keep the smarts in the Gnome API so the same fix applies to Nautilus and the launcher.

tecknomage (tecknode) wrote :

Again, putting a drive to 'sleep' is NOT correct fix!

You have to REMOVE POWER first, to *safely* remove/disconnect a USB drive.

That is what Safely Remove did in older versions of Ubuntu.

Daniel van Vugt (vanvugt) wrote :

Actually, you have to unmount all partitions first to avoid filesystem corruption. That's the one thing that is absolutely critical.

After that, yes, remove power if you can. However the reason why Gnome is treating this bug as Won't Fix is because there are too many device types that are unsafe to power down. Devices like optical drives and card readers that look like internal devices to you, but to the OS are USB devices in some cases. So Linux thinks they're safe to power down (which you can't recover from without rebooting).

Nick Hall (n-hall) wrote :

Some USB sticks have a light to indicate when they are powered. In 12.04, when "Safely Remove" was selected the light on the stick (and USB hub if plugged into a hub) go off. This is the expected behaviour.

There is no longer a "Safely Remove" option in 12.10. If I select "Eject", neither the light on the stick or hub go off. This doesn't give a good indication to the user that the drive can safely be removed.

I also have a problem that a Lexar 64MB Jumpdrive (05dc:0080) will re-appear on the launcher after I eject it.

Blair Zimmer (bmazimm) wrote :

Martin Pitt (pitti) wrote on 2012-11-13: #13
The "safe remove" functionality was removed from udisks2, and it's not planned to bring it back. It caused too much trouble with e. g. devices which are internally wired to an USB port, and you could never use them again until after a reboot. Also, having two options was a constant source of confusion. So I'm afraid this is "wontfix" from the distro side.

Martin, There is myself and I am sure many others who find this justification "unacceptable"! I have several systems in which devices are connected internally via USB headers/ports. Yes, the option does exist, be it Ubuntu 12.04.1, Windows XP-7, etc. to safely remove these devices via a right-click, even though they are devices that would not normally require such action. Examples of these devices are a wireless N network adapter, an internal media card reader with USB port, etc. Quite frankly, it comes down to a user exercising diligence when right-clicking on any device and knowing what device it is that they are about to safely remove beforehand! Saying that it causes too much trouble for devices that would then require a reboot to use again is in my opinion, a cop-out! It is a chance that most users would be willing to take, to err on the side of caution when it comes to properly powering down a device first before removing it! If it is a choice between having the safely remove command available to remove a device properly by completely powering it down or not having the safely remove command available at all in an attempt to eliminate the confusion that exists in correlation to the eject/unmount commands while helping to prevent some users from accidentally removing the wrong device, I think the majority of users do not find it as confusing as you implicate. I and others I am sure would rather have the option to safely power down our devices using the safely remove command and thus this is a request to have it formally reinstated. This too, has prevented me from upgrading to Ubuntu 12.10!

Download full text (3.3 KiB)

If there can't be a "safely remove" option, could you at least add an
"unmount all partitions on device" option or something similar so that
people don't have to right-click and unmount X partitions separately before
they can unplug the device? I'm guessing it can't be that hard to find
other partitions mounted from a certain device if one has been selected.

Anyway, from all the machines with Linux installed I've worked on over the
years I haven't once encountered an internally wired USB device and I have
to deal with my multi-TB external disks and their numerous partitions
daily. I think that a mistake of forgetting to unmount one of 6-7
partitions and causing the loss of data greatly outweights having to reboot
your machine if you accidentaly unmount an internally wired CD drive or
something.

On Fri, Dec 7, 2012 at 7:01 AM, Blair Zimmer <email address hidden> wrote:

> Martin Pitt (pitti) wrote on 2012-11-13: #13
> The "safe remove" functionality was removed from udisks2, and it's not
> planned to bring it back. It caused too much trouble with e. g. devices
> which are internally wired to an USB port, and you could never use them
> again until after a reboot. Also, having two options was a constant source
> of confusion. So I'm afraid this is "wontfix" from the distro side.
>
> Martin, There is myself and I am sure many others who find this
> justification "unacceptable"! I have several systems in which devices
> are connected internally via USB headers/ports. Yes, the option does
> exist, be it Ubuntu 12.04.1, Windows XP-7, etc. to safely remove these
> devices via a right-click, even though they are devices that would not
> normally require such action. Examples of these devices are a wireless
> N network adapter, an internal media card reader with USB port, etc.
> Quite frankly, it comes down to a user exercising diligence when right-
> clicking on any device and knowing what device it is that they are about
> to safely remove beforehand! Saying that it causes too much trouble for
> devices that would then require a reboot to use again is in my opinion,
> a cop-out! It is a chance that most users would be willing to take, to
> err on the side of caution when it comes to properly powering down a
> device first before removing it! If it is a choice between having the
> safely remove command available to remove a device properly by
> completely powering it down or not having the safely remove command
> available at all in an attempt to eliminate the confusion that exists in
> correlation to the eject/unmount commands while helping to prevent some
> users from accidentally removing the wrong device, I think the majority
> of users do not find it as confusing as you implicate. I and others I
> am sure would rather have the option to safely power down our devices
> using the safely remove command and thus this is a request to have it
> formally reinstated. This too, has prevented me from upgrading to
> Ubuntu 12.10!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1081716).
> https://bugs.launchpad.net/bugs/1067876
>
> Title:
> [quantal] Missing "Safely Remove Drive" and "Eje...

Read more...

I have encountered internally wired USB devices in two cases:
  1. An old Thinkpad connected the internal optical drive via USB.
  2. An internal card reader that fits a 3.5" drive bay and connects to a USB header.
In both cases, a full "Eject" of the device rendered it unusable till next reboot.

But I agree they are rare and we should not be punishing everyone just to avoid problems with such devices.

Xartsak (xartsak) wrote :

Safely Remove missing from ubuntu 12.10 qicklist ...
do we have any solutions ... Unplugging any device while powered up is dangerous!

Olaf (tholap) wrote :

So - we had this feature. And then it got removed to avoid rare problems and replace them with common problems?
(sigh)

Jan Tománek (janiktomanek) wrote :

Excuse me, is there any way it could get fixed in Ubuntu, evethough Gnome guys decided they won't fix it? There surely must be a way to recognise HDDs from card readers. A script that would do it is nice, but needs more clicks, can't we just have the old feature back?

This Gnome approach to things makes me a bit angry and wishing bad things to people.

tecknomage (tecknode) wrote :

Jan,

The "won't fix" decision is not by users and IMHO is bogus. Ubuntu 12.04 had the 'Safely Remove' feature and it worked. 'They *removed* it in 12.10 version.

'They' are also saying that Windoz CAN have the feature but Ubuntu cannot, which is BS.

By the way, I've tried Linux Mint and SUSE and both had the feature.

2 comments hidden view all 113 comments
Mircea Moldovan (mirceamld) wrote :

You can use my bash script from command line or through a shortcut key.

Lisa Schmidt (boxnotify) wrote :

Why not have "Eject" for USB sticks and other removable media, and "Safely remove" for external hard disks? For USB sticks and alike, "Eject" is alright, because it's usually safe. But for an external hard disk, it should be made more safe:
Clicking "Safely remove" should show a dialog window to confirm the action, so that users don't do this by accident.

Arthur Tan (artgtan) wrote :

How does the system distinguish between USB sticks and external hard drives (other than size)?

I've noticed that Nautilus actions do not trigger OSD notifications. Removing external media by right-clicking within nautilus will not generate OSD notifications.

The OSD notification behavior is not consistent. In 12.04 right-clicking and Ejecting in the LAUNCHER triggers an OSD notification, but right-clicking and selecting Safely-Remove in the launcher does not.

I think that any action on external media - from the Launcher or from Nautilus - should generate OSD notifications whether its Eject, or Safely Remove, or Unmount, etc.

tecknomage (tecknode) wrote :

Lisa,

[Safely Remove] = eject + REMOVE POWER from USB device.

The 'remove power' is the main issue. Removing/disconnecting ANY electronic device with power still applied is dangerous. This is the reason for [Safely Remove] option for mounted USB sticks.

Without the [Safely Remove] option, the only way to SAFELY remove/disconnect a USB stick is to shutdown your system first.

As I said before, the reasoning given for NOT putting [Safely Remove] is bogus and dangerous thinking. It is evidence that those who made the decision to remove the option are saying they are dumber than Windoz or other Linux OS which HAVE the option.

Sebastien Bacher (seb128) wrote :

Thanks all for your interest to this issue, Ubuntu is neither writting udisk nor responsible for that change, could one of you engage the conversation with the people writing this software by opening a bug on https://bugs.freedesktop.org/enter_bug.cgi?product=udisks ?

2 comments hidden view all 113 comments

A forward of bug 1067876 ( https://bugs.launchpad.net/ubuntu/+source/udisks2/+bug/1067876 ) on Launchpad:

In Ubuntu 12.04, I could right-click on my usb-external-harddrive's Unity-Task-Bar icon (launcher icon) and select "Safely Remove". Upon doing this, the icon would disappear and I would proceed in unplugging my external hard drive.

However, since upgrading to Ubuntu 12.10, this option is no longer available in the context menus (Quicklists) for external drives.

Instead, all I see is "Unmount", and after clicking "Unmount" the icon remains on the task-bar (launcher) and no indication is given that would imply that the unmount occurred successfully.

The intent of this report is to bring back the "Safely Remove" option which (by making the icon disappear after selected) indicates that you may now safely removal your USB external hard drive (by unplugging its usb connector).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Wed Oct 17 14:55:17 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to quantal on 2012-10-04 (13 days ago)

Also, the safely remove option would recognise if the external drive had multiple partitions and offer to remove the master device if I remember correctly. Now I have to manually unmount four partitions on my 2 TB external disk every time I want to remove it.

Expected behaviour - when it's detected that the user is ejecting a partition that is on an external drive containing more partitions, it should offer to safely remove the whole device. Alternatively there should be two options upon right clicking a drive icon - "unmount only the partition" and "safely remove master device".

2 comments hidden view all 113 comments
Dražen Lučanin (kermit666) wrote :

OK, I've opened a bug upstream:

https://bugs.freedesktop.org/show_bug.cgi?id=60293

Please, everybody who is interested subscribe to that thread too (you can add yourselves to the CC list and save changes, the beauty of having 10 different bug systems :).

Sebastien Bacher (seb128) wrote :

> OK, I've opened a bug upstream:

thank you!

Changed in gvfs:
status: New → Invalid
Changed in udisks:
importance: Unknown → Medium
status: Unknown → Confirmed
2 comments hidden view all 113 comments

NOTE: This bug is mirrored in https://bugs.launchpad.net/bugs/1067876

[Safely Remove] function = eject + REMOVE POWER.

It's the Remove Power function that is vitally important. Disconnecting ANY electronic device with power applied is dangerous.

As noted in the Launchpad reference Windoz and other Linux Distros (example SUSE & Mint) have this feature. So it should NOT have been removed from Ubuntu 12.10, there is NO logical reason why it was removed.

Changed in udisks:
status: Confirmed → Won't Fix
Martin Pitt (pitti) on 2013-02-11
Changed in udisks2 (Ubuntu):
status: Won't Fix → Triaged
Changed in gvfs (Ubuntu):
status: Invalid → Triaged
Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
summary: - [quantal] Missing "Safely Remove Drive" and "Eject" options from
- Quicklists. Only have "Unmount".
+ Missing "Safely Remove Drive" and "Eject" options from Quicklists. Only
+ have "Unmount".
Changed in udisks2 (Ubuntu):
status: Triaged → In Progress
Norbert (nrbrtx) on 2013-02-16
no longer affects: gnome-disk-utility
Norbert (nrbrtx) on 2013-02-16
no longer affects: nautilus
Martin Pitt (pitti) on 2013-03-04
summary: Missing "Safely Remove Drive" and "Eject" options from Quicklists. Only
- have "Unmount".
+ have "Eject".
summary: - Missing "Safely Remove Drive" and "Eject" options from Quicklists. Only
- have "Eject".
+ Missing "Safely Remove Drive" option from Quicklists. Only have "Eject".
Martin Pitt (pitti) on 2013-03-04
Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Changed in udisks2 (Ubuntu):
status: In Progress → Fix Committed
Changed in udisks2 (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2013-03-05
Changed in gvfs (Ubuntu):
status: Fix Released → In Progress
Martin Pitt (pitti) on 2013-03-06
Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2013-03-06
Changed in gvfs:
importance: Low → Unknown
status: Invalid → Unknown
Changed in gvfs (Ubuntu):
status: In Progress → Fix Released
status: Fix Released → In Progress
Changed in gvfs (Ubuntu):
status: In Progress → Fix Released
Changed in gvfs:
importance: Unknown → Low
status: Unknown → New
Changed in opensuse:
importance: Unknown → High
status: Unknown → Confirmed
Changed in nautilus:
importance: Unknown → High
status: Unknown → New
Norbert (nrbrtx) on 2013-03-14
tags: added: raring
Changed in nautilus (Mandriva):
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus:
importance: High → Medium
33 comments hidden view all 113 comments
Norbert (nrbrtx) wrote :

Safely remove remains broken but nobody cares.
While 'udisks --detach' and 'bdin' works (not user-friendly).

Norbert (nrbrtx) wrote :

Safely remove remains broken but nobody cares.
While 'udisks --detach' and 'bdin' works (not user-friendly).

(Again!)

I submitted this bug in October of 2012, and I'm surprised that this regression hasn't been fixed for 13.04.

I too have confirmed that the issue remains (currently) with only 3 days remaining before the release of Ubuntu13.04:
http://djazz.mine.nu/files/ubuntucountdown/

Norbert (nrbrtx) wrote :

Congratulations, you brought this bug to 13.04 Raring Ringtail release!

tags: removed: amd64
Sebastien Bacher (seb128) wrote :

@Norbert: please refrain from writting sarcastic comments there, the bug tracker is a medium to get work done, not to troll volunteers because they didn't work on your pet issues during their evenings. You are welcome to submit a patch as well if you want, the code is available

Norbert (nrbrtx) wrote :

Thank you reply, Sebastien. I don't want to troll volunteers. I'm sorry.

I understand that problem is caused by fundamental changes in upstream (udisks, gvfs, nautilus, etc.) and that Ubuntu developers took buggy packages from upstream. I prefer LTS versions, I use 12.04.2 on 1 my PC and 2 laptops.

As original bug reporter stated, today is 04/2013 and bug was reported at 10/2012 - so where is a progress?
Bug exists in Fedora, OpenSuse, etc (see above).
It seems that nobody cared here and in upstream. This is a reason of my sarcasm.

Sebastien Bacher (seb128) wrote :

> It seems that nobody cared here

well, that's a wrong assumption, I wouldn't be subscribed to this bug and wouldn't comment on it if I wasn't caring. See the number of the bug "1068786", it's over a million bugs registered on launchpad... not sure how many people care and work on those but it's probably in the magnitude of some hundreds, who do work on them on their free time or sometime on work time from companies, like Canonical, who give time and resources to improve Ubuntu.

Summary: there are ton to do, a limited number of people doing hard work. Trolling them for not doing enough, for you (and others), on their free time can be depressing.

5 comments hidden view all 113 comments

Bug still exists in OpenSuSe 12.3.
Please inform GNOME developers and fix this bug using joint efforts.

4 comments hidden view all 113 comments
Norbert (nrbrtx) wrote :

This bug is very hot here, 94 users are affected.
It still exists in Fedora 18 and OpenSuSe 12.3.

Norbert (nrbrtx) wrote :

Bug exists in Gnome 3.8 too (Ubuntu 13.04 with ppa:gnome3-team/gnome3, Fedora 19, OpenSuse Thumbleweed).

Please inform Gnome developers and fix this bug using joint efforts. I have already wrote to upstream.

4 comments hidden view all 113 comments

Bug exists in Gnome 3.8 (OpenSuse Tumbleweed).

3 comments hidden view all 113 comments
Sebastien Bacher (seb128) wrote :

What sort of devices are you using? eject should work just fine on usb stick? is there a real problem or just an user perception one? having some details on what the actual problem is, if there is one, would be useful. Eject should lead to the datas to be synced on the filesystem before eject and so not lead to any issue with the datas...

Norbert (nrbrtx) wrote :

Hello, Sebastien!

I’ll summarize my posts here.

My main linux distro is Ubuntu 12.04 and I think that Ubuntu is the best distro and will fix the bug #1 soon :)

In Ubuntu 12.04, Gentoo stable, Debian 6 and Debian 7 safely remove works for both USB-flash and USB-HDD.

In Ubuntu 12.10 and 13.04 (even with Gnome 3.8 from ppa); OpenSuse 12.3 and Tumbleweed; Fedora 18 and 19; Sabayon 11 safely remove does not exist or does not work as before.

I did some tests at my free time for Ubuntu and linux community. It seems that this bug is not Ubuntu-oriented, it is distro-wide.

We have 94 users affected by this bug here (they does not make as much buzz as me) and some in other bug-trackers.

I tested 4 USB-flashes and 1 USB-HDD on different PCs and distros (see my table at Google Docs for product names and USB VIDs and PIDs - https://docs.google.com/spreadsheet/ccc?key=0Ao5e713Ig9g_dEtqbmhOVnJuVmRmOEx1QXpMSncwbEE#gid=0 ).

1. USB flashes
I understand that removing unmounted (and synced) flash is quite safely operation. But in 12.04 (and other distros) flash led switched off after Safely remove. For me it is more comfortable to remove flash which LED is switched off.

In Ubuntu 13.04 I see Safely remove entry for only one my USB flash (Kingston DataTraveller G2 16 GB), and it works as expected (after pressing Safely remove LED on flash switched off, flash is removed from lsusb, fdisk -l and gnome-disks).

For 3 other flashes I see only Eject option. After pressing Eject LED on flash is switced on, flash is removed from fdisk -l, but still exists in lsusb and gnome-disks). After Eject I can not switch USB-flash manually (by udisks --detach).

2. USB HDDs
In Ubuntu 13.04 there is no way to spin down USB-HDD from GUI. I can spin down HDD only from console with udisks --detach. There is a Safely remove option in Nautilus window, but it does not spin down the drive. It removes drive from lsusb, fdisk -l and gnome-disks, but plates are rotating. I understand that SATA HDD are hot-swappable, but it’s not comfortable for me to remove rotating hard-drive.

So I hope that convenient safely remove will be back in next releases of major distros and Ubuntu.

I prefer LTS versions of Ubuntu - I use 12.04, and safely remove works in it as I expect.
If you does not believe my results - you can repeat these tests by yourself.

Download full text (3.3 KiB)

And another issue from my point of view that Norbert forgot to mention -
when your external hard drive has several partitions (which I think is
quite common nowadays, with multi-TB sizes), there is no more an option to
remove the whole device with a single action. This used to be the "safely
remove drive" option.

Instead, one has to right-click -> eject every partition on it (quite
cumbersome for my 4 partitions, especially since I have to discern them by
name from my internal HD partitions used for Windows).

On Mon, Apr 29, 2013 at 11:05 AM, Norbert <email address hidden>wrote:

> Hello, Sebastien!
>
> I’ll summarize my posts here.
>
> My main linux distro is Ubuntu 12.04 and I think that Ubuntu is the best
> distro and will fix the bug #1 soon :)
>
> In Ubuntu 12.04, Gentoo stable, Debian 6 and Debian 7 safely remove
> works for both USB-flash and USB-HDD.
>
> In Ubuntu 12.10 and 13.04 (even with Gnome 3.8 from ppa); OpenSuse 12.3
> and Tumbleweed; Fedora 18 and 19; Sabayon 11 safely remove does not
> exist or does not work as before.
>
> I did some tests at my free time for Ubuntu and linux community. It
> seems that this bug is not Ubuntu-oriented, it is distro-wide.
>
> We have 94 users affected by this bug here (they does not make as much
> buzz as me) and some in other bug-trackers.
>
>
> I tested 4 USB-flashes and 1 USB-HDD on different PCs and distros (see my
> table at Google Docs for product names and USB VIDs and PIDs -
> https://docs.google.com/spreadsheet/ccc?key=0Ao5e713Ig9g_dEtqbmhOVnJuVmRmOEx1QXpMSncwbEE#gid=0).
>
> 1. USB flashes
> I understand that removing unmounted (and synced) flash is quite safely
> operation. But in 12.04 (and other distros) flash led switched off after
> Safely remove. For me it is more comfortable to remove flash which LED is
> switched off.
>
> In Ubuntu 13.04 I see Safely remove entry for only one my USB flash
> (Kingston DataTraveller G2 16 GB), and it works as expected (after
> pressing Safely remove LED on flash switched off, flash is removed from
> lsusb, fdisk -l and gnome-disks).
>
> For 3 other flashes I see only Eject option. After pressing Eject LED on
> flash is switced on, flash is removed from fdisk -l, but still exists in
> lsusb and gnome-disks). After Eject I can not switch USB-flash manually
> (by udisks --detach).
>
> 2. USB HDDs
> In Ubuntu 13.04 there is no way to spin down USB-HDD from GUI. I can spin
> down HDD only from console with udisks --detach. There is a Safely remove
> option in Nautilus window, but it does not spin down the drive. It removes
> drive from lsusb, fdisk -l and gnome-disks, but plates are rotating. I
> understand that SATA HDD are hot-swappable, but it’s not comfortable for me
> to remove rotating hard-drive.
>
> So I hope that convenient safely remove will be back in next releases of
> major distros and Ubuntu.
>
> I prefer LTS versions of Ubuntu - I use 12.04, and safely remove works in
> it as I expect.
> If you does not believe my results - you can repeat these tests by
> yourself.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1081716).
> https://bugs.launchpad.net/bugs/1067876
>
> Title:
>...

Read more...

Norbert (nrbrtx) on 2013-04-29
no longer affects: udisks (ALT Linux)
2 comments hidden view all 113 comments
Norbert (nrbrtx) wrote :

Hello, guys!
I have recently installed Debian Wheezy and installed Nautilus 3.8 from experimental (package 'nautilus_3.8.0-1_i386.deb' from here http://packages.debian.org/experimental/i386/nautilus/download) with
apt-get install -t experimental nautilus.

I found interesting moment. There is no udisks2 package in the system. Safely remove works as expected for both USB-flash (with all 5 my flashes) and USB-HDD. It's great!

Dražen Lučanin [2013-04-29 9:38 -0000]:
> And another issue from my point of view that Norbert forgot to mention -
> when your external hard drive has several partitions (which I think is
> quite common nowadays, with multi-TB sizes), there is no more an option to
> remove the whole device with a single action. This used to be the "safely
> remove drive" option.

That's not the case here, though. eject is supposed to unmount all
partitions and make all /dev/sdaN go away.

What's the matter with the developers of Nautilus? Under Ubuntu 13.04, I can no longer see all attached drives. Instead, 'Computer' now displays the root directory of the main drive, which is wrong. My mobile broadband dongle doesn't show up at all anymore and it seems to have been affected after constantly removing it without being able to eject it. I now have to use Disk Utility to eject it properly. If Disk Utility can see all attached devices and provide the ability to eject them, then why can't Nautilus anymore? Besides this big problem, the arrangement on the toolbar is so inconsistent and there is no status bar anymore to show the total number of items. Please restore essential functionality and provide a decent interface.

17 comments hidden view all 113 comments

Bug still exists in OpenSuSe 12.3.
Please inform GNOME developers and fix this bug using joint efforts.

16 comments hidden view all 113 comments
Norbert (nrbrtx) wrote :

Hello, guys!

Bug is still exists in Ubuntu 12.10 and 13.04 (both are supported).

Norbert (nrbrtx) wrote :

Bug is present in development branch (Saucy Salamander, 13.10) too.

Norbert (nrbrtx) wrote :

Bug is present in development branch (Saucy Salamander, 13.10) Ubuntu GNOME too.

Norbert (nrbrtx) wrote :

Bug is present in development branch (Saucy Salamander, 13.10) Ubuntu GNOME too. Tested today.

Norbert (nrbrtx) wrote :

Regular Ubuntu 13.10 is still affected too.

Norbert (nrbrtx) wrote :

Regular Saucy is still affected by this bug.

Norbert (nrbrtx) wrote :

Ubuntu 13.10 GNOME is affected too.

Dražen Lučanin (kermit666) wrote :

I started seeing the "eject master device" option in the latest updates to
Ubuntu 13.04, which unmounts all the partitions.

On Sun, Sep 29, 2013 at 3:37 PM, Norbert <email address hidden> wrote:

> Ubuntu 13.10 GNOME is affected too.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1081716).
> https://bugs.launchpad.net/bugs/1067876
>
> Title:
> Missing "Safely Remove Drive" option from Quicklists. Only have
> "Eject".
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gvfs/+bug/1067876/+subscriptions
>

Norbert (nrbrtx) wrote :

>I started seeing the "eject master device" option in the latest updates to
>Ubuntu 13.04, which unmounts all the partitions.
It's good, Dražen.

But I mean normal safely remove which switches USB-flash LED off and spins down external USB-HDD.
This functionality is missed now (starting from Ubuntu 12.10).
But non-user-friendly "udisks --detach /dev/sdX" works normally.

Dražen Lučanin (kermit666) wrote :

OK, Norbert, I understand. I will also sleep easier once we get our "safely
remove" option back :)

On Mon, Sep 30, 2013 at 11:48 AM, Norbert <email address hidden>wrote:

> >I started seeing the "eject master device" option in the latest updates to
> >Ubuntu 13.04, which unmounts all the partitions.
> It's good, Dražen.
>
> But I mean normal safely remove which switches USB-flash LED off and spins
> down external USB-HDD.
> This functionality is missed now (starting from Ubuntu 12.10).
> But non-user-friendly "udisks --detach /dev/sdX" works normally.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1081716).
> https://bugs.launchpad.net/bugs/1067876
>
> Title:
> Missing "Safely Remove Drive" option from Quicklists. Only have
> "Eject".
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gvfs/+bug/1067876/+subscriptions
>

Norbert (nrbrtx) wrote :

Bug is still here. It seems that 13.10 will have this bug.

Norbert (nrbrtx) wrote :

Bug exists in Saucy final release.

Norbert (nrbrtx) on 2013-10-18
tags: added: saucy
Changed in nautilus (Gentoo Linux):
importance: Unknown → High
status: Unknown → New
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 14.04 with all installed updates.

tags: added: trusty
Norbert (nrbrtx) wrote :

Bug still exists in Ubuntu 14.04 with all installed updates.

Phillip Susi (psusi) wrote :

I'm seeing the safely remove option just fine in 13.10.

3 comments hidden view all 113 comments

Bug still exists in OpenSuSe 13.1.
Please inform GNOME developers and fix this bug using joint efforts.

2 comments hidden view all 113 comments
Norbert (nrbrtx) wrote :

Thank you for good news, Phillip!
For what devices do you have safely remove option?
If it is USB-flash - did LED on it switched off after Safely Remove?
If it is USB-HDD - did it spinned-down after Safely Remove?

I tested 3 flashes and 2 USB-HDDs on Ubuntu 13.10 on Unity session.
Unity launcher and Nautilus showed Safely Remove only for my HDDs. After Safely remove they do not spin-down as were in 12.04. My USB-flashes have only Eject, after Eject they have LED on, which is not expected.
So for me Safely remove is still broken.

Phillip Susi (psusi) wrote :

I tested with usb flash sticks, and yes, the light goes off after safely remove.

After you safe remote the hd, does the /dev/?da file still show up?

2 comments hidden view all 113 comments
Download full text (3.1 KiB)

On Sat, 18 Jan 2014 20:59:06 -0000, you wrote:

Q> I'm seeing the safely remove option just fine in 13.10.
Q>

It is NOT working correctly. It does unmount a thumb drive but DOES
NOT POWER IT OFF. I know because my thumb drives have a power LED,
after 'Safely' removing, or unmounting, the LED is still on.

"Safely" remove works correctly in Windoze because it removes *power*
from the port.

Q> You received this bug notification because you are subscribed to the bug
Q> report.
Q> https://bugs.launchpad.net/bugs/1067876
Q>
Q> Title:
Q> Missing "Safely Remove Drive" option from Quicklists. Only have
Q> "Eject".
Q>
Q> Status in GVFS:
Q> New
Q> Status in The Linux Mint Distribution:
Q> New
Q> Status in Nautilus:
Q> New
Q> Status in abstraction for enumerating and managing block devices:
Q> Won't Fix
Q> Status in Unity:
Q> Invalid
Q> Status in “gvfs” package in Ubuntu:
Q> Fix Released
Q> Status in “udisks2” package in Ubuntu:
Q> Fix Released
Q> Status in “udisks2” package in ALT Linux:
Q> Unknown
Q> Status in Fedora:
Q> Unknown
Q> Status in “nautilus” package in Gentoo Linux:
Q> New
Q> Status in “nautilus” package in Mandriva:
Q> Confirmed
Q> Status in openSUSE:
Q> Confirmed
Q>
Q> Bug description:
Q> In Ubuntu 12.04, I could right-click on my usb-external-harddrive's
Q> Unity-Task-Bar icon (launcher icon) and select "Safely Remove". Upon
Q> doing this, the icon would disappear and I would proceed in unplugging
Q> my external hard drive.
Q>
Q> However, since upgrading to Ubuntu 12.10, this option is no longer
Q> available in the context menus (Quicklists) for external drives.
Q>
Q> Instead, all I see is "Unmount", and after clicking "Unmount" the icon
Q> remains on the task-bar (launcher) and no indication is given that
Q> would imply that the unmount occurred successfully.
Q>
Q> The intent of this report is to bring back the "Safely Remove" option
Q> which (by making the icon disappear after selected) indicates that you
Q> may now safely removal your USB external hard drive (by unplugging its
Q> usb connector).
Q>
Q> ProblemType: Bug
Q> DistroRelease: Ubuntu 12.10
Q> Package: unity 6.8.0-0ubuntu2
Q> ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Q> Uname: Linux 3.5.0-17-generic x86_64
Q> NonfreeKernelModules: wl
Q> ApportVersion: 2.6.1-0ubuntu3
Q> Architecture: amd64
Q> CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Q> Date: Wed Oct 17 14:55:17 2012
Q> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
Q> ProcEnviron:
Q>  TERM=xterm
Q>  PATH=(custom, no user)
Q>  XDG_RUNTIME_DIR=<set>
Q>  LANG=en_US.UTF-8
Q>  SHELL=/bin/bash
Q> SourcePackage: unity
Q> UpgradeStatus: Upgraded to quantal on 2012-10-04 (13 days ago)
Q>
Q> To manage notifications about this bug go to:
Q> https://bugs.launchpad.net/gvfs/+bug/1067876/+subscriptions
--
=========== Tecknomage ===========
   Computer Systems Specialist
         IT Technician
           (retired)
  ...

Read more...

Phillip Susi (psusi) wrote :

Can you run tail -f -n 0 /var/log/syslog, then activate the safely remove option, and paste the output, and check to see if the /dev/sdX node is still present?

Norbert (nrbrtx) wrote :

It seems that problem is fixed with the newest version udisks2 2.1.3-1 in Trusty.
From NEWS file:
      Send SCSI START STOP UNIT when powering down a drive (see this commit - http://cgit.freedesktop.org/udisks/commit/?id=fcdd8f48b6ac9b1b6da82fdf5f59230fc2ea6feb)
      udisksctl: add power-off verb to power off drives (see this commit - http://cgit.freedesktop.org/udisks/commit/?id=a54c2fa14c522487a78828d4a9dfd89f916a3576)

It spins down my USB-HDD with safely remove. It's great.

Please note:
   * with modern version of udisks2 "Safely remove drive" in Nautilus and "Safely remove parent drive" in Unity options are available only for USB-HDDs,
   * for USB-flashes there is only Eject option and it is normal.

Zwylicht (zwylicht) wrote :

I do not encounter the problem with 14.04 anymore.

Displaying first 40 and last 40 comments. View all 113 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.