hewlett-packard keymap for Presario CQ60

Bug #935804 reported by steubens on 2012-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Martin Pitt

Bug Description

whilst fixing my touchpad disable key on my own craptop, i discovered gnome-settings-daemon doesn't even bind separate enable/disable key events, just toggle. so the following are at best broke:

ohsix@krang:/lib/udev/keymaps$ grep 0xD[8-9] hewlett-packard*
hewlett-packard-2510p_2530p:0xD8 f23 # touchpad off
hewlett-packard-2510p_2530p:0xD9 f22 # touchpad on
hewlett-packard-pavilion:0xD8 f23 # touchpad off
hewlett-packard-pavilion:0xD9 f22 # touchpad on
hewlett-packard-tx2:0xD8 f23 # Toggle touchpad button on tx2 (OFF)
hewlett-packard-tx2:0xD9 f22 # Toggle touchpad button on tx2 (ON)

what follows is background on what i did to fix up a keymap for mine

i was getting events from keymap -i that looked like this
enabled -> disabled
got scan code event 0xD8 without a key code event
got scan code event 0xD8 without a key code event

disabled -> enabled
scan code: 0xD9 key code: help

so i mapped them to on/off as above, didn't work; checked /apps/gnome_settings_daemon/keybindings saw that it only bound toggle, set them both to f21 (toggle), it then worked.

the touchpad disable key has worked in the past, what i suspect happened is that xorg at one time translated on/off events to toggle events, or that g-s-d at one time caught both or all 3

afair since last looked into, there are now TOUCHPAD_* key codes in input.h, i did not try them.

as an aside, why aren't the keymaps being submitted upstream as suggested the user do in /usr/share/doc/udev/README.keymap.txt.gz? i've seen the same keymaps for quite a few releases

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: udev 167-0ubuntu3 [modified: lib/udev/rules.d/95-keymap.rules]
ProcVersionSignature: Ubuntu 2.6.38-13.55-generic 2.6.38.8
Uname: Linux 2.6.38-13-generic x86_64
Architecture: amd64
Date: Sat Feb 18 13:58:01 2012
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard Compaq Presario CQ60 Notebook PC
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-13-generic root=UUID=d332acb1-e554-4637-84fe-731b5e39212b ro quiet splash vt.handoff=7
SourcePackage: udev
UpgradeStatus: Upgraded to natty on 2011-03-17 (338 days ago)
dmi.bios.date: 12/15/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.65
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3612
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 09.67
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.65:bd12/15/2010:svnHewlett-Packard:pnCompaqPresarioCQ60NotebookPC:pvrPCID:rvnHewlett-Packard:rn3612:rvr09.67:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: Compaq Presario CQ60 Notebook PC
dmi.product.version: PCID
dmi.sys.vendor: Hewlett-Packard

steubens (steubens) wrote :
steubens (steubens) wrote :

this was provided to me while i was writing the initial report, explains some things http://lists.freedesktop.org/archives/xorg/2010-November/051727.html

will update bug when i get a chance to read the thread

Martin Pitt (pitti) wrote :

For your model "Compaq Presario CQ60 Notebook PC", the only rule that matches loads "hewlett-packard-compaq_elitebook", which has a different defintion for 0xD9 and no definition for 0xD8. I'll get that fixed for this model.

Martin Pitt (pitti) wrote :

> as an aside, why aren't the keymaps being submitted upstream as suggested the user do in /usr/share/doc/udev README.keymap.txt.gz?

Not sure what you mean here. All keymaps get committed upstream, we have no Ubuntu patches there.

Martin Pitt (pitti) wrote :

Added your model to the upstream rules. Thanks!

Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Committed
summary: - hewlett-packard keymaps mostly wrong or obsolete
+ hewlett-packard keymap for Presario CQ60
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 175-0ubuntu7

---------------
udev (175-0ubuntu7) precise; urgency=low

  * builtin-block-polling.patch: Fix default attribute comparison for CD
    drives, the default value of events_poll_msecs is -1, not 0. This really
    makes in-kernel polling work for those.
  * builtin-block-polling.patch: Apply to all drives with removable media, not
    just CD drives. (LP: #948663)
  * 00git-keymaps.patch: Update to the latest keymaps from upstream:
    - Dell XPS (LP: #910911)
    - HP Presario CQ60 (LP: #935804)
  * debian/rules: Drop prep and tarball targets. We want to use the upstream
    released tarballs.
  * debian/rules: Use dh_autoreconf. Add build dependency.
 -- Martin Pitt <email address hidden> Wed, 28 Mar 2012 12:23:10 +0200

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers