Comment 165 for bug 903422

actually it now works for me when adding this ppa:

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update

apply all updates and restart computer. found the info here: http://www.webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html