Comment 149 for bug 903422

@Mio, H.-Dirk Schmitt

Please test the latest version of libmtp and gvfs from Philips PPA.

https://launchpad.net/~langdalepl/+archive/gvfs-mtp

Also on my Galaxy S3 and Nexus 7 these (Natty packages) work great!

I would really suggest to get these packages to Natty-backports since the amount of Android devices using MTP in this world is enormous. The current user experience is horrible and hard to explain (like: yes Android is linux-based but it doesn't work with your Ubuntu linux... :-S) while with these new packages the user experience is great (just plug it in, file-manager opens, and there are nice icons for Internal Storage and SD storage).

Every day more and more Android devices are sold, most of them by now having Android OS 4.x+ and only MTP...