Comment 142 for bug 903422

I've been watching the thread for a while now as I still can't find a solution to get any files to/from my mobile devices (HTC One X and Acer A500) but by using ssh (either installing ssd on mobile devices or connection to my laptop/desktop). Both my laptop and desktop are running Ubuntu, usually the last stable one, so now it is Quantal.

First of all I would like to thank the ones working on the solution to this problem as it is a shame that Ubuntu does not support the andriod devices out of box (I've tried to use them since Oneiric with no success).

I've tried the gcfs-mtp solution mentioned above almost with out success. It allowed me to browse folders and open PDF files (only !) on my devices, but I could neither copy or move any files nor open image files.

Now I've udated to the newer version and got even worse results: I still can open a pdf in the root folder of my HTC, but when I try to enter the DCIM folder nautilus closes with "Connection closed" error (I see a localized message in hungarian but if it is important I can check the message the original message). Also I've got
 pool[26210] general protection ip:7f95b802a69c sp:7f95aeffcc28 error:0 in libgobject-2.0.so.0.3400.1[7f95b7ff9000+4d000]
error in my kern.log.

When using my Acer A500 the same thing happens if I try to open the root folder of the device...

Can I do anything to help solving these problems? SHould I post any logs or try anything?