Ubuntu

bluez fails to discover mx5000 keyboard and mouse

Reported by Casey J Peter on 2010-03-28
236
This bug affects 46 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: bluez

Post beta patching as of 3-28-2010 0700 mdt to current. the mx5000 keyboard and mouse no longer are initialized.
The bluez icon (never previously in the status area, now shows up and checking it there are no devices listed. running 'setup new devices "sees" the keyboard/mouse intermittently, but the application loses the ability to see them and so fails to set them up.

this issue did NOT exist prior to the last large group of updates to the beta on my system and has not been an issue since the initial alpha release.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: bluez 4.60-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Mar 28 08:50:52 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100219.1)
InterestingModules: rfcomm sco bnep l2cap btusb bluetooth
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic root=UUID=958d1ad9-2a6c-4d31-8d85-0193f0b8a55b ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: bluez
dmi.bios.date: 10/22/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F10d
dmi.board.name: GA-K8N Pro-SLI
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF10d:bd10/22/2008:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-K8NPro-SLI:rvrx.x:

Casey J Peter (caseyjp1) wrote :
Casey J Peter (caseyjp1) wrote :

Screenshot attached showing 'grant access' dialog which now pops up for the mouse (mx1000). this doesn't succeed even with "always grant aceess" checked....and will continue to pop up intermittently.

Keyboard (mx5000) functions properly through the boot (bios) process, but during grub, the keyboard window (on keyboard) shows "passphrase:" Hitting the enter key allows the keyboard to continue operating normally in the grub phase, but upon GDM start, neither the keyboard or mouse function, requiring a usb keyboard/mouse to continue using the system.
This behavior is NEW and is broken as usb keyboard/mouse is not the normal setup for this testing system.

This does not occur when booting any other OS on this system (Arch and ubuntu karmic).

Casey J Peter (caseyjp1) wrote :

Last addendum to this:

I do NOT use the dongle as a "bluetooth"...rather it was just being utilized as a 'hub' to connect the mouse and keyboard. This functionality is what has recently changed/broken. After looking through the bug reports it appears that the logitech dongle has ALWAYS had issues as a 'bluez' device. this bug report is for loss of functionality that has been working fine since the intrepid release.

hapee (hapee) wrote :

I have similar problems after a Lucid update of 30 march. Bluetooth mouth Logitech MX something is just working fine but the Logitech is not able to connect, it is visable in the bleautooth applet but it is not able to connect to the device. At some point the Applet crashes but it is not possible to use the keyboard.

Casey J Peter (caseyjp1) wrote :

Still no luck after today's updates with the 2.6.32-19 kernel + daily updates.

I'm not sure anyone is even looking at this yet, which surprises me as it would seem that noone uses logitech keyboards + ubuntu?

This is not broken with karmic, nor a current install of Arch, so whatever is broken is broken specifically with Lucid.

Casey J Peter (caseyjp1) on 2010-04-02
tags: added: bluetooth mx5000 usb

I just came home from holyday, and upgraded my Lucid64, and found that ny Locitech DiNovo keypad would not be recognized. Tested both on my laptop and desktop, same issue. Windows OK (so not hardware related)
This had been working fine until my recent upgrade (unfortnatly this had not beed updated in 14 days, so I cannot pinpoint the date whitch this occurred) I'ts not beeing used in BT mode, but "hub" mode... (eg paired between dongle and keyboard, not keyboard and BT-in linux .... think this i same av Chasey's problem).
-Torstein

Casey J Peter (caseyjp1) wrote :

Well...my issue seems to have cleared up...but still not sure completely what caused it to begin with.

I unplugged...replugged...unplugged and then replugged the reciever several times, the last time holding in the red reset button.

The last time, for whatever reason, the utility discovered the mx5000 keyboard, requested a new input pin number, and suddenly it all decided to work again. (including the mouse).

Two reboots as well as a cold shutdown later and lucid seems to remember the keyboard/mouse and works during login, only now the "bluez" applet no longer shows up in the indicator panel after things settle out...which was the way things were before this wankyness started happening in the first place.

My guess here, and its ONLY a guess after rooting through several debian udev bug reports and such is that for some reason the rules don't switch the logitech bluetooth receiver from one mode to another with any reliability. This behavior, as far as I can tell from research, started happening sometime mid-january for some users.

Under Arch there are no issues whatsoever, and Karmic as well. Under Lucid it appears that resetting the keyboard with a new passkey completely has fixed this, but it did require multiple plug/removes of the receiver as well as holding down the red reset button on the device to get bluez to recognize the keyboard. It would see the mouse, but the entry would always disappear after a few minutes in bluez preferences.

My fix to this issue is more along the lines of banging on the box with a hammer, but it does seem to have done the job. As to the issue, I'm not alone with the problem, but at least for now, the mx5000 keyboard/mx1000 mouse are functioning again with the hardware/software in this bug report.

gromez (gromez) wrote :

I confirm this bug with the beta2 Lucid LiveCD. I have the MX5500 keyboard/MX Revolution mouse with the Bluetooth dongle and I've got the same problem.

Relevant lsusb informations :

Bus 001 Device 025: ID 046d:c71c Logitech, Inc.
Bus 001 Device 024: ID 046d:c71b Logitech, Inc.
Bus 001 Device 022: ID 046d:0b06 Logitech, Inc.

Tim Rørstrøm (timroerstroem) wrote :

This may have something to do with the resolution to bug #444420 (or at least udev), since commenting out the two lines mentioned in that bug report (I commented out the line just below the two as well, not sure if that was necessary) resolves the problem.

I had a look at bug #444420 and came up with a solution, well at least one that works for me, I changed a line in /lib/udev/rules.d/70-hid2hci.rules

from

# Logitech devices
KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

to

KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

I also turned bluetooth off from the icon in the notification bar.

Hope this helps

Uli Tillich (utillich) wrote :

Kent thank you very much for that fix, it worked perfectly for me too.

cheers,
Uli

John Ioakimidis (arkan19) wrote :

Kent, your solution worked for me too, despite the fact that it needed two reboots to work correctly(the first time, the only thing working was the mouse, as it did before the change to the rules file).

Thank you!

sbrendtro (steven-brendtro) wrote :

Thanks Kent! It worked perfectly... Just made the udev changes, rebooted and the mouse worked, then hit the connect buttons and the keyboard worked.

planetbeing (planetbeing) wrote :

The fix by Kent Wilkinson also worked for me and was necessary aftter my upgrade to 10.04.

planetbeing (planetbeing) wrote :

Commenting out the lines also appears to fix the problem. I guess the problem is that we never associated our Logitech devices over Bluetooth with Ubuntu (the reason I do not is because it breaks the pairing with Windows) and using the devices as bluetooth host breaks things for us. Hopefully a more elegant solution can be found that allows bluetooth host to be enabled (manually! since not having bluetooth is a lot better than not having a keyboard and a mouse), but doesn't disable our input devices if they are not paired.

Kim Botherway (dj-dvant) wrote :

I am trying the change to hidraw. Hopefully this fixes all the issues.

KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

malrost (estesko) wrote :

Kent's solution worked for me as well; Logitech deNovo Edge keyboard. I had an USB mouse handy and was able to effect the changes using the onscreen keyboard. Took a while though...

irober02 (ianwroberts) wrote :

I edited /lib/udev/rules.d/70-hid2hci.rules as per Kent's workaround, replugged the Logitech USB device, pressed its red button and both keyboard and mouse connected. I guess I may need to repeat that after updates.

Ulrik Mikaelsson (rawler) wrote :

Same problem for me, and the above solution worked.

Konstigt (konstigt) wrote :

Clearly confirmed, updating the status

Changed in bluez (Ubuntu):
status: New → Confirmed
Dave Efflandt (efflandt) wrote :

Normally my Logitech diNovo Edge with its proprietary USB dongle is totally OS independent (does not need any drivers and did not even bring up Bluetooth applet).

It looks like the cause of this breakage is related to bug 444420 for 9.10, which changed hidraw* to hiddev*. Although, that never changed in my 9.10, which always worked fine with my diNovo Edge as hidraw*.

/lib/udev/rules.d/70-hid2hci.rules was changed in 10.04 LTS release, which even breaks installation unless you have another wired keyboard mouse to boot a live session and change hiddev* back to hidraw*. I don't know if there is more than one type of Logitech USB Bluetooth hid dongle, or if some people are unknowingly using some other 3rd party Bluetooth on their PC. But an even simpler solution is to comment out that entirely:

# Logitech devices
#KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
# RUN+="hid2hci --method=logitech-hid --devpath=%p"

Reinsert your Logitech dongle, and it should work (works for me from live session on 10.04 LTS CD).

David Lichterman (lavid) wrote :

why not just change the rules to:
KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345bce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"
KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70a", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

that way we get the best of both worlds: we fix this bug and https://bugs.edge.launchpad.net/bugs/444420

Rahul Khanna (rahul-melbourne) wrote :

Just confirming that I'm having the same problem with the MX5500 - and that this was not an issue in Alpha 3. Haven't tried the work-around yet, need to dig out another keyboard and mouse - but thanks to those that found it.

Trond F (trondf) wrote :

I had to do the same as Dave E to get it to work.
Changing to hidraw did not work, but when commenting out the line entirely it did.

Bhabba (bhabba) wrote :

Hi@all

I was fighting the same problem after installing a fresh Ubuntu 10.04 LTS. First my Logitech bluetooth devices (MX5000 keyboard/MX1000 mouse) didn't work at all which was the reason why I stumbled upon this bug report. But the suggested workarounds didn't help me at all, because what I wanted to have is both working, the bluetooth dongle (thus switching to "HCI mode") and the mouse/keyboard (thus recognized as bluetooth devices). Changeing "hiddev" to "hidraw" or vice versa, commenting it out or any combination (e.g. mouse=hiddev, keyboard=hidraw and so on) mostly results in not switching the bluetooth dongle into HCI mode (hence remaining in HID mode) or doesn't change anything. Of course when the dongle is in HID mode the mouse and keyboard are working but I can't enjoy bluetooth functionality.

Then I discovered that it must have something to do with the pairing of the bluetooth devices because after replacing batteries in the MX5000 keyboard it connected properly (with passkey prompt) through ubuntu's bluetooth wizard. Since devices store the pairing status even after power off somehow in memory you have to "reset" them before trying to connect them with ubuntu. So the only thing I had to do is holding the tiny red button on the bottom side of the MX1000 mouse for a few seconds (same applies to the MX5000 keyboard) and voilà: it worked like a charm! It survived a cold reboot so I'm still happy. Hopefully the same will be effective for the other owners of logitech mice/keyboards.

Greets from Switzerland
-Bhabba

hidraw and red button on dongle worked for me on my dual boot with mx5500 keyboard and mouse ... rebooted to windows ... works ... rebooting back to ubuntu - did NOT work .., reboot again to ubuntu, still nothing ... replaced batteries in keyboard, more red buttons, mouse back ... more reboots and red buttons, consistently inconsistent outcomes in ubuntu ... reboot to windows ... fine ... will try commenting out line tomorrow, but it is late and I'm off to bed

Addendum to the above

Logged into ubuntu the next day, mouse and keyboard working fine :/ Oh well, happy now :)

Bhabba (bhabba) wrote :

In addition to my first post:

This morning I ran across another problem related to the Logitech MX5000-set: It seems that the bluetooth dongle doesn't get activated properly every boot up with the consequence of a not responding mouse/keyboard. Although the bluetooth indicator in the notification area shows up in deactivated/greyed out state it offers the option (by clicking on it) to deactivate bluetooth. If you do so nothing happens for the moment, but now you get finally the option to activate it, which properly works. At this point I was able you use my mouse/keyboard again (of course I did the activation with another non-bluetooth mouse).

Next time I booted up bluetooth was working from the beginning as it did in my first post... no clue what's happening here! But maybe this is the same misbehaviour which my previous speaker "lagerdalek" told about.

Cheers!
-Bhabba

hardhu (qzerty) wrote :

This bug affects also my installation of Lynx 64-bit on a Sony Vaio VPCCW1S1E notebook, and bluetooth mouse Logitech V470. When I try to set up the mouse as a new device, it appears randomly on the list of discovered devices, and also when it appears, then the setting of the mouse fails.

Martin Pitt (pitti) wrote :

This was fixed upstream in http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=8b56bada9a9d9a73af06d27634e53648be0cc612
This is in maverick now, so closing main task and keeping lucid task open.

affects: bluez (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: Confirmed → Fix Released
tags: added: regression-potential
tags: added: regression-release
removed: regression-potential
Changed in udev (Ubuntu Lucid):
status: New → Triaged
Martin Pitt (pitti) wrote :

By switching back in lucid we'd reopen bug 444420. I wonder if things still work for you if you change /lib/udev/rules.d/70-hid2hci.rules to have both variants? Like

# Logitech devices
KERNEL=="hiddev*|hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

Thanks for testing!

Martin Pitt (pitti) wrote :

I also asked in bug 444420 for testing the combined rule.

Josh Mize (jgmize) wrote :

Martin, I tested the combined rule you suggested and it did not work for me. I tried both KERNEL=="hiddev*|hidraw*" and then I tried KERNEL=="hidraw*|hiddev*" just in case the order mattered. However, David Lichterman's suggestion in comment #22 of switching to KERNEL=="hidraw*" just for product id c70a worked for me, and should not revert bug 444420 based on the fact that different product ids were listed in the lsusb output.

Scott (computorwiz) wrote :

The combined fix for this bug and 444420 did not work for me.
I have a MX5500 I am only using the BT Keyboard not the mouse. I am using a MX Revolution Mouse.

Here is list of logitech devices in my lsusb when I plug the BT reciever using the combined fix and the keyboard is NOT WORKING:

Bus 007 Device 042: ID 046d:c709 Logitech, Inc. BT Mini-Receiver (HCI mode)
Bus 007 Device 041: ID 046d:c71c Logitech, Inc.
Bus 007 Device 040: ID 046d:c71b Logitech, Inc.
Bus 007 Device 039: ID 046d:0b06 Logitech, Inc.
Bus 007 Device 002: ID 046d:c526 Logitech, Inc. MX Revolution Cordless Mouse

Here is my lsusb when I plug the BT reciever using only hiddraw* and the keyboard is WORKING:

Bus 007 Device 038: ID 046d:c71c Logitech, Inc.
Bus 007 Device 037: ID 046d:c71b Logitech, Inc.
Bus 007 Device 036: ID 046d:0b06 Logitech, Inc.
Bus 007 Device 002: ID 046d:c526 Logitech, Inc. MX Revolution Cordless Mouse

Josh Mize (jgmize) wrote :

Scott,

Please try this:

KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345bce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"
KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[9a]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

In reply to #36 I want to report that it works for me Josh. Like Scott I tried the previous version:

# Logitech devices
KERNEL=="hiddev*|hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

but that did not work.

This is the full output of lsusb while using a Logitech MX 5000 keyboard and MX 1000 mouse sucessfully:

Bus 002 Device 005: ID 046d:c70a Logitech, Inc. MX5000 Cordless Desktop
Bus 002 Device 004: ID 046d:c70e Logitech, Inc. MX1000 Bluetooth Laser Mouse
Bus 002 Device 003: ID 047f:0ca1 Plantronics, Inc. USB DSP v4 Audio Interface
Bus 002 Device 002: ID 046d:0b02 Logitech, Inc. BT Mini-Receiver (HID proxy mode)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

When I tried the version which combined "hiddev*|hidraw*" there were 2 "Logitech, Inc. BT Mini-Receiver" devices, 0b02 like now in HID proxy mode and c709 in HCI mode. Now c709 is missing. Bluetooth is used for mouse and keyboard connectivity though, so I cannot comment if any other functionality is missing.

Additional note about the importance of this bug, reading that it's "Undecided". From my point of view it should be of very high importance, since in certain hardware configurations it can render the whole system unusable at least when it is used as a desktop and no wired alternative for keyboard and mouse is at hand.

Floyd42 (axelheider) wrote :

Here is how it works for me now:

/lib/udev/rules.d/70-hid2hci.rules:
  KERNEL=="hidraw*|hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
    RUN+="hid2hci --method=logitech-hid --devpath=%p"

Bluetooth works, Mouse and keyboard work via bluetooth only. Pressing
the connect button on the Logitech receiver does nothing. lsubs output:
  ID 046d:c707 Logitech, Inc. Bluetooth wireless hub
  ID 046d:c703 Logitech, Inc. Elite Keyboard Y-RP20 + Mouse MX900 (Bluetooth)

Now I diconnect and reconnect the Logitech USB receiver. Bluetooth no longer
work, but the connect button on the receiver works and allows pairing
mouse/keyboard. lsubs output:
  ID 046d:c703 Logitech, Inc. Elite Keyboard Y-RP20 + Mouse MX900 (Bluetooth)

Actually, I can live with this and I can manually swtich between the two configuration.
But it's still not what was working in karmic with a USB BT receiver and keyboard/mouse
working vie Logitech proprietary wireless interface.

Floyd42 (axelheider) wrote :
Download full text (3.5 KiB)

And here is the syslog:

usb 6-1: new full speed USB device using uhci_hcd and address 2
usb 6-1: configuration #1 chosen from 1 choice
hub 6-1:1.0: USB hub found
hub 6-1:1.0: 2 ports detected
usb 6-1.1: new low speed USB device using uhci_hcd and address 3
usb 6-1.1: configuration #1 chosen from 1 choice
input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.1/6-1.1:1.0/input/input5
generic-usb 0003:046D:C703.0003: input,hidraw2: USB HID v1.10 Keyboard [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input0
input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.1/6-1.1:1.1/input/input6
generic-usb 0003:046D:C703.0004: input,hiddev97,hidraw3: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input1
usb 6-1.2: new full speed USB device using uhci_hcd and address 4
usb 6-1.2: configuration #1 chosen from 1 choice
Bluetooth: Core ver 2.15
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: Generic Bluetooth USB driver ver 0.6
usbcore: registered new interface driver btusb
input: Logitech MX900 Mouse as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.2/6-1.2:1.0/bluetooth/hci0/hci0:44/input8
generic-bluetooth 0005:046D:B001.0005: input,hidraw4: BLUETOOTH HID v22.01 Mouse [Logitech MX900 Mouse] on 00:07:61:12:29:48
input: Logitech Elite Keyboard as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.2/6-1.2:1.0/bluetooth/hci0/hci0:41/input9
generic-bluetooth 0005:046D:B301.0006: input,hidraw5: BLUETOOTH HID v23.04 Keyboard [Logitech Elite Keyboard] on 00:07:61:12:29:48

Now I disconnect the receiver

usb 6-1: USB disconnect, address 2
usb 6-1.1: USB disconnect, address 3
bluetoothd: HCI dev 0 down
bluetoothd: Adapter /org/bluez/1276/hci0 has been disabled
bluetoothd: Stopping security manager 0
usb 6-1.2: USB disconnect, address 4
bluetoothd: HCI dev 0 unregistered
bluetoothd: Unregister path: /org/bluez/1276/hci0

and reconnect it

usb 6-1: new full speed USB device using uhci_hcd and address 5
usb 6-1: configuration #1 chosen from 1 choice
hub 6-1:1.0: USB hub found
hub 6-1:1.0: 2 ports detected
usb 6-1.1: new low speed USB device using uhci_hcd and address 6
usb 6-1.1: configuration #1 chosen from 1 choice
input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.1/6-1.1:1.0/input/input12
generic-usb 0003:046D:C703.0009: input,hidraw2: USB HID v1.10 Keyboard [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input0
input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.1/6-1.1:1.1/input/input13
generic-usb 0003:046D:C703.000A: input,hiddev97,hidraw3: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input1
usb 6-1: USB disconnect, address 5
usb 6-1.1: USB disconnect, address 6
usb 6-1: new full speed USB device using uhci_hcd and address 7
usb 6-1: configuration #1 chosen from 1 choice
hub 6-1:1.0: USB hub found
hub 6-1:1.0: 2 ports detected
usb 6-1.1: new low speed USB device using uhci_hcd and address 8
usb 6-1.1: configuration #1 chosen from 1 choice
input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1.1/6-1.1:1.0/input/input14
generic-usb 0003:046D:...

Read more...

Mattias H (mattias-stubin) wrote :

I have a Logitech Dinovo edge wireless keyboard and just upgraded to 10.04. Applying the fix above (http://git.kernel.org/?p=linux/hotplug/udev.git;a=commit;h=ba854cf8c32a85e9415debdb8d2a7292ddb3c452) does not help me.

$ lsusb
Bus 003 Device 047: ID 046d:c714 Logitech, Inc.
Bus 003 Device 046: ID 046d:c713 Logitech, Inc.
Bus 003 Device 045: ID 046d:0b04 Logitech, Inc.

Then i played around a little and came up with two solutions that works for me:
1)
$ diff 70-hid2hci.rules 70-hid2hci.rules.works_1
14c14
< KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345bce]|c71[34bc]", \
---
> KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345bce]|c71[bc]", \

2)
$ diff 70-hid2hci.rules 70-hid2hci.rules.works_2
14c14
< KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345bce]|c71[34bc]", \
---
> KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345bce]|c71[bc]", \
16c16
< KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70a", \
---
> KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70a|c71[34]", \

Uli Tillich (utillich) wrote :

I had previously gotten my mx5000 working in usb mode via Kents fix (post #10).
After a recent update however my keyboard stopped working. After login (with the virtual keyboard) however I was able to connect it as a Bluetooth device.
Since the Keyboard can now be used in Bluetooth mode, and the dongle can also used to connect other Bluetooth devices I consider this bug to be fixed. Can someone please confirm this.

Miika Laaksonen (miika) wrote :

I can confirm that the recent udev update broke the fix mentioned in this thread. I can also confirm that keyboard and mouse works in Bluetooth HCI mode. However, this bug is for people that prefer HID mode over HCI mode. I have few problems with HCI mode.
1. Keyboard doesn't work when I try to enter to BIOS setup during boot.
2. Keyboard misses few key strokes when it wakes up from the sleep mode.
3. Keyboard and mouse disappear during dist upgrade. https://bugs.launchpad.net/ubuntu/+source/bluez-utils/+bug/154193

I just updated my Ubuntu 10.04 home server, and I am seeing this problem AGAIN.
I don't know exactly which update caused it, because I updated a bunch of packages at the same time.
This is a serious, serious regression in the update. The update has rendered my computer all but useless. Operating it without a mouse and keyboard is challenging to say the least! Do you really think it should be a requirement that all Ubuntu users have a wired keyboard and mouse in order to set up their bluetooth keyboard? Bluetooth mice and keyboards must *work* without any effort at all.
I am an avid proponent for Ubuntu everywhere I go. I am running it on 3 computers at home and trying to push it at my work. Things like this make me look like a fool when they happen to those that I recommend Ubuntu to.

Sorry for sounding like this. It just really gets me worked up when basic things like keyboards do not work. I thought I was just doing a regular update, and know I have my wife on my case because the TV server is down. Losing WAF points every minute.

Bhabba (bhabba) wrote :

@Uli Tillich

In my sight following problems still remain:

1) If the MX5000-set is paired with another computer (or e.g. with windows on a dual-boot machine) and you're trying to connect it with Ubuntu in HCI mode, it won't work unless you've resetted it manually (by pressing the red button for a few seconds on the bottomside of each device). The other way round it's working gracefully.

2) From time to time (I really can't figure out the exact cause) the bluetooth dongle doesn't get activated properly and you gotta fall back on a wired mouse/keyboard to activate it again. For further details see my previous post (#28).

3) As Miika Laaksonen already mentioned, the keyboard misses key strokes (though as far as I can tell not after every wake-up but after boot-up)

4) Until shortly the numeric pad didn't work properly (e.g. did the numbers 4, 6, 8 and 2 work like arrow keys). But now it works just fine (without changeing the keyboard layout or something), so I can't say if I just stumbled upon a Fata Morgana or whatsoever...

However. the problem of a not responding keyboard in BIOS setup which Miika Laaksonen reported doesn't apply to me.

Ulrik Mikaelsson (rawler) wrote :

Adding +1. Kents solution from comment #10 worked, but broke with last update.

Yennix (yennix) wrote :
Download full text (4.3 KiB)

Wanted to kick in with this.

I'm using the Logitech Bluetooth Dongle to connect my MX1000 mouse (all from the MX5000 keyboard/mouse combo kit). I'm only connecting the mouse (ditched the keyboard long ago) so I'm running a really really simplified setup.

I applied the rule updates in comment 10 about 4 months ago. That fixed my mouse up until I applied the udev update last week.

Since then, none of the suggested rules have worked. Not even the combined KERNEL=="hidraw*|hiddev*" fix.

What has worked however, was purging the whole "KERNEL==<BLAH>," reference entirely. I followed the directions in this post (http://ubuntuforums.org/showthread.php?p=9574808) to do only the following:

1) sudo cp /lib/udev/rules.d/70-hid2hci.rules /etc/udev/rules.d/70-hid2hci.rules --- Contents of the /etc/udev/rules.d override the /lib/udev/rules.d and dont get overwritten on an update
2) Change <<KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \>> to <<ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \>>

I didn't do ANY OF THE OTHER STEPS in that document, only the two above. Your mileage may vary;)

So...all that said...I don't know the significance of removing "KERNEL==<BLAH>," from the rule. Presumably, it's there for a very good reason. But since my requirements are so trivial, this appears to work for me (though it should be noted that I haven't restarted my machine yet >.>)

Hopefully this helps rather than hurts.

$ uname -a
Linux sholan 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:21:58 UTC 2010 x86_64 GNU/Linux

$ cat /etc/*release*
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

$ lsusb
Bus 002 Device 008: ID 046d:c709 Logitech, Inc. BT Mini-Receiver (HCI mode)
Bus 002 Device 007: ID 046d:0b02 Logitech, Inc. BT Mini-Receiver (HID proxy mode)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ aptitude show bluez
Package: bluez
State: installed
Automatically installed: no
Version: 4.60-0ubuntu8
Priority: optional
Section: admin
Maintainer: Ubuntu Developers <email address hidden>
Uncompressed Size: 1,401k
Depends: libbluetooth3 (>= 4.60-0ubuntu8), libc6 (>= 2.7), libdbus-1-3 (>= 1.1.1), libglib2.0-0 (>= 2.23.5), libnl1 (>= 1.1), libusb-0.1-4
         (>= 2:0.1.12), module-init-tools, makedev | udev, lsb-base, dbus
Suggests: python-gobject, python-dbus
Conflicts: bluez-utils (<= 3.36-3)
Replaces: bluez-audio, bluez-input, bluez-network, bluez-serial, bluez-utils (<= 4.9)
Description: Bluetooth tools and daemons
 This package contains tools and system daemons for using Bluetooth devices.

 BlueZ is the official Linux Bluetooth protocol stack. It is an Open Source project distributed under GNU General Public License (GPL).
Homepage: http://www.bluez.org

$ aptitude show udev
Package: udev
State: installed
Automatically installed: no
Version: 151-12.1
Priority: required
Section: admin
Maintainer: Scott James Remnant <email address hidden>
Uncompressed Size: 1,626k
Depends: libacl1 (>= 2.2.11-1), libc6 (>= 2.9), libglib2.0-0 (>= 2.16....

Read more...

Konstigt (konstigt) wrote :

After that udev update I just changed the line with 'hiddev' back to 'hidraw' and it worked again..

Smurphy (smurphy-linux) wrote :
Download full text (3.4 KiB)

Having the same issue. Only that mine may be a little bit more complex.
Running a Mac Mini 4,1 (last one available) with KUbuntu. And - because I didn't want to use any more USB Ports, I also got the MX5500 Keyboard/Mouse combination.

So - setup is simple: Mac Mini builtin bluetooth communication device, and MX5500 hooked up to it.
Now - both are recognized as HID devices (Keyboard and mouse).
But - I only have basic functionality on both. Means:
1. The keyboard only has the standard keys to run on (at least I can type). Nothing else (Multimedia keys etc. are running).
2. The mouse only has Left/Right buttons, and mouse function. Nothing else. Roll-function disabled, all supp. keys are disabled as well.

Hence - it's not really usable.
For information - running Maverick 10.10 64Bit version here, latest updates applied.
At least under Mac OS-X I can use the middle Mouse Roll button.

smurphy@pandora:~$ sudo lsusb
Bus 004 Device 006: ID 05ac:8218 Apple, Inc.
Bus 004 Device 005: ID 05ac:820b Apple, Inc.
Bus 004 Device 004: ID 05ac:820a Apple, Inc.
Bus 004 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 004 Device 002: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here the relevant parts for the mouse/keyboard out of lsinput:
/dev/input/event4
   bustype : BUS_USB
   vendor : 0x5ac
   product : 0x820a
   version : 273
   name : "HID 05ac:820a"
   phys : "usb-0000:00:06.0-6.1/input0"
   uniq : ""
   bits ev : EV_SYN EV_KEY EV_MSC EV_LED EV_REP

/dev/input/event5
   bustype : BUS_USB
   vendor : 0x5ac
   product : 0x820b
   version : 273
   name : "HID 05ac:820b"
   phys : "usb-0000:00:06.0-6.2/input0"
   uniq : ""
   bits ev : EV_SYN EV_KEY EV_REL EV_MSC

Dmesg output:
[ 2.085653] usbhid: USB HID core driver
[ 2.099137] apple 0003:05AC:8242.0001: hiddev96,hidraw0: USB HID v1.11 Device [Apple Computer, Inc. IR Receiver] on usb-0000:00:06.0-5/input0
[ 2.358048] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
[ 2.412552] usb 4-6: new full speed USB device using ohci_hcd and address 3
[ 2.649071] hub 4-6:1.0: USB hub found
[ 2.652056] hub 4-6:1.0: 3 ports detected
[ 2.952110] usb 4-6.1: new full speed USB device using ohci_hcd and address 4
[ 3.087301] input: HID 05ac:820a as /devices/pci0000:00/0000:00:06.0/usb4/4-6/4-6.1/4-6.1:1.0/input/input4
[ 3.087393] generic-usb 0003:05AC:820A.0002: input,hidraw1: USB HID v1.11 Keyboard [HID 05ac:820a] on usb-0000:00:06.0-6.1/input0
[ 3.172109] usb 4-6.2: new full speed USB device using ohci_hcd and address 5
[ 3.307343] input: HID 05ac:820b as /devices/pci0000:00/0000:00:06.0/usb4/4-6/4-6.2/4-6.2:1.0/input/input5
[ 3.307455] generic-usb 0003:05AC:820B.0003: input,hidraw2: USB HID v1.11 Mouse [HID 05ac:820b] on usb-0000:00:06.0-6.2/input0
[ 3.392108] usb 4-6.3: new...

Read more...

Smurphy (smurphy-linux) wrote :

What I just wanted to add here. It seems, that the HID Devices are recognized, however not as Logitech devices.
Any way to get a workaround here, so the logitech drivers are loaded correctly ? HID 05ac:820b/HID 05ac:820a ?

Smurphy (smurphy-linux) wrote :

Another addition. Using xev to try to localize all the supplementary buttons won't work. xev won't show anything if pushing any of the other buttons on the mouse.

C'mon folks - I can't be the only one having this issue ....

Ther Mac Mini is the perfect computer, and has bluetooth integrated. Why can't I use that keyboard normally with it ?

Smurphy (smurphy-linux) wrote :

Last addition.
When adding the Bluetooth Dongle provided by Logitech, all keys and extra stuff of the leyboard works (except the LCD screen - but that's not a requirement).

So - any chance in getting the Kernel to recognize the MX5500 MX Revolution with Mouse MX Revolution, without the logitech Bluetooth Dongle ? It should IMHO not make a difference, which device we use.
At least, is there somewhere the possibility to override the keyboard/mouse type during bluetooth initialization ?

Smurphy (smurphy-linux) wrote :

Forgot to add the lsbusb output - it shows the difference between using the Logitech Bluetooth dongle:
smurphy@pandora:~$ lsusb
Bus 004 Device 006: ID 05ac:8218 Apple, Inc.
Bus 004 Device 005: ID 05ac:820b Apple, Inc.
Bus 004 Device 004: ID 05ac:820a Apple, Inc.
Bus 004 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 004 Device 002: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 013: ID 046d:c71c Logitech, Inc.
Bus 003 Device 012: ID 046d:c71b Logitech, Inc.
Bus 003 Device 011: ID 046d:0b06 Logitech, Inc.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

while not using it returns:
smurphy@pandora:~$ sudo lsusb
Bus 004 Device 006: ID 05ac:8218 Apple, Inc.
Bus 004 Device 005: ID 05ac:820b Apple, Inc.
Bus 004 Device 004: ID 05ac:820a Apple, Inc.
Bus 004 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 004 Device 002: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any hints ?

Smurphy (smurphy-linux) wrote :

For those having this issue, replacing the btusb module fixed it for me.
Check out this link: https://help.ubuntu.com/community/MacBookPro6-2/Maverick#Bluetooth

awi (a-w-kinnunen) wrote :

I'm using DiNovo Edge, and after every ubuntu version update, I'm still changing "hiddev" to "hidraw" in udev rules. File changed to 62-bluez-hid2hci.rules for Oneric. Is the problem in logitechs dongle working wrong or why this is still broken?

I'll have to look at the Smurphy's solution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers