Failed to execute child process "ubuntuone-control-panel-qt"

Bug #939797 reported by Joshua Hoover on 2012-02-23
78
This bug affects 20 people
Affects Status Importance Assigned to Milestone
ubuntuone-installer
Status tracked in Trunk
Stable-3-0
High
Rodney Dawes
Trunk
High
Rodney Dawes
ubuntuone-installer (Ubuntu)
High
Rodney Dawes
Precise
High
Rodney Dawes

Bug Description

Latest updates on Precise as of 2012-02-23

1. Click Ubuntu One icon
2. Installer starts, prompts for keyring password
3. Installer hangs and outputs the following error to the console:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ubuntuone-installer/ubuntuone/installer/gui.py", line 361, in finished
    GLib.spawn_command_line_async(CONTROL_PANEL_COMMAND)
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Failed to execute child process "ubuntuone-control-panel-qt" (No such file or directory)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntuone-installer 2.99.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
Date: Thu Feb 23 14:39:04 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120223.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~dobey/ubuntuone-installer/fix-939797
Roberto Alsina (community): Approve on 2012-02-24
Joshua Hoover (joshuahoover) wrote :
summary: - Installer doesn't complete install
+ Failed to execute child process "ubuntuone-control-panel-qt"
Changed in ubuntuone-installer:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-installer (Ubuntu):
status: New → Confirmed
Rodney Dawes (dobey) on 2012-02-24
Changed in ubuntuone-installer (Ubuntu Precise):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-installer - 2.99.5-0ubuntu3

---------------
ubuntuone-installer (2.99.5-0ubuntu3) precise; urgency=low

  * 01_bzr-fix-939797.patch:
    - Limit package install list to uninstalled packages. (LP: #939797)
 -- Rodney Dawes <email address hidden> Fri, 24 Feb 2012 14:41:24 -0500

Changed in ubuntuone-installer (Ubuntu Precise):
status: Confirmed → Fix Released
John McDonald (johnmcd) wrote :

I can confirm that this bug still exists. I am running 12.04 with ubuntuone-installer version 3.0.0ubuntu1.

Output to the terminal is as follows:
$ ubuntuone-installer
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ubuntuone-installer/ubuntuone/installer/gui.py", line 373, in finished
    GLib.spawn_command_line_async(CONTROL_PANEL_COMMAND)
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Failed to execute child process "ubuntuone-control-panel-qt" (No such file or directory)

John McDonald (johnmcd) wrote :

so doing:
sudo apt-get install ubuntuone-control-qt
fixed it.

Synaptic didn't pick up the dependency.

James Moon (mooniker) wrote :

~$ sudo apt-get install ubuntuone-control-panel-qt
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntuone-control-panel-qt : Depends: ubuntu-sso-client-qt (>= 2.99.92) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers