[FFe] [needspackaging] ubuntuone-installer needs packaged

Bug #817133 reported by dobey on 2011-07-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntuone-installer (Ubuntu)
High
dobey

Bug Description

As we change to our agile delivery of Ubuntu One, which this bug is tracked on, we will need to package ubuntuone-installer in Ubuntu. This package will also need an MIR and to be put on the CD, with the existing ubuntuone packages being pulled off the CD.

Changed in ubuntu:
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Kees Cook (kees) wrote :

This doesn't look like it's ready for the archive to me:

    def __get_series(self):
        """Get the series we're running on."""
        return 'natty'

That won't work for oneiric :)

GUI strings aren't localized from what I can tell, so it would be English-only.

Beyond that, it seems fine. It's very small and uses aptdaemon to install a repo and package (ubuntuone-control-panel-gtk).

dobey (dobey) wrote :

Yes. That code is planned to change, and the strings will get localized before UI freeze. There are some changes coming from design, and I didn't want to waste translators' time with having to translate strings that I know are going to change anyway. The get_series method will do the right thing very soon, and I will have the PPAs set up as well, to avoid the 404 errors. For now it will just add that PPA and the packages will actually come from the Ubuntu archive anyway.

dobey (dobey) on 2011-08-15
tags: added: ffe needs-packaging
summary: - [needspackaging] ubuntuone-installer needs packaged
+ [FFe] [needspackaging] ubuntuone-installer needs packaged
Scott Kitterman (kitterman) wrote :

Based on what I see in https://wiki.ubuntu.com/StableReleaseUpdates?action=show&redirect=SRU#Special_Cases and https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions this either still needs tech board approval or their approval needs to be added to the documentation.

Changed in ubuntu:
status: In Progress → Incomplete
Kees Cook (kees) wrote :

@scottk hm? this is for oneiric, not an SRU, afaiu.

Changed in ubuntu:
status: Incomplete → New

kees: That's correct, but the purpose of the package, AIUI, is to enable easy
post-release updates. Approving the package to do this before the policy
exception is granted seems to be getting the cart before the horse.

Martin Pitt (pitti) wrote :

Rodney, how will this look like? Back then in the discussion we said that it would be better to properly SRU these packages (if needed, with bundled libraries) instead of completely foregoing the usual SRU review, QA and regression testing by installing a PPA.

Now, I understood that you actually wanted to do both and offer a PPA for beta testers as well, but that wasn't supposed to be in the UI. Did that change then?

Is there a wiki page or similar which describes the current process?

dobey (dobey) wrote :

The current code adds our stable release PPA, and then proceeds to install Ubuntu One. The code is simple enough to change it to not add the PPA though. I think it's a 1 line change to not do that, and only do the installation instead. My understanding was that we would add our stable PPA always, and do our own heavy QA on it, and if people want to add the beta/nightlies PPAs, they can do it the same way they do now.

I suppose I misunderstood though. If I fix the code to not add the PPA by default, I suppose there is no tech board issue then, right?

Martin Pitt (pitti) wrote :

I'm still not clear what the purpose of this package is, and more generally, what the intended rollout plan is for this. Surely we want to have the ubuntuone packages in Ubuntu as well, not only in a PPA? If not, why did that get changed? Merely adding this package is certainly not everything you want to do here, so what is the complete plan here?

Thanks!

Martin

Changed in ubuntu:
status: New → Incomplete

Historically we haven't allowed packages in the archive to add PPAs (See envy for an example)

dobey (dobey) wrote :

The plan is that in Oneiric we will not have Ubuntu One installed by default, but only ubuntu-sso-client (as it is used by other apps as well) and this ubuntuone-installer, which will install the ubuntu one client bits if not already installed. The ubuntuone packages will remain in Ubuntu, as well, yes.

But we need to add this package and get it through MIR and on the CD, first, I think, before unseeding the other packages from the CD.

John Lenton (chipaca) wrote :

The adding of the stable ppa is an error, tracked by lp:827519.

John Lenton (chipaca) wrote :

The long-term purpose of this package is to unify our (Ubuntu One's) installation procedures along all supported platforms. It has the additional benefit in the short term that it makes a bit more space in the CD while still enabling us to describe the service to new users, and will at some point make it easier for people to test our beta releases.

dobey (dobey) on 2011-08-16
Changed in ubuntu:
status: Incomplete → New
Scott Kitterman (kitterman) wrote :

This is pretty clearly inconsistent with standard policy for the Ubuntu archive. I think it would be inappropriate for the release team to review this without tech board approval.

Changed in ubuntu:
status: New → Incomplete
Martin Pitt (pitti) wrote :

Bug 827519 says that the PPA actually won't be added by default after all. So this is merely a shim to install more ubuntuone-* packages from the Ubuntu archive depending on which services you want to enable?

I guess it also offers a less obvious way to enable a beta channel for people who you ask to test stuff in bug reports, etc? As long as this isn't offered in the GUI like "Try this cool new stuff which might potentially break your system", this is probably alright. But as I said, I'd like to know how the stable/beta PPAs will be offered through this. Thanks!

dobey (dobey) wrote :

There will be no GUI in Oneiric to enable PPAs. We /may/ have a command line option to add the beta PPA. And yes, this is just a shim to install the ubuntuone-* pacakges from the archive, though not dependent on which services are wanted. It will install one or a few top-level packages for Ubuntu One in Oneiric, that will also pull in any Depends/Recommends from those packages.

Right now in trunk, there is no way to enable the PPA addition, without patching the code to do that instead. I'll make ready a new release/upload from trunk, with this change.

dobey (dobey) wrote :
dobey (dobey) wrote :
dobey (dobey) wrote :
Martin Pitt (pitti) wrote :

Just discussed with Scott and Rodney in #u-devel. A mere package installer is fine and approved at this point.

For the record, this is not an approval of a future change to enable PPAs or otherwise circumvent the SRU process, which needs to be accepted by the TB (i. e. it is not just a feature freeze matter).

Thanks!

Changed in ubuntu:
status: Incomplete → Confirmed
Martin Pitt (pitti) wrote :

Uploaded, will go to source NEW now.

Changed in ubuntu:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Actually, this has been in for some days now, closing.

Changed in ubuntu:
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
affects: ubuntu → ubuntuone-installer (Ubuntu)
Changed in ubuntuone-installer (Ubuntu):
milestone: ubuntu-11.10-beta-2 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers