Comment 9 for bug 829186

Martin Pitt (pitti) wrote :

software-center-gtk3 works fine with new pygobject, but the gtk2 variant crashes now:

$ software-center
Traceback (most recent call last):
  File "/usr/bin/software-center", line 136, in <module>
    from softwarecenter.ui.gtk.app import SoftwareCenterApp
  File "/usr/share/software-center/softwarecenter/ui/gtk/app.py", line 73, in <module>
    from installedpane import InstalledPane
  File "/usr/share/software-center/softwarecenter/ui/gtk/installedpane.py", line 34, in <module>
    from softwarepane import SoftwarePane
  File "/usr/share/software-center/softwarecenter/ui/gtk/softwarepane.py", line 58, in <module>
    from appdetailsview_gtk import AppDetailsViewGtk as AppDetailsView
  File "/usr/share/software-center/softwarecenter/ui/gtk/appdetailsview_gtk.py", line 45, in <module>
    from softwarecenter.backend.weblive import get_weblive_backend
  File "/usr/share/software-center/softwarecenter/backend/weblive.py", line 25, in <module>
    from gi.repository import GObject
  File "/usr/lib/python2.7/dist-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))