Singular form is incorrect in notification

Bug #723327 reported by Ted Gould on 2011-02-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
Eric Casteleijn
ubuntuone-client (Ubuntu)
Medium
Alejandro J. Cura

Bug Description

Binary package hint: ubuntuone-client

A got a notification:

"1 files are uploading to your cloud."

Where it should be:

"1 file is being uploaded to your cloud."

Related branches

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
assignee: nobody → Eric Casteleijn (thisfred)
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu):
assignee: Eric Casteleijn (thisfred) → Alejandro J. Cura (alecu)
Changed in ubuntuone-client:
assignee: nobody → Alejandro J. Cura (alecu)
Changed in ubuntuone-client:
importance: Undecided → Medium
status: New → Fix Committed
Alejandro J. Cura (alecu) wrote :

This is fixed on ubuntuone-client trunk, and should be packaged today.
Thanks for reporting it!

Changed in ubuntuone-client:
status: Fix Committed → In Progress
assignee: Alejandro J. Cura (alecu) → Eric Casteleijn (thisfred)
Eric Casteleijn (thisfred) wrote :

Oops, alecu, please ping me next time you take a bug from me (which you're more than welcome to do at any time! ;)

I finished this another version of this on my own branch. And yes I know I reviewed this branch, but I did not pay overly much attention to the i18n changes apparently.

Single/plural is a very complicated i18n issue which is why gettext provides ngettext and dngettext, the latter of which we should use here, IMO, as my new branch does.

Alejandro J. Cura (alecu) wrote :

Hi eric, thanks for your branch to fix this!
btw: Just after nessita told you about this bug on irc I mentioned that it was already fixed in trunk, so she told me to link this branch and mark the bug as fixed. My solution was ugly though, since it just changed the "1 files" into "1 file(s)", so I must agree that your fix using proper gettext looks a lot nicer and it will surely work for languages with more than one plural form.

Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2011-03-10
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.5.6-0ubuntu1

---------------
ubuntuone-client (1.5.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Remove already upstreamed patch
    - Release pathlock when command cancelled (LP: #729158)
    - syncdaemon continuously hashing (LP: #580855)
    - Self conflict when saving the same file a lot (LP: #718924)
    - SYS_QUOTA_EXCEEDED not being sent (LP: #720797)
    - The check_condition call may be too heavy (LP: #720844)
    - AQ_DOWNLOAD_CANCELLED is no more (LP: #721479)
    - SD should update a single notification (LP: #723227)
    - Two entries in Messaging menu (LP: #721525)
    - Singular form incorrect for notification (LP: #723327)
    - File names should be shown on notifications (LP: #729055)
  * Moved icon files to ubuntuone-client package (LP: #727195)
 -- Rodney Dawes <email address hidden> Wed, 09 Mar 2011 21:11:44 -0500

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers