[10.04] Ubuntu One still does not sync purchased music (with all updates)

Bug #648396 reported by jhfhlkjlj on 2010-09-26
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntuone-client (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntuone-client

In accordance to bug 571548. The bug was marked as fixed but others are still experiencing problems in 10.04. The workaround described in the bug:

touch ~/.ubuntuone/Purchased\ from\ Ubuntu\ One/placeholder; u1sdtool -q; u1sdtool -c

still fixes the problem.

We were told to file a new report; as such, please do not mark as a dupe.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubuntuone-client 1.2.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Sep 26 17:19:26 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
UbuntuOneSyncdaemonExceptionsLog:

UbuntuOneUserSyncdaemonConfig:
 [bandwidth_throttling]
 read_limit = 2097152
 write_limit = 2097152
 on = False

E King (eakst7) wrote :

I am on 10.4 (Lucid) with all current updates.

I purchased my first album from the Ubuntu One Music Store, which included creating my Ubuntu One account. The audio files made in to the server (ie., I could see and download them via the web), but did not sync to my "~/.ubuntuone/Purchased from Ubuntu One" directory until I used the workaround described in 571548.

I also opened bug 646348; you can close that as a dup of this one.

-Ed

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
E King (eakst7) wrote :

Attaching syncdaemon logs.

Just bought a second album tonight. I had to use the command again a few times.

I definitely recommend getting an SRU for this once a fix is found. :).

pjarvi (patrickjarvi) wrote :

Just bought "Love Janis" Janis Joplin album and the entire album sat at queuing. I used PayPal for the purchase which processed payment with out issue, mentioning that in case paying with PayPal is related to whatever is causing this problem. Using the workaround listed in the description for this bug worked and all the songs are now downloading.

I've been buying 1 album a month. This is the 3rd album i've purchased but the 1st one I ran into this problem with. The albums I purchased in August and September downloaded without issue for me.

Matt Griffin (mattgriffin) wrote :

pjarvi - Just checked your account and our tracking shows that the album "Love Janis" has downloaded to your personal cloud. If the songs haven't downloaded to your desktop yet, perhaps confirm that you are connected for file sync.

In a terminal, you can type 'u1sdtool -s' to check the status of file sync for your computer. If 'is_connected' = False and 'is_online' = False, then you know you're not connected. You can type 'u1sdtool -c' to connect. Once it connects, files in your personal cloud (the music) will synchronize down to your machine. Thanks!

TenLeftFingers (tenleftfingers) wrote :

jarlath@jarlath-desktop:~$ u1sdtool -s
State: QUEUE_MANAGER
    connection: With User With Network
    description: processing queues
    is_connected: True
    is_error: False
    is_online: True
    queues: WORKING_ON_BOTH

jarlath@jarlath-desktop:~$ u1sdtool --current-transfers
Current uploads: 0
Current downloads: 0

if there is anything else I should attach, please tell me what apport command to issue.

Artūras Norkus (xeranas) wrote :

Yesterday this issue touched me too. Songs download was stuck till i restart Rhythmbox and device from Ubuntu One preferences.

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
NonfreeKernelModules: fglrx
Package: ubuntuone-client 1.2.2-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic-pae 2.6.32.15+drm33.5
Tags: lucid
UbuntuOnePreferencesLog:
 2010-09-23 11:41:05,632 - ubuntuone-preferences - DEBUG - starting
 2010-09-23 11:41:05,665 - ubuntuone-preferences - DEBUG - got limits: dbus.Dictionary({dbus.String(u'download'): dbus.Int32(2097152), dbus.String(u'upload'): dbus.Int32(2097152)}, signature=dbus.Signature('si'))
 2010-10-05 11:19:31,864 - ubuntuone-preferences - DEBUG - starting
 2010-10-05 11:19:31,993 - ubuntuone-preferences - DEBUG - got limits: dbus.Dictionary({dbus.String(u'download'): dbus.Int32(2097152), dbus.String(u'upload'): dbus.Int32(2097152)}, signature=dbus.Signature('si'))
UbuntuOneSyncdaemonExceptionsLog:

UbuntuOneUserSyncdaemonConfig:
 [bandwidth_throttling]
 read_limit = 2097152
 write_limit = 2097152
 on = False
Uname: Linux 2.6.32-24-generic-pae i686
UserGroups: adm admin cdrom dialout kvm libvirtd lpadmin plugdev sambashare

tags: added: apport-collected

apport information

apport information

apport information

E King (eakst7) wrote :

Ran into the same problem again today after purchasing three new albums. Music was available via the Ubuntu One website, but did not sync locally. "Your Downloads" in the Ubuntu One section of Rythmbox showed everything as "Queued..." but not downloading. I ran apport-collect while in this state.

I then performed the workaround and syncing began immediately.

I'm attaching syncdaemon.log from today. Note that this log shows the creation of "placeholder" (around 10:57:55 am) followed by the download of the albums I purchased.

Bing@Chi (bwang) wrote :

Same problem and workaround works. 10.04 with updates applied.

This is too old and has probably been fixed. If anyone is still having issues, please report a new bug.

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Invalid
dobey (dobey) on 2012-03-12
Changed in ubuntuone-client (Ubuntu):
status: Invalid → Confirmed

As I am the OP, and I do not have this bug any more, I am closing this. Please open a new bug if you are having issues.

dobey (dobey) wrote :

Please do not set this to Invalid. While it is good that you aren't seeing this any more, because you've upgraded to a newer version of Ubuntu, or for some other unexplained reason, it does not mean that the bug is either invalid, nor fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers