Feature freeze exception: ubuntuone-client devices and services tabs

Bug #525803 reported by Joshua Hoover on 2010-02-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
dobey
ubuntuone-client (Ubuntu)
Medium
dobey

Bug Description

Binary package hint: ubuntuone-client

The 'devices' tab of the Ubuntu One control panel needs to provide a way to connect/disconnect/restart the syncdaemon and a way of removing devices from your account (if, say, a device is stolen). The 'services' tab needs to make the already existing UI work (both in the "it reacts to user input" and in the "it calls out to the back end and actually does stuff" senses), and adding a checkbox for turning off synchronizing of Gwibber (because it's a bit of a bandwidth hog and doesn't really add much value to most users).

Related branches

Steve Langasek (vorlon) wrote :

Can you tell us more about the implementation of this feature? Does the new API pull in any new dependencies on other packages not currently in main / not currently on the CD?

Changed in ubuntuone-client (Ubuntu):
status: New → Incomplete
Elliot Murphy (statik) wrote :

After discussion with the team yesterday, I am postponing this feature to Lucid+1, as it's not ready yet, and enough work is left that I don't want to put the Lucid release at risk.

Steve Langasek (vorlon) wrote :

ok, closing the FFe request, thanks.

Changed in ubuntuone-client (Ubuntu):
status: Incomplete → Invalid
John Lenton (chipaca) wrote :

Reopening because we'd agreed with Rick Spencer that we'd piggyback the other remaining controlpanel work on this. So SSO won't be making it in, but the devices tab and the services tab of the control panel definitely are going in.

Changed in ubuntuone-client (Ubuntu):
status: Invalid → New
Steve Langasek (vorlon) on 2010-03-10
summary: - Feature freeze exception: ubuntuone-client SSO integration
+ Feature freeze exception: ubuntuone-client devices and services tabs
John Lenton (chipaca) wrote :

The 'devices tab' work is what is in lp:~chipaca/ubuntuone-client/devices-tab; it's been in the beta ppa for a few days. The 'services tab', lp:~dobey/ubuntuone-client/services-enablement is currently WIP, but is rather simple: it's tying what's already available via dbus up with the already written ui. So it's basically just the glue (plus some minor changes to the ui, but essentially that).

John Lenton (chipaca) wrote :

Following up after talking on IRC: The 'devices' tab needs to get in because without it there is no graphical way to connect/disconnect/restart the syncdaemon, and no way of removing devices from your account (if, say, a device is stolen).
The 'services' tab work consists of making the already existing UI work (both in the "it reacts to user input" and in the "it calls out to the backend and actually does stuff" senses), and adding a checkbox for turning off synchronizing of gwibber (because it's a bit of a bandwidth hog and doesn't really add much value to most users).

Steve Langasek (vorlon) wrote :

FFe approved for services, devices tabs.

When will this be expected to land in lucid?

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
John Lenton (chipaca) wrote :

Hopefully today. At least the devices tab work today; the services tab is still in the race.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.1.4-0ubuntu1

---------------
ubuntuone-client (1.1.4-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - Bring in UI for public files handling in Nautilus. (LP: #525803)
    - Bring in UI for managing devices. (LP: #525803)
  * Add dependency on python-httplib2 to packaging. (LP: #535207)
 -- Rodney Dawes <email address hidden> Wed, 10 Mar 2010 18:36:57 -0500

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
dobey (dobey) wrote :

This is only partially done, so changing back to In Progress.

Changed in ubuntuone-client (Ubuntu):
status: Fix Released → In Progress
John Lenton (chipaca) on 2010-03-15
tags: added: desktop+ freeze-exception u1-lucid
description: updated
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
Changed in ubuntuone-client:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
tags: added: package
Changed in ubuntuone-client:
milestone: none → lucid-beta-2
dobey (dobey) on 2010-03-24
Changed in ubuntuone-client:
status: In Progress → Fix Committed
John Lenton (chipaca) on 2010-03-25
Changed in ubuntuone-client:
status: Fix Committed → In Progress
dobey (dobey) on 2010-03-31
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.1.90-0ubuntu1

---------------
ubuntuone-client (1.1.90-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - Notify user when approaching and exceeding quota (LP: #540360)
    - Add instructional text to ubuntuone-preferences (LP: #539676)
    - UbuntuOne needs to autostart and connect by defualt (LP: #534707)
    - Impossible to infer status of file synchronization (LP: #526084)
    - Devices and Services tabs functionality and development (LP: #525803)
  * Add debian/source/format.
  * Remove python-httplib2 from the dependencies (LP: #535207)
 -- Rodney Dawes <email address hidden> Wed, 31 Mar 2010 19:47:01 -0400

Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
John Lenton (chipaca) on 2010-04-05
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers