Ubuntu

FFe: Upload Oneiric Ubuntu 11.10 wallpapers

Reported by Paul Sladen on 2011-08-19
64
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubuntu-wallpapers (Ubuntu)
Undecided
Paul Sladen

Bug Description

Following on from bug #740588, the wallpapers in Ubuntu come from the Ubuntu Wallpaper contest:

  http://design.canonical.com/2011/08/quick-wallpaper-update/
  http://www.flickr.com/groups/1777695@N22/pool/

There are ~30 shortlisted entries and a selection of those have been chosen. There are two types of image, most are photographic (JPGs) with a small number of non photographic images (PNGs).

  1. Publish the list of winning entries on design.canonical.com
  2. All images are CC-BY-SA which is a criteria for inclusion and this was a stated requirement of submission. Contributors have been asked to update the relevant metadata on Flickr
  3. Scale all the images to the same 2000px width and corresponding height to maintain aspect ratio. If in doubt this should be done from the centre.
  4. I understand that compression is managed when it's packaged so if it's oversize we can recompress/ reduce the number of images. For reference our current wallpapers are around 4MB and we anticipate this will be about the same size.
  5. Upload to main

Note that it is not possible to directly download the images from the shortlist group because not all members have Flickr Pro accounts. Iain will source all the images we need direction from the artists and will attach them here. Sladen will spend an evening tweaking compression settings so that all the images still look good.

The format of the filenames references the artist and I have named the file using the existing convention of Image_name_by_Artist_Name.jpg/.png

Changed in ubuntu-wallpapers (Ubuntu):
status: New → Confirmed
Iain Farrell (iain-farrell) wrote :
Iain Farrell (iain-farrell) wrote :

One of the people selected was away on holiday when we set the deadline but has very kindly supplied images. I add an updated zip files in the hopes that we may yet still squeeze it in :)

Paul Sladen (sladen) wrote :

Iain: ah, thanks for getting these on the bug report, even if I'd missed them. Have you got the originals (instead of the 60% versions and I'll see how we can squeeze each one until they make the 3.4MB limit.

summary: - FFe: Upload Oneiric Ubuntu 11.10 wallpapers
+ FFe+UIFe: Upload Oneiric Ubuntu 11.10 wallpapers

When selecting (and compressing) images please be very mindful of jpeg artifacts. The Natty photos where almost all highly infected with noise. This especially unbearable on high end screens.

Paul Sladen (sladen) wrote :

mikkel: yeah, from memory there was a high-frequency cornfield photo in the last release that just wouldn't accept its destiny. This is part of the reason for wanting the close-to-originals first.

What it really needs is a manual JPEG coder where one can select and highlight areas that need more entropy and areas that need less allocating. Do you know of any Libre tools that can do this?

Paul Sladen (sladen) wrote :

mikkel: I spent several hours looking into selective optimisation and the internals of libjpeg last night. (There doesn't appear to be any code available)

It'll need some code writing; either based on:

  http://en.wikipedia.org/wiki/Structural_similarity (SSIM metrics)

or specific regions (8x8 pixel granularity) so that the compression/quantisation level is varied per region. This is going to be much longer than I can do in an evening before uploading but is likely to be useful in the long run for allowing greater compression for the CD images (not just wallpapers) without sacrificing perceived quality.

I think for the moment, I'll wait for the 40MB originals from Iain and see what I can do. Of course, with the originals published on this page anyone else is welcome to help with try and help meet the package size target with a better SSIM score.

Paul Sladen (sladen) wrote :

Reference using Matlab (not usable, since it is -NC):

  https://ece.uwaterloo.ca/~z70wang/research/ssim/

Paul Sladen (sladen) wrote :

Ubuntu 11.10 Wallpaper shortlist selection full-set (precompression masters).
Hopefully we can do an 'ubuntu-wallpapers-high-quality' package too.

Distributed under the Terms of the CC-BY-SA licence:

  http://creativecommons.org/licenses/by-sa/3.0/

The wonderful artists and their works:

Bridge in Scanolera by Robert Anderson
Siberian Tiger by Jan Hoover
Minas by CarmenGloria Gonzalez
Buck off by SirPecanGum
Berge II by Simon Schlegl
Small flowers by Dariusz Duma
Forest by Dariusz Duma
Mulgustus by Tauno Erik
WildWheat by Brian Burt
Tower by Simon Schlegl
The White Way by Simon Schlegl
JardinPolar by CarmenGloria Gonzalez
Soil by Erwin Udomlya
La solucion-mañana by Pilar Flores
El cielo sobre Berlin by Pilar Flores
Purple Dancers by Emilio Merlino
Not Alone by Deacon MacMillan
Darkening Clockwork by Matt Katzenberger
Renault Alpine Sideview by David Kirba
Sepia Leaf by Erin Estes
Langelinie Allé by SirPecanGum
Woodland by Dariusz Duma
Los colores del verde by Pilar Flores
Rose by Simon Schlegl
Dybbølsbro Station by SirPecanGum
Dewy Clover by Noah Bertilson
Autocoleopteros by CarmenGloria Gonzalez
Deboth by Fernando Garca
Segovia by Fernando Garca
Penguin beach by edb
Power of Words by Antonio Litterio
Momiji Dream by Deacon MacMillan
The Grass Aint Greener by fix pena
Sand Maze by Jose Bolorino
Touchdown by Mohamed Malik
Mount Snowdon Wales by Adam Vellender
Take2 by Francisco Villalobos
Altitude by Erin Estes
Variations on Oneiric Ocelot by madeinkobaia
Stalking Ocelot by Sayantan Chaudhuri
Reclining Ocelot by Sayantan Chaudhuri
Oxygen by Hugo Cliff
Red Poppies by Ádám Fejes
Unnamed by Federica Miglio

Paul Sladen (sladen) on 2011-09-27
summary: - FFe+UIFe: Upload Oneiric Ubuntu 11.10 wallpapers
+ FFe: Upload Oneiric Ubuntu 11.10 wallpapers
Iain Farrell (iain-farrell) wrote :
Paul Sladen (sladen) on 2011-09-29
Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → In Progress
milestone: none → ubuntu-11.10
assignee: nobody → Paul Sladen (sladen)
Paul Sladen (sladen) on 2011-09-29
Changed in ubuntu-wallpapers (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-wallpapers - 0.32.1

---------------
ubuntu-wallpapers (0.32.1) oneiric; urgency=low

  [Iain Farrell/Otto Greenslade]
  * Wallpapers from the Ubuntu 11.10 community contest (LP: #829213)
    http://design.canonical.com/2011/08/quick-wallpaper-update/
 -- Paul Sladen <email address hidden> Thu, 29 Sep 2011 20:59:59 +0000

Changed in ubuntu-wallpapers (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers