Ubuntu wallpaper called warty-final-ubuntu.png is made with Adobe Photoshop CS3 Macintosh

Bug #357218 reported by Claudio Pacchierotti on 2009-04-07
82
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ubuntu-wallpapers (Ubuntu)
Low
Unassigned
Declined for Jaunty by C de-Avillez

Bug Description

Binary package hint: ubuntu-wallpapers

The wallpaper seems to be a Photoshop artwork (on a Mac!)...

Right Click>Properties>Image Tab>Software

See the attachment.

kimj (emailadoc) on 2009-04-07
Changed in ubuntu-wallpapers (Ubuntu):
status: New → Confirmed

I confirm the bug too.

Wallpaper is nice, but it would be better to develop Ubuntu on Ubuntu itself.

Brian Murray (brian-murray) wrote :

This isn't the case with any of the recent Ubuntu wallpapers so I'm setting it to low.

Changed in ubuntu-wallpapers (Ubuntu):
importance: Undecided → Low

@Brian: well, it is true but warty-final-ubuntu is the *default* wallpaper, so I think importance is much than "low".

Darko82 (dariazzo1) wrote :

@Brian: It isn't something of vital importance, but it is really embarassing.

Furthermore, the image is a jpeg with the extension changed to png...you can't open it if you don't change the extension :|

The png/jpeg problem was already reported here:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-wallpapers/+bug/296538

Here we talk about making an Ubuntu Wallpaper using Photoshop on a Mac.

Alessandro Scarozza (xan.scale) wrote :

@Brian: this is the default wallpaper of jaunty!!!!!

Martin Pitt (pitti) on 2009-04-17
Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-wallpapers - 0.28.4

---------------
ubuntu-wallpapers (0.28.4) jaunty; urgency=low

  * Changing simple-ubuntu to reduce size; fixes LP: #345523
  * Removing headers to fix LP: #357218

ubuntu-wallpapers (0.28.3) jaunty; urgency=low

  * updating simple-ubuntu.png to fix LP: #345523

 -- Kenneth Wimer <email address hidden> Fri, 17 Apr 2009 13:25:20 +0200

Changed in ubuntu-wallpapers (Ubuntu):
status: Fix Committed → Fix Released

I really don't think this bug should considered closed!
You just removed references to Photoshop!
No, I think the background should be changed with a gimp-made one!
Someone good at using gimp may do this in moments!

And however, the file is still a renamed jpg!
I know this isn't the place to talk about, but if you change the package you can also convert it.

To remove header is not a fix.
The bug is: Ubuntu default wallpaper (called warty-final-ubuntu.png) is made with Adobe Photoshop CS3 Macintosh.

So it is necessary to remove wallpaper and to make another one with Gimp or Krita to fix it.

Changed in ubuntu-wallpapers (Ubuntu):
status: Fix Released → Confirmed
olive (olivier.fraysse) wrote :

This is not only the default wallpaper, this is also used for the CD cover and label of Jaunty CD.

@olive: oh... bad.
I see...

Changed in ubuntu-wallpapers (Ubuntu):
assignee: nobody → marouan mohammed (marouan--mohammed)
CK (copkiller-cop) wrote :

as i see it there is no image editor on ubuntu anymore that could do such a job

"as i see it there is no image editor on ubuntu anymore that could do such a job"

Please....
If you talk about the removal of gimp from the CD, then be a bit more serious. Gimp is not removed from Ubuntu, just from the CD. Becouse it is confusing, and discouraging for the novice users. You can install it anytime with 5 clicks or so.

Shiki (shiki) wrote :

Everyone who would consider this as a bug. Try making a new wallpaper and next time send them (as a brainstorm idea or something). Still, GIMP is purely inferior to Photoshop so you should just give up. Use a solid color if you want to fight about such thing that much.

Why did the team confirm it as a bug? Sheesh. Close it, fixed. You should (reporter) spend your time on something more important (family, etc) or help the project with something what matters (report REAL bugs) and please don't waste the time of the developers.

@zsolt: "Still, GIMP is purely inferior to Photoshop"

Please, stop your trolling.
Gimp is largely sufficient to draw a wallpaper and Ubuntu wallpapers are very trivial to reproduce with Gimp (or Inkscape).

Shiki (shiki) wrote :

Then why don't you draw a new wallpaper and submit it as a fix of this bug? Afraid of contributing? :)

Nigel Babu (nigelbabu) wrote :

Please do not change the status of Fix Released bug reports unnecessarily.

Changed in ubuntu-wallpapers (Ubuntu):
assignee: marouan mohammed (marouan--mohammed) → nobody
status: Confirmed → Fix Released

@nigel:

bug report is about the fact that the wall paper is made with Photoshop.

To change a sting does *not* solve the bug.

Then it is unfixed.

To solve a bug reported in a log doesn't consist of removing a sting in the log.

Changed in ubuntu-wallpapers (Ubuntu):
status: Fix Released → Confirmed
C de-Avillez (hggdh2) wrote :

Back to Fix Released. Frankly, I do not see this as a bug at all. Are we now to restrict contributions to Linux, Ubuntu, etc to *only* free software? Then -- for example -- we must also prohibit most of the pictures that are taken, since most of the photographic equipment uses proprietary firmware to work. This simply does not make sense.

The way I see it, I am glad this was done and provided under a FLOSS-compatible licence. Certainly, I would be even more glad if it was done via GIMP, or whatever, but I am not going to refuse it on these grounds.

If you do not like the fact that someone did something to help using proprietary software, you are free to reverse-engineer it, and redo the work using whatever you think is appropriate.

Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Fix Released

@ C de-Avillez:

You miss the point.

Ubuntu today is a non consistent OS, because 'stupid' bugs like this.

Does Canonical supply Photoshop in Ubuntu repos? No, of course.

Canonical should build Ubuntu on Ubuntu itself.

This is a technical issue, not only a ethical issue.

Techical issues are called "bugs", then this is a bug. And Canonical should fix it.

Changed in ubuntu-wallpapers (Ubuntu):
status: Fix Released → Confirmed
Vish (vish) wrote :

Guiodic (Guido Iodice):
Kindly stop changing the status of this bug report. It will not solve the problem you hope to address. You are making this hard for bug triagers *only* .

Asking a designer who has worked for 10-20yrs with proprietary software to relearn their skills is not a reasonable task. And bordering on being unfair to the designer.

However the design team members are taking effort to switch to free software. [ eg: http://kwwii.blogspot.com/2010/05/ubuntu-maverick-uds-group-photo-made.html ] and others are trying to switch as well.

In the meantime .Ubuntu is a community project and patches / new wallpapers are welcome. If the quality is better than the design team's we will surely use them.

To repeat , Kindly do not change the task *unless* you can point to some Ubuntu guideline/rule/COC that mentions the artwork should be done only with free software. [dont not change task otherwise]

We all do hope that proprietary software is not used as well , hang in there. :-)

Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Fix Released

"Asking a designer who has worked for 10-20yrs with proprietary software to relearn their skills is not a reasonable task. And bordering on being unfair to the designer."

well, pay other designer who know GIMP, Inkscape, krita, etc.

I suggest the author of this tutorial: http://verysimpledesigns.com/vectors/inkscape-tutorial-abstract-wallpaper.html
He uses Inkscape on Windows, but you can ship him a Lucid live CD :)

"To repeat , Kindly do not change the task *unless* you can point to some Ubuntu guideline/rule/COC that mentions the artwork should be done only with free software"

This is no matter of guidelines. And this is not only matter of free software. This is matter of reliability of your OS.

Would you use an operating system that needs another OS to be developed?

I presume Apple does Mac OS X wallpapers and artworks on a Mac, not on a Windows PC.

Canonical wants to imitate and compete with Apple.
Well, it's time to begin. Use Ubuntu to build Ubuntu.

Last but not least: if there aren't guidelines about "making Ubuntu with Ubuntu" the status of this bug is "invalid", not "fixed".

olive (olivier.fraysse) on 2010-09-15
Changed in ubuntu-wallpapers (Ubuntu):
status: Fix Released → Invalid
MestreLion (mestrelion) wrote :

After reading all the (excelent) discussion here, my 2 cents are:

- I agree this is not actually a bug... but it is *extremely* embarassing for Ubuntu/Cannonical to have something as "iconical" as its default wallpaper done in 1 - Another OS, 2 - Using proprietary software, specially since Ubuntu has appropriate tools for that job.

- Its even more embarassing that the suggested "fix" was to actually remove the header from the image! This is literally swapping the dirt under the carpet. From all possible fixes imaginable, this "lets hide the evidence that we used PS on Mac" approach is truly shameful. If its OK to use other OSses and non-free sw to build Ubuntu, why hide this fact?

- If this is an invalid bug, *do not apply the patch*. Leave the header there, and maybe this will motivate the Desing Team @ Cannonical to re-create the wallpaper using GIMP in Ubuntu

Finally, a side-comment: not sure if this is related to the missing header or to the fact that this "png" image is actually a JPEG, but when i open it using F-Spot and try to see the metadata, i get this error:

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers