warty-final-ubuntu.png is actually a JPEG file

Bug #296538 reported by Andreas Olsson
244
This bug affects 42 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
ubuntu-wallpapers
Fix Released
Undecided
Unassigned
unity-2d
Undecided
Unassigned
ubuntu-wallpapers (Ubuntu)
Low
Unassigned
Declined for Hardy by Sebastien Bacher
Declined for Jaunty by Brian Murray
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: ubuntu-wallpapers

The default wallpaper was in Ubuntu 8.10 and still used in 12.10 is actually a JPEG file.

user@computer:~$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, EXIF standard

Related branches

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. I can confirm this on up-to-date Intrepid

chr1s@chris-desktop:~$ apt-cache policy ubuntu-wallpapers
ubuntu-wallpapers:
  Installed: 0.28.1
  Candidate: 0.28.1
  Version table:
 *** 0.28.1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
     0.28 0
        500 http://ppa.launchpad.net intrepid/main Packages

Changed in ubuntu-wallpapers:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
era (era) wrote :

This is not a problem for actually using it as a wallpaper (as remarked in the changelog for 0.28.1, Gnome will figure it out anyway) but you cannot open the image in eog (called "Image Viewer" in the UI). Perhaps this should be reported as a bug against eog but a symptom is that you cannot double-click on warty-final-ubuntu.png in /usr/share/backgrounds in Nautilus; the error message is "Could not load image 'warty-final-ubuntu.png'. Fatal error reading PNG image file: Not a PNG file".

Whatever the analysis, it seems misdirected to use an incorrect extension, and this should be easy enough to fix. (Also the base name "warty-final" is peculiar at best.)

Revision history for this message
David D Lowe (flimm) wrote :

I've uploaded a patch for this bug on my PPA:
https://launchpad.net/~flimm/+archive?field.name_filter=ubuntu-wallpapers&field.status_filter=any
(ubuntu-wallpapers_0.28.1-0ubuntu1)

Revision history for this message
era (era) wrote :

Perhaps it could be changed to intrepid-final.jpg while you're at it, or something which does not mention a particular release.

Revision history for this message
David D Lowe (flimm) wrote :

Done, renamed to intrepid-final-ubuntu.jpg
(ubuntu-wallpapers_0.28.1-0ubuntu2)

Revision history for this message
David D Lowe (flimm) wrote :

I'm attaching the patch so that it will show up to those searching for user submitted patches. It's still available in my PPA.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Hi,

Thanks for submitting a patch! You should check out https://wiki.ubuntu.com/SponsorshipProcess to see the process for having your patch uploaded.

Also, a note on your patch. I'm not positive, but I believe that the wallpaper is still referred to a warty-final on purpose in order to automatically upgrade the default wallpaper when the user does a dist-upgrade. Someone from the artwork team should comment...

Revision history for this message
Kenneth Wimer (kwwii) wrote :

the reason for this file being named thusly is historical and due to the update process. It was intentionally done this way because the update process currently cannot handle different file types for the wallpaper. This is something that should be fixed in Jaunty.

Revision history for this message
David D Lowe (flimm) wrote :

Which project/package would be responsible for the update process, Kenneth? Is it update-manager? Do you know if a bug has been filed there concerning this issue?

Revision history for this message
Սահակ (petrosyan) wrote :

this bug is still present in Ubuntu 9.04

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, JFIF standard 1.02

Revision history for this message
Tiwanaku (foobar1000) wrote :

This bug is still present in Ubuntu 9.10 as of August 30, 2009.

Revision history for this message
yurikoles (yurikoles) wrote :

>Ubuntu 9.10 as of August 30, 2009.
Epic

Revision history for this message
Tiago Silva (tiagosilva) wrote :

This bug is still present in Ubuntu 10.04a3

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Confirming in latest release:

$ apt-cache policy ubuntu-artwork
ubuntu-artwork:
  Installed: 52
  Candidate: 52
  Version table:
 *** 52 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, JFIF standard 1.02

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Oops, that was meant to say:

$ apt-cache policy ubuntu-wallpapers
ubuntu-wallpapers:
  Installed: 0.31
  Candidate: 0.31
  Version table:
 *** 0.31 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Revision history for this message
Michael Wood (mwood) wrote :

Still present in Lucid Beta 1 (the package version is still 0.31.1)

Revision history for this message
JP Vossen (jp-jpsdomain) wrote :

Still present in Lucid Beta 2 (the package version is still 0.31.1)

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu lucid (development branch)
Release: 10.04
Codename: lucid

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, JFIF standard 1.02

$ apt-cache policy ubuntu-wallpapers
ubuntu-wallpapers:
  Installed: 0.31.1
  Candidate: 0.31.1
  Version table:
 *** 0.31.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

And ++ for comment 4, but see comments 8,9. If you need a file to update, change the name once and make that stick. Using an obsolete name is confusing and annoying. See also LP bug 362526.

Revision history for this message
xiaomao101 (xiaomao101) wrote :

Still present in Ubuntu 10.04 LTS (Lucid)

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, JFIF standard 1.02

$ apt-cache policy ubuntu-wallpapers
ubuntu-wallpapers:
  Installed: 0.31.3
  Candidate: 0.31.3
  Version table:
 *** 0.31.3 0
        500 http://mirrors.163.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Revision history for this message
actionparsnip (andrew-woodhead666) wrote :

Just use imagemagick to convert the file..

Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue is that the name is used in users configurations so renaming would break upgrades

Revision history for this message
Mohamed Amine Ilidrissi (ilidrissi.amine) wrote :

@Sebastien: Can't we rename it and make "warty-final-ubuntu.png" a symlink?

Revision history for this message
Christian González (droetker) wrote :

Therefore Mohamed said "Symlink".
a simple

mv warty-final-ubuntu.png ubuntu-default-wallpaper.jpg
ln -s ubuntu-default-wallpaper.jpg warty-final-ubuntu.png

and include the "warty-final-ubuntu.png" symlink in a separate upgrade transition .deb

Hey, you're doing a whole (great!) OS, fixing this bug can't be a real problem, can it?

Revision history for this message
Tobias Wolf (towolf) wrote :

A better solution would be to make it an actual PNG. On my color calibrated monitor I can see blocky JPEG actifacts.

Is the uncompressed version available anywhere?

Revision history for this message
Paul Sladen (sladen) wrote :

Tobias: yes, Otto Greenslade has the originals. The choice of PNG/JPEG and compression size depends on what amount of space is available on the CD and the style of the image. For instance, if the next version of the default wallpaper was a piece of line-art, then it be more efficient to store it as a PNG.

Revision history for this message
Tobias Wolf (towolf) wrote :

So, it’s on his hard drive and not anywhere on launchpad?

Designers always seem to get special treatment.

Revision history for this message
Christian González (droetker) wrote :

Hm. Again - this bug is present since 2 1/2 years, and not substantly fixed despite beeing a beginner's job, isn't it?
Maybe Ubuntu will have a default wallpaper in a format we don't know yet in future or a video.
What makes it so difficult writing it in a config file with the full file name, no matter what format it has?

<pseudo config code>

[Default Ubuntu Background]
wallpaper=/usr/share/backgrounds/blah.jpg

</pseudo config code>

So where is the problem? Using 2 years of bugtracking does not equate the effort to fix this bug, does it?
So what can I do to help you fix this once and for all time for 11.04, or at least 11.10?

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

I could understand if too much stuff already linked to the pic and therefore changing it would break all that. But the problem is that almost nothing can link to it because its broken format! And software is tweaked to each release individually anyway.

Bob Bib (bobbib)
description: updated
tags: added: invalid-file-extension
summary: - warty-final-ubuntu.png is actually a jpeg
+ warty-final-ubuntu.png is actually a JPEG file
tags: added: packaging
description: updated
Revision history for this message
Bob Bib (bobbib) wrote :

libunity-2d-private0 package creates a symlink to that picture:
/usr/share/unity-2d/warty-final-ubuntu.jpg

Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

I have proposed a merge to ubuntu-wallpapers that should resolve this long bug which is overdue for a fix.

Changed in ubuntu-wallpapers (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Benjamin Kerensa (bkerensa)
Gerry Boland (gerboland)
Changed in unity-2d:
status: New → Confirmed
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

My merge was put on hold because there were some conflicts which I will go through and fix and resubmit.... This is on my shortlist of bugs to finish by the end of next week.

tags: added: bk
Revision history for this message
Bob Bib (bobbib) wrote :

Is any progress there?..

Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

I have a new merge proposal in that fixes the bug... my last proposal was broken a bit for some odd reason.

Changed in unity-2d:
status: Confirmed → Invalid
Revision history for this message
Bob Bib (bobbib) wrote :

aacid,
look at the comment #28:
libunity-2d-private0 package creates a symlink to that picture:
/usr/share/unity-2d/warty-final-ubuntu.jpg

Changed in unity-2d:
status: Invalid → New
Changed in unity-2d:
status: New → In Progress
assignee: nobody → Pawel Stolowski (stolowski)
Changed in ubuntu-wallpapers (Ubuntu):
assignee: Benjamin Kerensa (bkerensa) → nobody
status: In Progress → New
status: New → Confirmed
Revision history for this message
Laurent Bonnaud (laurent-bonnaud) wrote :

This bug is still there in Ubuntu quantal in this package version:

Package: ubuntu-wallpapers
Version: 0.35.2

description: updated
Pander (pander)
tags: added: graphics quantal raring
Revision history for this message
vgeloven (vgeloven) wrote :

The one in 12.04 is actually better then the one in 12.10. Please have a look at that one.

Bob Bib (bobbib)
tags: added: hardy lucid oneiric precise
tags: removed: hardy
Revision history for this message
Bob Bib (bobbib) wrote :

Why that JPEG picture named "warty-final-ubuntu.png"?
Is it a some sort of nostalgia for Ubuntu 4.10 Warty Warthog?
Shouldn't it be replaced with some more generic name at last?

description: updated
Changed in unity-2d:
assignee: Pawel Stolowski (stolowski) → nobody
Revision history for this message
Pander (pander) wrote :

I agree with Bob. Pehaps name it simply ubuntu.jpg Then links to it will not break with distribution upgrades.

The version of Precise (also called warty-final-ubuntu.png and also a JPEG) in ubuntu-wallpapers-0.34.1 is indeed of higher quality then the one in ubuntu-wallpapers-0.35.2 from Quantal. If you want a copy to improve your Quantal desktop, you can find it directly here http://img29.imageshack.us/img29/6749/wartyfinalubuntu.jpg

Revision history for this message
theghost (theghost) wrote :

Please finally fix this bug its more than 4 years old now.
It's embarrassing that even this simple bug is still not fixed !

Revision history for this message
Սահակ (petrosyan) wrote :

this bug is still present in Ubuntu 13.10

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, EXIF standard

tags: added: saucy
Dario Ruellan (druellan)
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Սահակ (petrosyan) wrote :

this bug has been fixed in Ubuntu 14.10

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: PNG image data, 2560 x 1600, 8-bit/color RGB, non-interlaced

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in unity-2d:
status: In Progress → Fix Released
Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-wallpapers:
status: New → Fix Released
Revision history for this message
Dien (dienopar) wrote :

It is jpeg again in cosmic

$ file /usr/share/backgrounds/warty-final-ubuntu.png
/usr/share/backgrounds/warty-final-ubuntu.png: JPEG image data, Exif standard: [TIFF image data, little-endian, direntries=0], baseline, precision 8, 4096x2304, frames 3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers