[Indicators] regression - Indicator icons don't match the settings they display

Bug #1253804 reported by Ursula Junque on 2013-11-21
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Florian Boucault
ubuntu-ui-toolkit (Ubuntu)
Critical
Florian Boucault
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

In the top bar I have these icons: network (mobile, wifi), bluetooth, location, incoming, battery, sound and clock. When I drop down to access the settings, the only one that shows the correct panel is Network. All the others display settings different than what the icon implies. For example, Bluetooth icon displays Incoming settings, Location displays Bluetooth, Incoming displays Battery, Battery displays Upcoming, Sound displays Location and the Clock displays Sound settings.

I'm using mako, -proposed, r27, read-only.

Related branches

Ursula Junque (ursinha) wrote :
Ursula Junque (ursinha) wrote :
summary: - Indicator icons mismatch the settings they display
+ Indicator icons don't match the settings they display
Ursula Junque (ursinha) on 2013-11-21
tags: added: avengers

Regression since trusty image 10.

tags: added: regression
Changed in unity (Ubuntu):
status: New → Confirmed

Critical as it's a regression.

Changed in unity (Ubuntu):
importance: Undecided → Critical
summary: - Indicator icons don't match the settings they display
+ [regression] Indicator icons don't match the settings they display
Didier Roche (didrocks) on 2013-11-25
affects: unity (Ubuntu) → unity8 (Ubuntu)
Changed in unity8 (Ubuntu):
importance: Critical → Undecided
Changed in unity8 (Ubuntu):
importance: Undecided → Critical
Didier Roche (didrocks) wrote :

Confirmed that with image 28, if we revert from ubuntu-ui-toolkit 0.1.46+14.04.20131118-0ubuntu1 to 0.1.46+14.04.20131105.1-0ubuntu1, everything is then working fine again.

affects: unity8 (Ubuntu) → ubuntu-ui-toolkit (Ubuntu)
affects: unity8 → ubuntu-ui-toolkit
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
assignee: nobody → Florian Boucault (fboucault)
Florian Boucault (fboucault) wrote :

I don't see any commit related to this. Investigating more.

Florian Boucault (fboucault) wrote :

UI Toolkit revision 836 seems to have introduced the regression.

Changed in ubuntu-ui-toolkit:
status: New → In Progress
Florian Boucault (fboucault) wrote :

Reverting 836 is not trivial as 2 other commits are touching the same code since then.

Florian Boucault (fboucault) wrote :

Discrepancy between the 2 models Unity's MenuContent.filteredIndicators and the toolkit's Tabs.tabBar.model:

http://pastebin.ubuntu.com/6475395/

Florian Boucault (fboucault) wrote :

2 bugs are the cause of this:

1) Tabs does not respect the ordering of its children. It always appends new tabs at the end.
2) If the ordering of children changes, Tabs ignores it.

Quick'n'dirty patch fixing that:
http://pastebin.ubuntu.com/6475676/

Florian Boucault (fboucault) wrote :

Fix is ready. Although the overall situation of the Tabs is not good and an important rethink of the API needs to be undertaken.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Florian Boucault (fboucault)
Michał Sawicz (saviq) on 2013-11-26
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Florian Boucault (fboucault) wrote :

Commit actually happened 7 hours ago.

Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2013-11-26
tags: added: needs-ap-tests
tags: added: needs-ap-test
removed: needs-ap-tests
Allan LeSage (allanlesage) wrote :

This is in progress, should help to prevent in future, expect to land by EOW pending some advice and reviews: lp:~allanlesage/unity8/autopilot-indicator-tab-matches-widget .

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.85+14.04.20140410.1-0ubuntu1

---------------
unity8 (7.85+14.04.20140410.1-0ubuntu1) trusty; urgency=medium

  [ Didier Roche ]
  * Resync trunk with previous revert upload

  [ Michał Sawicz ]
  * Set the Qt.ImhNoPredictiveText flag on wifi password field, fixes
    lp:1291575 (LP: #1291575)

  [ Albert Astals ]
  * Take into account the originY when specifying the delegate ranges
    Fixes bug #1300302 (LP: #1300302)

  [ CI bot ]
  * Resync trunk

  [ Allan LeSage ]
  * Swiping open an indicator must show its correct title--protect
    against lp:1253804 . (LP: #1253804)

  [ Alexander Sack ]
  * Fix TypeError: issue seen in system_integration autopilot test on
    image 279. (LP: #1303685)

  [ Bill Filler ]
  * Set the Qt.ImhNoPredictiveText flag on wifi password field, fixes
    lp:1291575 (LP: #1291575)

  [ Leo Arias ]
  * Added a search autopilot helper.

  [ Michael Terry ]
  * Provide a all-in-one script for getting a device to an unlocked
    state.
 -- Ubuntu daily release <email address hidden> Thu, 10 Apr 2014 10:03:31 +0000

Changed in unity8 (Ubuntu):
status: New → Fix Released
John Lea (johnlea) on 2014-04-25
summary: - [regression] Indicator icons don't match the settings they display
+ [Indicators] regression - Indicator icons don't match the settings they
+ display
Ruby Hatem (rh-r) on 2014-06-24
Changed in ubuntu-ux:
assignee: nobody → Ruby Hatem (rh-r)
no longer affects: ubuntu-ux
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers