Broken icon in indicator when iphone attached

Bug #1470080 reported by Alan Pope 🍺🐧🐱 🦄 on 2015-06-30
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-power (Ubuntu)
High
Charles Kerr
ubuntu-themes (Ubuntu)
High
Matthieu James

Bug Description

Running wily with an iPhone 4 (but I doubt it matters which rev of iphone) attached, I see a combined battery gauge for desktop and phone in the indicator. Unfortunately the icon is broken / missing when the phone is attached, like it's missing a small version of the icon you see in system settings -> power.

See screenshot (next to 61%)

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: indicator-power 12.10.6+15.10.20150522-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-22.22-generic 3.19.8-ckt1
Uname: Linux 3.19.0-22-generic x86_64
ApportVersion: 2.17.3-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Jun 30 12:10:40 2015
InstallationDate: Installed on 2014-06-16 (379 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: indicator-power
UpgradeStatus: Upgraded to wily on 2015-05-09 (51 days ago)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu):
status: New → Confirmed
Anthony Wong (anthonywong) wrote :

Happens to me as well with iPhone 5. Please see the screenshot. I am surprised this bug does not have any activities, has this already been resolved?

Anthony Wong (anthonywong) wrote :

I am on 16.04.

Sebastien Bacher (seb128) wrote :

Seems like that upower doesn't have a "state" for that device and upower indicator_power_device_get_icon_names() displays a unknown icon in that case, it looks like it could be better handled ... Charles, any suggestion there? Should devices without a valid icon not be made primary for the indicator? Or maybe it should default to display charging icon, that would be better than unknown one?

Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
Sadi Yumuşak (sa-yu) wrote :

I have the same problem with iPad under Ubuntu 16.04.
IMHO the best solution would be in the first place displaying own power status in the indicator, and the status of any connected device in the menu, which is displayed on that device anyway.

tags: added: rls-x-incoming
Matthew Paul Thomas (mpt) wrote :

Sadi, which device is shown in the menu title is unrelated to this bug, because the same icon is supposed to be shown for the device inside the menu as well. If the problem occurs inside the menu as well, it’s probably a missing or misreferenced icon; if it doesn’t, it’s probably an inconsistency in the indicator code.

(If anyone is wondering how to take a screenshot of the menu: take a whole-screen screenshot with a five-second delay, then open the menu during the delay.)

Sadi Yumuşak (sa-yu) wrote :

Matthew, I don't know, I've just suggested it as a possible workaround or whatever it might be called.

I've reported my problem here: https://bugs.launchpad.net/bugs/1556622 which was marked as duplicate of this bug report, and I can confirm that the problem I've first seen with iPad is the same as iPhone.
The "missing icon" image in the indicator appears only when any such Apple device is being charged.
If it's fully charged it only appears in the power menu, and in both cases - as far as I can see - its menu item simply has no icon instead of a "missing icon" image as can be seen in my screenshot there.

I could even suggest having the same behavior as other devices such as a Kindle or an Android mobile phone, which are not shown anywhere in the power indicator - neithe in the indicator or its menu - as they show their own power status anyway.

Matthew Paul Thomas (mpt) wrote :

Apparently for iPhones, we know what their charge level is, but we don’t know whether they are charging. I didn’t know that was (and don’t understand why it is) a possibility, so I hadn’t considered that case in the design. Specification updated: if we know the charge level, but not that it’s charging, we should use the same icons as when it’s discharging. <https://wiki.ubuntu.com/Power?action=diff&rev2=78&rev1=77>

Separately, we shouldn’t show a device in the menu title when we don’t know whether it’s charging or discharging, if for other things we *do* know whether they’re charging or discharging. <https://wiki.ubuntu.com/Power#Title> So that’s a bug, but fixing it wouldn’t fix the missing icon by itself, just make it less prominent. It would still appear in the title if, for example, you connect an iPhone to a battery-less desktop PC.

Changed in indicator-power (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

the upower dump command out was confusing, the code correctly sees that the device is charging (the dbus service also returns the right value), the issue there is that the device type is phone and that the code tries to display "phone-<level>-charging" icons which we don't have...

Changed in ubuntu-themes (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

ideally we would get phone-charging icons, if we don't unsure what is the next best option, display a standard battery icon for phone? never making phones primary devices?

we have a phone-symbolic icon but it's not looking good in the indicator so that's not really an option

Matthieu James (tiheum) on 2016-05-26
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Matthieu James (tiheum)
Sebastien Bacher (seb128) wrote :

in fact we have gpm-phone-xxx.svg icons in ubuntu-mono, just not -charging versions ...

Charles Kerr (charlesk) wrote :

Yep. In addition to the fixes above, we should also fall back to foo-bar when foo-bar-charging is unavailable.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+16.10.20160708-0ubuntu1

---------------
indicator-power (12.10.6+16.10.20160708-0ubuntu1) yakkety; urgency=medium

  [ Charles Kerr ]
  * Fix bug that chose the wrong header icon if a connected device has a
    charge but its charging/discharging state is unknown. (LP: #1470080)

 -- Antti Kaijanmäki <email address hidden> Fri, 08 Jul 2016 08:00:43 +0000

Changed in indicator-power (Ubuntu):
status: Triaged → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → 13
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Is ubuntu-themes still relevant here?

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers