Cellular Option immediately crashes [OTA-12]

Bug #1607079 reported by Sayonara Player Team on 2016-07-27
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-network (Ubuntu)
High
Antti Kaijanmäki
ofono (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to OTA-12 today, everything seemed to work perfectly. But after rebooting the first time, I was not asked for a SIM PIN number. I had to deactivate/activate the SIM card so I could use the phone again.

Due to the fact that the indicator-network is empty, I tried to activate the 3G connection by using the cellular option in the system settings.

The cellular data option immediately crashes when selecting it.

Edit:
After rebooting a few times and deactivate/activate the SIM card again I could use this option. But I cannot activate/deactivate the cellular data option. My carrier is shown correctly.

Related branches

Sayonara Player Team (lucioc) wrote :
description: updated
ubuntushop (g-info-l) wrote :

did an update of my bq E4.5.Cannot activate cellular data.Provider is shown correctly

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → Alejandro J. Cura (alecu)
Changed in indicator-network (Ubuntu):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → High
milestone: none → 13
Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in ofono (Ubuntu):
status: New → Confirmed
Antti Kaijanmäki (kaijanmaki) wrote :

This is clearly a crash of i-network. I will address this ASAP.

Changed in indicator-network (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
Changed in ofono (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Invalid
renie (rene-duris) wrote :

I can report cellular data not working also on my Bq E5. The mobile data switch is greyed out and could not be used.

fgores (fgores-2) wrote :

Same here on Meizu MX4.

Michael S. (i-mich9el-s) wrote :

Similar #1609055:

I left my office at about 17:30 h and tried to read my email 10 min. later. No mobile data connection was available (see attached log).

Workaround: Go to flight mode and back to normal (non flight mode)

fgores (fgores-2) wrote :

@michael S.: This I had to do very often as well....already before OTA-12! a common issue I experienced many times. The bug now is not able to toggle Mobile data at all...so switching flightmode on/off has no effect.

Michael S. (i-mich9el-s) wrote :

In my case the workaround works.
It is not the whole device ccmni0 blocked - only transmission with a huge number of errors:

/var/log/syslog:
.
Aug 3 17:42:06 ubuntu-phablet kernel: [43904.216292][ccci/net] (1)CCMNI0 TX busy and stop queue: q_idx=32, skb->len=70
Aug 3 17:42:06 ubuntu-phablet kernel: [43904.216326][ccci/net] (1) TX read_out = 0 avai_out = 32 avai_in = 32
Aug 3 17:42:06 ubuntu-phablet kernel: [43904.216352][ccci/net] (1) RX read_out = 0 avai_out = 0 avai_in = 99
.
[Repeating serveral times]
.

Output of ifconfig:

ccmni0 Link encap:Ethernet Hardware Adresse c2:75:ba:b8:fd:3e
          inet Adresse:10.79.248.38 Maske:255.255.255.0
          UP RUNNING NOARP MTU:1500 Metrik:1
          RX-Pakete:21543 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:17009 Fehler:8017 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX-Bytes:15643461 (15.6 MB) TX-Bytes:1860544 (1.8 MB)
.

(massive transmission errors: "Fehler:8017")

Daniel van Vugt (vanvugt) wrote :

Would the fix for this bug also resolve bug 1598010?

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.8.0+16.10.20160804-0ubuntu1

---------------
indicator-network (0.8.0+16.10.20160804-0ubuntu1) yakkety; urgency=medium

  [ Antti Kaijanmäki ]
  * Add qttools5-dev-tools to build dependencies to get qdoc.
  * Fix crash when modem becomes ready before it's SIM. (LP: #1607079)

  [ Stephen M. Webb ]
  * Update the DESKTOP_SESSION string used to identify a Unity 8 session
    on Ubuntu desktop. (LP: #1603453)

 -- Antti Kaijanmäki <email address hidden> Thu, 04 Aug 2016 12:00:04 +0000

Changed in indicator-network (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers