Use default keymap on creation of surface

Bug #1524400 reported by Jonas G. Drange
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
High
Michał Sawicz
Canonical System Image
High
Michał Sawicz
The Avila project
High
Michał Sawicz
qtmir (Ubuntu)
High
Lukáš Tinkl
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange
unity8 (Ubuntu)
High
Lukáš Tinkl

Bug Description

Keymaps should be configurable pr surface or for all surfaces. This bug tracks implementation of the latter.

Determining what keymap to use
Input sources (InputSources) is an array of dicts on the org.freedesktop.Accounts.User interface, which is on the system bus. This holds all the user chosen keymaps. If empty, it indicates en_us. It is on the system bus so that the greeter can determine what keymap to use.

If keymaps > 1, the default keymap for all surfaces will be the first applicable keymap.

Related branches

Gerry Boland (gerboland)
Changed in qtmir (Ubuntu):
status: New → Confirmed
importance: Undecided → High
description: updated
description: updated
description: updated
Michał Sawicz (saviq)
Changed in qtmir (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Bill Filler (bfiller) wrote :

This is needed for HW Keyboard settings panel for convergence

Changed in canonical-devices-system-image:
milestone: none → ww08-2016
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → High
Changed in canonical-pocket-desktop:
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → High
Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
milestone: ww08-2016 → ww04-2016
assignee: kevin gunn (kgunn72) → Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
status: New → Triaged
importance: Undecided → High
Changed in qtmir (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
status: New → Triaged
Changed in canonical-pocket-desktop:
status: New → Triaged
Revision history for this message
Michał Sawicz (saviq) wrote :

Blocked by bug #1530946 atm.

Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Changed in qtmir (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Changed in avila:
status: New → In Progress
assignee: nobody → Michał Sawicz (saviq)
Changed in canonical-pocket-desktop:
status: Triaged → In Progress
assignee: kevin gunn (kgunn72) → Michał Sawicz (saviq)
Changed in ubuntu-system-settings (Ubuntu):
status: New → In Progress
assignee: nobody → Jonas G. Drange (jonas-drange)
Changed in avila:
importance: Undecided → High
Changed in canonical-devices-system-image:
milestone: ww04-2016 → ww08-2016
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
Revision history for this message
Jonas G. Drange (jonas-drange) wrote :

There was a question in bug 1546282, asking how to configure this from the command line. The answer is, AFAIK, that the current value (en/us) is hard coded in Mir. So to change it is not currently possible. If you know what a silo [1] is, you could install 064 which has all the code needed for the layout to be changed.

[1] https://wiki.ubuntu.com/citrain/LandingProcess

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20160323-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20160323-0ubuntu1) xenial; urgency=medium

  [ jonas-drange ]
  * Add External Keyboard panel which allows for configuration of the
    default keymap. (LP: #1524400, #1491340)

 -- Michael Zanetti <email address hidden> Wed, 23 Mar 2016 08:46:55 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.8+16.04.20160322.1-0ubuntu1

---------------
qtmir (0.4.8+16.04.20160322.1-0ubuntu1) xenial; urgency=medium

  [ Nick Dedekind ]
  * Added Application::setStage

  [ Lukáš Tinkl, Michał Sawicz ]
  * Support for switching keyboard layouts (LP: #1524400, #1491340)

  [ Lukáš Tinkl, Michał Sawicz, Nick Dedekind ]
  * Add support for low shell chrome. (LP: #1535397)

 -- Michael Zanetti <email address hidden> Tue, 22 Mar 2016 16:18:06 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.12+16.04.20160323.2-0ubuntu1

---------------
unity8 (8.12+16.04.20160323.2-0ubuntu1) xenial; urgency=medium

  [ Michael Terry ]
  *
  * Fix setting OSK layout in OOBE wizard
  * Stop the left edge tutorial from being shown when the bottom edge
    tutorial wants to be shown after receiving a call.

  [ Albert Astals Cid ]
  * Filter implementation with Option Selector filter as the only filter
  * Get the engine from the parent context
  * Implement the API changes due to filters
  * Match design visuals for the new dash navigation/page header popup
  * New Dash Navigation UX
  * Range Input filter
  * Value slider filter
  * Workaround SDK ListItem bug

  [ Albert Astals Cid, Lukáš Tinkl ]
  * Fix various tests

  [ CI Train Bot ]
  * Resync trunk.
  * Update translation template

  [ Lukáš Tinkl, Michael Terry ]
  * New first-run wizard for the phone (part of the OOBE effort) (LP:
    #1536688, #1536617, #1543790, #1555222)

  [ Lukáš Tinkl, Michał Sawicz ]
  * Keymap switching support (LP: #1524400, #1412492, #1491340)

  [ Michael Terry, Michael Zanetti ]
  * Redesign the first-boot edge tutorial

  [ Michael Zanetti ]
  * disabling some tests that are flaky in adt but can't be made fail on
    our machines

  [ Michael Zanetti, Michał Sawicz ]
  * Change the behavior alond with the switch in indicator-display (LP:
    #1538591)

  [ Michael Zanetti, Michał Sawicz, Nick Dedekind ]
  * Add support for low shell chrome. (LP: #1535397)
  * Sidestage load/unload redesign (LP: #1544479)

 -- Michael Zanetti <email address hidden> Wed, 23 Mar 2016 09:53:17 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-pocket-desktop:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

This bug is still present for the "instant reply" feature of the messaging indicator:
When you receive a message and display it via the system indicator, you can tap the message and instantly type a reply, without having to start up the messaging app. The text box or this instant reply does not use the right keyboard layout when a bluetooth keboard is connected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers