[system-settings] Updates panel does not detect active network conection

Bug #1505663 reported by Pat McGowan on 2015-10-13
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
ubuntu-system-settings (Ubuntu)
High
Ken VanDine

Bug Description

MX4 running latest rc-proposed r136
Settings is an open app
The phone suspends, goes away from wifi
Phone resumes and wifi is connected, cellular data is also available

Go to updates and it says no network detected, retrying does not find the active connection

Stop and reopen the app
Updates are found right away

Related branches

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww46-2015
Changed in canonical-devices-system-image:
status: New → Confirmed
Bill Filler (bfiller) on 2015-10-16
Changed in ubuntu-system-settings (Ubuntu):
assignee: Ken VanDine (ken-vandine) → Jonas G. Drange (jonas-drange)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
assignee: Jonas G. Drange (jonas-drange) → Ken VanDine (ken-vandine)
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2015-10-30
summary: - Does not detect active network conection
+ [system-settings] Updates panel does not detect active network conection
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20151103.1-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20151103.1-0ubuntu1) xenial; urgency=medium

  [ Bartosz Kosiorek ]
  * Remove "Retry" button, when no internet connection is available. It
    will automatically retry after establishing connection (LP:
    #1479447) (LP: #1479447)

  [ Ken VanDine ]
  * Don't elide connect to internet label (LP: #1512768)
  * Ensure we only check for updates when NetworkingStatus.online is
    true (LP: #1505663)
  * [system-settings] Abort request when the onlineStatus changes to
    false (LP: #1505663)

 -- Ken VanDine <email address hidden> Tue, 03 Nov 2015 16:26:31 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers