Dim timeout gsetting key not set anymore

Bug #1503693 reported by Alexandros Frantzis on 2015-10-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
gsettings-qt (Ubuntu)
High
Lars Karlitski
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange

Bug Description

The dim-timeout gsettings key is not set anymore when the activity-timeout key changes, so a default value of 45sec is used for dim-timeout regardless of the activity timeout selected by the user in the batter plugin.

The logic to set the dim timeout value is there in battery/SleepValues.xml in the GSettings onChanged handler, but it seems that the onChanged handler is not called when the activity-timeout value changes.

Not sure if this is a problem in the way ubuntu-system-settings uses the GSettings QML item, or if the item implementation itself is broken somehow.

Related branches

kevin gunn (kgunn72) on 2015-10-07
Changed in canonical-devices-system-image:
milestone: none → ww46-2015
assignee: nobody → Bill Filler (bfiller)
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
status: New → In Progress
Bill Filler (bfiller) on 2015-10-16
Changed in canonical-devices-system-image:
importance: Undecided → High
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Incomplete
Jonas G. Drange (jonas-drange) wrote :

I did this:
1. Build and install gsettings-qt from lp:~unity-team/gsettings-qt/bump-changelog
2. Log on onChanged in GSettings in SleepValues.qml
3. Change the sleep value, I get a log and therefore changed event.
4. Reinstall using sudo apt-get install {libgsettings-qt1,qtdeclarative5-gsettings1.0}=0.1+15.04.20150810-0ubuntu1
5. Do step 2 and 3 without any log.

It seems changing a setting using the GSettings binding does not generate the “changed“, but changing it from the command line does.

Jonas G. Drange (jonas-drange) wrote :

Code which with you can reproduce the issue: http://pastebin.ubuntu.com/12990612/

Lars Karlitski (larsu) wrote :

We've changed the way the changed signal is dispatched due to Qt bug 32859 (tracked as bug #1460970 here), which leads to these signals not being emitted at all anymore when changing a setting from qml.

I've attached a branch that explicitely emits those signals in that case.

Changed in gsettings-qt (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Lars Uebernickel (larsu)
Bill Filler (bfiller) on 2015-10-30
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsettings-qt - 0.1+16.04.20151104-0ubuntu1

---------------
gsettings-qt (0.1+16.04.20151104-0ubuntu1) xenial; urgency=medium

  [ Lars Uebernickel ]
  * qgsettings-qml: explicitly emit changed events (LP: #1503693)

gsettings-qt (0.1+15.04.20150810-0ubuntu1) vivid; urgency=medium

  [ Lukáš Tinkl ]
  * Force handling deferred delete events to avoid memory leaks (LP:
    #1460970)
  * Force handling deferred delete events to avoid memory leaks (LP:
    #1460970)

 -- Sebastien Bacher <email address hidden> Wed, 04 Nov 2015 17:59:13 +0000

Changed in gsettings-qt (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in ubuntu-system-settings (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers