Set default interface font size to 11 for communitheme sessions

Bug #1782190 reported by Frederik Feichtmeier on 2018-07-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-settings (Ubuntu)
Medium
Didier Roche
Bionic
Medium
Didier Roche

Bug Description

[Impact]

 * communitheme snap users see the gnome shell overview window thumbnail labels cutted off

 * 18.04 users can install the communitheme snap from within gnome-software

 * To fix this the default font size of the interface needs to be switched to 11 (again)

[Test Case]

 * Install ubuntu

 * install the communitheme snap

 * reboot

 * select the communitheme snap session and login

 * Open "activities" by clicking "activities" in the GNOME shell's upper left corner or by pressing the super/ubuntu/windows key

 * Each window thumbnail is labeled with a text which is now cut

 * This is caused by a bug in gnome-shell which can't handle any other font size than 11 for any other font beside cantarell

* install the new ubuntu-settings version

* open again activities

* check that window thumbnails aren't cut anymore

[Regression Potential]

 * It's affecting only the communitheme session, not available by default and reverting to the same default than ubuntu main session

[Other Info]

 * Gitlab upstream issue: https://gitlab.gnome.org/GNOME/gnome-shell/issues/378

description: updated
Didier Roche (didrocks) on 2018-07-18
Changed in ubuntu-settings (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in ubuntu-settings (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)
Changed in ubuntu-settings (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-settings (Ubuntu Bionic):
importance: Undecided → High
importance: High → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-settings (Ubuntu Bionic):
status: New → Confirmed
Changed in ubuntu-settings (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The fix was uploaded to cosmic (failing to build on a meson issue) and bionic (waiting for review)

Changed in ubuntu-settings (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-settings (Ubuntu Bionic):
status: Confirmed → Fix Committed

Hello Frederik, or anyone else affected,

Accepted ubuntu-settings into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-settings/18.04.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 18.10.1

---------------
ubuntu-settings (18.10.1) cosmic; urgency=medium

  [ Iain Lane ]
  * Work around meson bug #3914 by creating the symlink in packaging instead
    of using the upstream build system. This change should be reverted once
    that bug is fixed.

  [ Didier Roche ]
  * Set Suru theme and settings as default. (LP: #1783571)

 -- Iain Lane <email address hidden> Fri, 17 Aug 2018 12:39:12 +0100

Changed in ubuntu-settings (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) wrote :

I installed it on bionic and confirmed that on a default configuration, the new settings is taken.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 18.04.6

---------------
ubuntu-settings (18.04.6) bionic; urgency=medium

  * debian/ubuntu-settings.gsettings-override:
    - revert in communitheme session default font size to 11, as it creates
      rendering issues in GNOME Shell (LP: #1782190)
  * debian/control:
    - convert and change Vcs-* to git
  * debian/gbp.conf:
    - set to track Bionic

 -- Didier Roche <email address hidden> Wed, 18 Jul 2018 17:04:18 +0200

Changed in ubuntu-settings (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers