Comment 7 for bug 1511875

Jon Brase (jonathan-brase) wrote :

I'm running into the same thing trying to upgrade from 14.04 to 16.04.

After Googling around about the issue, this link at first looked like a promising lead, as I'm running into this on Haswell hardware and I have Core2 hardware that was unaffected:

https://groups.google.com/forum/#!topic/mechanical-sympathy/QbmpZxp6C64

So I tried using a custom-compiled 4.4 series kernel to see if that resolved the issue, and it does cause the upgrade to stop hanging in the futex wait channel, but, unfortunately, does not cause the upgrade to stop hanging. On the 4.4 kernel, system monitor shows the process to be in waiting channel 0 instead of the futex wait channel, but gdb shows the process to be hung in "sem_wait()".

I am running into this on bare hardware, not a container or VM.

Given that I'm seeing it on a Haswell machine but my Core2 laptop did not experience the hang, and given that using a newer kernel version changed the specifics of how the hang is occuring, it seems to be related to the kernel bug discussed at the Google Groups link above, but the kernel bug can't be the whole story, or else the new kernel would have fixed it.