Cannot upgrade to 14.04 due to grep:i386

Bug #1307904 reported by Roberto Celeste on 2014-04-15
40
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Michael Vogt
Trusty
High
Unassigned

Bug Description

SRU instructions:
1. use saucy (minimal install is fine)
2. sudo apt-get install grep:i386
3. do-release-upgrade -d
4. verify that it fails with a error message that the upgrade can not be calculated

6. do-release-upgrade --proposed
7. verify that the upgrade works and that it removes grep:i386 and installs grep:amd64

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-release-upgrader-core 1:0.205.5
ProcVersionSignature: Ubuntu 3.11.0-19.33-generic 3.11.10.5
Uname: Linux 3.11.0-19-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
CrashDB: ubuntu
Date: Tue Apr 15 10:14:24 2014
InstallationDate: Installed on 2013-11-27 (138 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to saucy on 2014-04-15 (0 days ago)

Roberto Celeste (r0bby) wrote :
Jean-Baptiste Lallement (jibel) wrote :

The upgrade is rejected because:
2014-04-15 10:10:47,946 DEBUG The package 'grep:i386' is marked for removal but it's an ESSENTIAL package
2014-04-15 10:10:48,002 ERROR Dist-upgrade failed: 'The essential package 'grep:i386' is marked for removal.'

which is due to:
  MarkInstall grep [ amd64 ] < none -> 2.16-1 > ( utils ) FU=1
   Removing: grep
    MarkDelete grep [ i386 ] < 2.14-3 -> 2.16-1 > ( utils ) FU=0

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

Thanks Jean-Baptiste for the analysis of the issue. This is indeed a bug in the release-upgrader.

@roberto: as a workaround you can run "sudo apt-get install grep:amd64" and then re-run the upgrade again.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Medium → Undecided
status: In Progress → Fix Committed
description: updated
Changed in ubuntu-release-upgrader (Ubuntu):
milestone: none → trusty-updates
Roberto Celeste (r0bby) wrote :

Many thanks, it seems that installing gerp:amd64 the error is not present . I'll give a try later . Thank you

Michael Vogt (mvo) wrote :

Hello Roberto - in your comment is a typo "gerp:amd64" should be "grep:amd64"

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
Roberto Celeste (r0bby) wrote :

Hello Michael , thanks for the note ... some years ago i made a "gerp" alias in my shell cfg file ... :)

Roberto Celeste (r0bby) wrote :

Anyway i tried your solution and it worked perfectly . After installing grep:amd64 i could upgrade to 14.04!

Michael Vogt (mvo) wrote :

@Roberto: Thanks, great to hear that it works now.

summary: - Cannot upgrade to 14.04
+ Cannot upgrade to 14.04 due to grep:i386
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
milestone: none → trusty-updates
importance: Undecided → High
status: New → Fix Committed
Changed in ubuntu-release-upgrader (Ubuntu):
milestone: trusty-updates → none

Hello Roberto, or anyone else affected,

Accepted ubuntu-release-upgrader into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:0.220.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:14.10.2

---------------
ubuntu-release-upgrader (1:14.10.2) utopic; urgency=low

  * debian/test/control:
    - add missing pep8 test dependency
  * tests/test_xorg_fix_intrepid.py:
    -
 -- Michael Vogt <email address hidden> Sat, 03 May 2014 08:37:51 +0200

Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

I've verified that the version of ubuntu-release-upgrader in trusty-proposed could properly calculate the upgrade from saucy to trusty when grep:i386 was installed.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

Hello Roberto, or anyone else affected,

Accepted ubuntu-release-upgrader into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:0.220.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.220.4

---------------
ubuntu-release-upgrader (1:0.220.4) trusty-proposed; urgency=low

  * DistUpgrade/DistUpgradeCache.py:
    - fix crash in free space check for certain locales (LP: #1172740)
    - removal of essential packages that are not in the main arch
      is ok (LP: #1307904)
    - fix str/unicode crash in certain locales when a package is
      found in the removal blacklist (LP: #1310053)
  * DistUpgrade/DistUpgradeViewGtk3.py:
   - make details dialog resize when details are expanded/collapsed
     (LP: #1072460)
    - load webkit only when needed
  * DistUpgrade/DistUpgradeViewText.py:
    - fix py3 crash in text mode
  * DistUpgrade/DistUpgradeMain.py:
    - log python version
  * po/{eo,id,ug}.po:
    - fix translations of check-new-release-gtk which cause a crash
      (LP: #1311396)
  * data/demoted.cfg:
    - autmatic refresh of the demoted packages
  * po/*.po:
    - automatic refresh from launchpad
 -- Michael Vogt <email address hidden> Thu, 24 Apr 2014 14:57:39 +0200

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers