Comment 6 for bug 1304403

This log, taken from a manual dist-upgrade in a precise schroot with postgresql-server-dev-9.1 installed, has some more info:

Investigating (0) libkdb5-7 [ amd64 ] < none -> 1.12+dfsg-2ubuntu2 > ( libs )
Broken libkdb5-7:amd64 Breaks on libkadm5srv-mit8 [ amd64 ] < 1.10+dfsg~beta1-2ubuntu0.3 > ( libs ) (< 1.11+dfsg~)
  Considering libkadm5srv-mit8:amd64 1 as a solution to libkdb5-7:amd64 0
  Holding Back libkdb5-7:amd64 rather than change libkadm5srv-mit8:amd64
Investigating (1) libkadm5srv-mit9 [ amd64 ] < none -> 1.12+dfsg-2ubuntu2 > ( libs )
Broken libkadm5srv-mit9:amd64 Depends on libkdb5-7 [ amd64 ] < none -> 1.12+dfsg-2ubuntu2 > ( libs )
  Considering libkdb5-7:amd64 0 as a solution to libkadm5srv-mit9:amd64 2
  Holding Back libkadm5srv-mit9:amd64 rather than change libkdb5-7:amd64
Investigating (2) krb5-multidev [ amd64 ] < 1.10+dfsg~beta1-2ubuntu0.3 -> 1.12+dfsg-2ubuntu2 > ( libdevel )
Broken krb5-multidev:amd64 Depends on libkadm5srv-mit9 [ amd64 ] < none -> 1.12+dfsg-2ubuntu2 > ( libs ) (= 1.12+dfsg-2ubuntu2)
  Considering libkadm5srv-mit9:amd64 2 as a solution to krb5-multidev:amd64 4
  Removing krb5-multidev:amd64 rather than change libkadm5srv-mit9:amd64
Investigating (2) libpq-dev [ amd64 ] < 9.1.13-0ubuntu0.12.04 -> 9.3.4-1 > ( libdevel )
Broken libpq-dev:amd64 Depends on krb5-multidev [ amd64 ] < 1.10+dfsg~beta1-2ubuntu0.3 -> 1.12+dfsg-2ubuntu2 > ( libdevel )
  Considering krb5-multidev:amd64 4 as a solution to libpq-dev:amd64 2
  Removing libpq-dev:amd64 rather than change krb5-multidev:amd64
Investigating (2) libkrb5-dev [ amd64 ] < 1.10+dfsg~beta1-2ubuntu0.3 -> 1.12+dfsg-2ubuntu2 > ( libdevel )
Broken libkrb5-dev:amd64 Depends on krb5-multidev [ amd64 ] < 1.10+dfsg~beta1-2ubuntu0.3 -> 1.12+dfsg-2ubuntu2 > ( libdevel ) (= 1.12+dfsg-2ubuntu2)
  Considering krb5-multidev:amd64 4 as a solution to libkrb5-dev:amd64 -1
  Removing libkrb5-dev:amd64 rather than change krb5-multidev:amd64
Investigating (2) postgresql-server-dev-9.1 [ amd64 ] < 9.1.13-0ubuntu0.12.04 > ( libdevel )
Broken postgresql-server-dev-9.1:amd64 Depends on libpq-dev [ amd64 ] < 9.1.13-0ubuntu0.12.04 -> 9.3.4-1 > ( libdevel ) (>= 9.1~)
  Considering libpq-dev:amd64 4 as a solution to postgresql-server-dev-9.1:amd64 -1
  Removing postgresql-server-dev-9.1:amd64 rather than change libpq-dev:amd64
Done
The following packages will be REMOVED:
  krb5-multidev libkrb5-dev libpq-dev postgresql-server-dev-9.1