prompt to restart services in text mode during an upgrade in graphic mode

Bug #1298281 reported by Jean-Baptiste Lallement on 2014-03-27
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Michael Vogt
Trusty
High
Michael Vogt

Bug Description

Fresh install of Precise Desktop + updates upgraded to Trusty with "update-manager -d"

During upgrade the console window opens with a prompt from debconf to restart services that depends on libc6 (see screenshot)

1. It must be a graphical prompt
2. There should be no prompt

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Jean-Baptiste Lallement (jibel) wrote :

upgrade logs

Jean-Baptiste Lallement (jibel) wrote :

From apt-term.log:

Preparing to replace libc6 2.15-0ubuntu10.5 (using .../libc6_2.19-0ubuntu3_amd64.deb) ...
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gtk -- is libgtk2-perl installed?)
debconf: falling back to frontend: Dialog

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1298281

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

While it should be a graphical dialog if it does appear, I don't think it should appear at all. See bug 1105137.

Brian Murray (brian-murray) wrote :

It looks like there is something awry in start_update() in DistUpgradeViewGtk3.py.

Brian Murray (brian-murray) wrote :

Actually, that's right and DEBIAN_FRONTEND=gnome is appended to self.env.

Brian Murray (brian-murray) wrote :

It looks like gtk has ended up in a broken state given the error messages after the attempting to open the dialog:

debconf: unable to initialize frontend: Gnome^M
debconf: (Unable to load Gtk -- is libgtk2-perl installed?)^M
debconf: falling back to frontend: Dialog^M
Processing triggers for hicolor-icon-theme ...^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.32.4/./gobject/gtype.c:2722: You forgot to call g_type_init()^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.32.4/./gobject/gtype.c:2722: You forgot to call g_type_init()^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed^M
^M
(gtk-update-icon-cache-3.0:6517): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed^M
Segmentation fault (core dumped)^M

Did you happen to catch the core dump?

Brian Murray (brian-murray) wrote :

I tested upgrading from Precise to Trusty again and observed a Segmentation fault error message in my /var/log/dist-upgade/apt-term.log file but could find no apport crash report.

Brian Murray (brian-murray) wrote :

I spoke too soon, there is a gtk-update-icon-cache crash in /var/crash. I'm not convinced this is the cause of the gnome frontend not being used.

I saw this crash too, but it is unrelated. Instead it could be because newest version of libgtk2-perl and its dependencies are not all installed on the system.
From apt-term.log, we can see that libgdk-pixbuf2.0-0 is already unpacked but libgtk2-perl itself and its other dependencies are still at previous version. So when the gnome frontend is called by the trigger libgtk2-perl cannot be loaded.

""""
[...]
Preparing to replace libgdk-pixbuf2.0-common 2.26.1-1 (using .../libgdk-pixbuf2.0-common_2.30.6-1_all.deb) ...
Unpacking replacement libgdk-pixbuf2.0-common ...
[...]
Unpacking replacement libgdk-pixbuf2.0-0 ...
[...]
Unpacking replacement liblzma5 ...
Processing triggers for fontconfig ...
Processing triggers for libglib2.0-0 ...
Processing triggers for gconf2 ...
Processing triggers for man-db ...
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gtk -- is libgtk2-perl installed?)
""""

tags: removed: rls-t-incoming
Michael Vogt (mvo) on 2014-04-07
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

This diff should fix the prompt on the upgrade.

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
assignee: nobody → Michael Vogt (mvo)

I tried an upgrade from Precise Desktop amd64 to Trusty with the PPA enabled (eglibc 2.19-0ubuntu4) and the result is the same: Prompt in text mode.

I confirm it is fixed and I didn't see any prompt during an upgrade from Precise Deskop AMD64 to Trusty with 2.19-0ubuntu4.1 from mvo's PPA

tags: added: patch
Brian Murray (brian-murray) wrote :

This didn't get auto-fixed because the task is about ubuntu-release-upgrader.

eglibc (2.19-0ubuntu4) trusty; urgency=low

  * debian/debhelper.in/libc.preinst:
    - do not show glibc/restart-services question when the system
      is uprading via the desktop session (LP: #1298281)
 -- Michael Vogt <email address hidden>

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers