Change Korean font at ubuntu-desktop

Bug #836430 reported by Jinkyu Yi on 2011-08-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ttf-nanum (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

"ubuntu-desktop" package's dependency suggest ttf-unfonts-core as Korean fonts.
But at 2008, new free Korean font, Nanum came with OFL license(free license).
And, Nanum family fonts are having much better quility than Un family's.
As the result, Mac OS 10.7(codename Lion) and ChromeOS decide to include Nanum fonts.
So, I strongly suggest to use ttf-nanum instead of ttf-unfonts-core.

Jinkyu Yi (jincreator) wrote :
Jinkyu Yi (jincreator) wrote :
Jinkyu Yi (jincreator) wrote :

Oops! Don't use debdiff at #2!
Actually it's not a problem.
Just add ':' at commit message(LP #836430 -> LP: #836430) :)

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Thanks for your patch! I can't merge this right now because it is IMO too late in the Oneiric release cycle to be changing the default set of installed packages in any significant way. However, I can offer some advice on getting this merged for the P cycle.

 * ttf-nanum is in universe, and will need to be promoted to main in order to be installed by default. I've created a task against that package. Please see https://wiki.ubuntu.com/MainInclusionProcess for what needs to be done next.
 * This is not how we maintain ubuntu-meta. The files you're patching are actually generated automatically, and you need to edit the source for them instead, which is: lp:~ubuntu-core-dev/ubuntu-seeds/ubuntu.oneiric
 * I suggest having a brief conversation on <email address hidden> about this, in order to give other Korean speakers an opportunity to give feedback.

Colin Watson (cjwatson) wrote :

I'm unsubscribing ubuntu-sponsors for the time being based on the above feedback, but this is not a rejection; please do resubscribe us at the start of the P cycle when you've done the above. Thanks again!

Jinkyu Yi (jincreator) wrote :

Oh, I didn't know about MIR.
Now I open LP: #846353(whether it can be go in Oneiric or not).
Colin, thank you for your advice!

tags: added: patch
Martin Pitt (pitti) wrote :
Changed in ttf-nanum (Ubuntu):
status: New → Invalid
Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Incomplete
Martin Pitt (pitti) on 2011-10-26
Changed in ubuntu-meta (Ubuntu):
status: Incomplete → Fix Committed
Martin Pitt (pitti) on 2012-02-23
Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers